
DirectRoute User Guide​ ​ 26.1 

 

DirectRoute User Guide (v26.1)

 



DirectRoute User Guide​ ​ 26.1 

 

Table of Contents 

Table of Contents.....................................................................................................................................................2 
Introduction.............................................................................................................................................................. 7 
DirectRoute installation.............................................................................................................................................. 7 

DirectRoute Updates.....................................................................................................................................8 
System Requirements................................................................................................................................................8 
1. DirectRoute Components....................................................................................................................................9 
1.1. DirectRoute Menu............................................................................................................................................... 9 

1.1.1. File Menu............................................................................................................................................ 9 
1.1.2. Edit Menu.......................................................................................................................................... 11 
1.1.3. ResourcePro Menu........................................................................................................................... 12 
1.1.4. Analysis Menu...................................................................................................................................12 
1.1.5. DRTrack Menu.................................................................................................................................. 12 
1.1.6. Window Menu................................................................................................................................... 13 
1.1.7. Help Menu.........................................................................................................................................15 

1.2. Map Menu and Map Tools.................................................................................................................................16 
1.2.1. Default Map.......................................................................................................................................17 
1.2.2. Point Field Displayed........................................................................................................................ 19 
1.2.3. Map Tools..........................................................................................................................................19 
1.2.4. Zoom.................................................................................................................................................19 
1.2.5. Additional Assorted Map Features....................................................................................................23 

1.3. Map Symbols and Color Chart..........................................................................................................................23 
1.3.1. Color Chart........................................................................................................................................24 
1.3.2. Display/Edit Stop Info on the Map.....................................................................................................25 

1.4. Toolbar and Icons..............................................................................................................................................26 
1.5. Mouse Pointer Symbols.................................................................................................................................... 28 
2. Routing Overview.............................................................................................................................................. 29 
2.1. Routing Data..................................................................................................................................................... 30 
2.2. Types of Routes................................................................................................................................................ 30 
2.3. Routing Preferences......................................................................................................................................... 31 

2.3.1. Routing Preferences and Options Table........................................................................................... 33 
2.3.2. Lambda and Lambda Values............................................................................................................ 55 
2.3.3. Box Expand and Box Expand Values............................................................................................... 57 

3. Route Files..........................................................................................................................................................58 
3.1. Creating Route Files......................................................................................................................................... 58 
3.2. The Stop File.....................................................................................................................................................58 

3.2.1. Create a New Stop File.....................................................................................................................59 
3.2.2. Stop File Fields and Descriptions Table............................................................................................60 
3.2.3. Time Windows...................................................................................................................................67 

Time Window Gap Buffer......................................................................................................................67 
3.3. Account Master File.......................................................................................................................................... 68 

3.3.1. Import/Extract an Account Master.....................................................................................................69 
3.3.2. Extract a Daily Order File..................................................................................................................70 
3.3.3. Extract to Create a New Stop File.....................................................................................................70 

3.4. Truck File.......................................................................................................................................................... 72 

©2026 Trimble Maps​ 2​ ​  Mar -26 



DirectRoute User Guide​ ​ 26.1 

 
3.4.1. Create a New Truck File................................................................................................................... 72 
3.4.2. Truck File Fields and Descriptions Table.......................................................................................... 74 

3.5. Distance File..................................................................................................................................................... 79 
3.5.1. Get Distance Entries from Database (Db)........................................................................................ 80 
3.5.2. Distance File Settings Table..............................................................................................................80 
3.5.3. Generate a Distance File.................................................................................................................. 83 
3.5.4. Use Ultrafast Distance Matrix........................................................................................................... 84 
3.5.5. Add New Entries to a Distance File.................................................................................................. 87 
3.5.6. View, Edit, Save, or Export a Distance File.......................................................................................88 

4. Geocoding Records...........................................................................................................................................88 
4.1. Address Cleanup.............................................................................................................................................. 89 
4.2. Geocode Options.............................................................................................................................................. 91 

4.2.1. Geocode by Address........................................................................................................................ 92 
4.3. Geocode Results.............................................................................................................................................. 94 

4.3.1. Validate Coordinates.........................................................................................................................95 
4.4. Custom Geocode File....................................................................................................................................... 96 

4.4.1. Creating a Custom Geocode File......................................................................................................96 
4.4.2. Preparations for Using Custom Geocode File.................................................................................. 97 

4.5. Geocoding with Google Maps API....................................................................................................................97 
4.5.1. Create a Google Maps API Key........................................................................................................97 
4.5.2. Google Geocode Settings.................................................................................................................98 
4.5.3. Google Geocoding Results............................................................................................................... 99 

4.6. Geocoding with PC*Miler Web Services.........................................................................................................100 
5. Building Routes............................................................................................................................................... 101 
5.1. Create a New Route....................................................................................................................................... 101 
5.2. Inbound Routes...............................................................................................................................................102 

5.2.1. Set up Inbound Routes................................................................................................................... 102 
5.3. Manual Route Building Tool............................................................................................................................ 102 
5.4. Optimization Options.......................................................................................................................................103 

5.4.1. Optimize Trucks After Loading........................................................................................................104 
5.4.2. Optimize Stops After Loading......................................................................................................... 104 
5.4.3. Optimize Within Routes.................................................................................................................. 104 
5.4.4. Optimize Between Routes.............................................................................................................. 105 

5.4.5. Box Expand and Values........................................................................................................... 107 
5.5. Priority Routing Tool........................................................................................................................................108 

5.5.1. Priority Route File Selection............................................................................................................109 
5.5.2. Import Records From DRTrack....................................................................................................... 109 
5.5.3. Preview Selected Stop Records......................................................................................................110 

5.6. New Routes with Priority Routing....................................................................................................................111 
5.7. Priority Routing Results...................................................................................................................................112 

Unloaded Stops.........................................................................................................................................112 
Statistics....................................................................................................................................................112 

5.8. Selective Routing Tool.....................................................................................................................................113 
5.8.1. Selective Route File Selection........................................................................................................ 115 
5.8.2. Selecting Stops............................................................................................................................... 116 
5.8.3. Loading Trucks................................................................................................................................119 

©2026 Trimble Maps​ 3​ ​  Mar -26 



DirectRoute User Guide​ ​ 26.1 

 
5.8.4. Using the Lasso to Select Stops..................................................................................................... 120 
5.8.5. Selective Routing Results............................................................................................................... 120 

5.9. Apply Minimum Time Between Stops After Directions....................................................................................121 
6.  Speed Adjustments........................................................................................................................................ 122 
6.1  Speed Adjustments at Project-level................................................................................................................123 
6.2  Speed Adjustments for Stop / Truck File........................................................................................................ 123 
7. The Route Book............................................................................................................................................... 124 
7.1. Route Book Tools............................................................................................................................................125 

7.1.1. Show Gauges................................................................................................................................. 126 
7.1.2. Show or Hide Details, Directions.................................................................................................... 126 

7.2. Route Book Reports........................................................................................................................................127 
7.2.1. Summary Report.............................................................................................................................127 
7.2.2. Detail Report................................................................................................................................... 128 
7.2.3. Header Report................................................................................................................................ 128 
7.2.4. Miles by State Report......................................................................................................................129 
7.2.5. Solution Statistics............................................................................................................................130 

7.3. Customizing Reports.......................................................................................................................................131 
7.3.1. Header Report Customization.........................................................................................................131 
7.3.2. Multiple Report Formats..................................................................................................................132 

7.4. Route Book Info Boxes................................................................................................................................... 132 
7.5. Selecting Records for Display and Edit...........................................................................................................135 
7.6. View Route Violations..................................................................................................................................... 135 
7.7. Generate Directions........................................................................................................................................ 136 

7.7.1. Driving Directions Options.............................................................................................................. 137 
7.7.2. PC*Miler Direct Driving Directions Options.....................................................................................138 

8. Route Modifications.........................................................................................................................................139 
8.1. Route Book Modify Menu...................................................................................................................139 
8.1.1. Undo/Redo......................................................................................................................................140 
8.1.2. Optimize Routes............................................................................................................................. 140 
8.1.3. Add, Delete, Move Stops................................................................................................................ 141 
8.1.4. Reload or Load Unloaded Stops.....................................................................................................142 
8.1.5. Edit Leg/Invert Route...................................................................................................................... 143 
8.1.6. Lock Routes.................................................................................................................................... 143 
8.1.7. Switch Routes/Trucks, Set Route Start Time..................................................................................145 

8.2. Change Stop Sequence..................................................................................................................................146 
8.3. Add Stops from the Map................................................................................................................................. 147 
8.4. Working with Unloaded Stops.........................................................................................................................147 

8.4.1. Sort Unloaded Stops.......................................................................................................................148 
8.4.2. Sort from the View Reason Dialog Box...........................................................................................149 
8.4.3. Load Unloaded Stops..................................................................................................................... 149 

8.5. Scenario Manager...........................................................................................................................................150 
8.5.1. Using Scenario Manager................................................................................................................ 150 
8.5.2. Scenario Manager Time Windows/Buffers......................................................................................151 
8.5.3. Scenario Manager Results..............................................................................................................152 

8.6  Cross Dock vs DC.........................................................................................................................................153 
8.6.1 Use Cross Dock Tool....................................................................................................................... 154 

©2026 Trimble Maps​ 4​ ​  Mar -26 



DirectRoute User Guide​ ​ 26.1 

 
8.6.2 Cross Dock Statistics....................................................................................................................... 156 

9. Advanced Routing........................................................................................................................................... 156 
9.1. Special Equipment Codes...............................................................................................................................156 

9.1.1. Equipment Codes (Eq)....................................................................................................................157 
9.1.2. Back Hauls (BH)............................................................................................................................. 158 
9.1.3. Priority Codes................................................................................................................................. 158 
9.1.4. Sequence Codes............................................................................................................................ 159 
9.1.5. Sequence Preference Code............................................................................................................160 
9.1.6. Territory Codes................................................................................................................................160 
9.1.7. Exclusion Codes............................................................................................................................. 161 
9.1.8. Inclusion Codes.............................................................................................................................. 161 
9.1.9. Origin-Destination Pairs.................................................................................................................. 161 

9.2. Consolidating Stops........................................................................................................................................ 162 
9.2.1. Consolidate by ID1/ID2................................................................................................................... 163 
9.2.2. Consolidate by Address.................................................................................................................. 163 

9.3. Redispatch...................................................................................................................................................... 164 
9.4. Splitting Stops................................................................................................................................................. 164 

9.4.1. Dynamic Splitting............................................................................................................................ 165 
9.4.2. Stops That Should Not Be Split...................................................................................................... 166 

9.5. Using the Lasso Tool.......................................................................................................................................167 
9.6. Build Manual Routes on the Map....................................................................................................................168 
9.7. Move, Delete, or Add Stops............................................................................................................................ 169 
9.8. Inbound Routes...............................................................................................................................................170 
9.9. Routing Dense Stops...................................................................................................................................... 170 
9.10. Relay Routes................................................................................................................................................ 171 

9.10.1. Creating a Relay Route.................................................................................................................171 
9.10.2. Relay by Destination..................................................................................................................... 172 
9.10.3. Relay by Truck.............................................................................................................................. 172 

9.11. Tanker Assignments......................................................................................................................................173 
9.11.1. Tanker Algorithm Settings............................................................................................................. 173 
9.11.2. Product Ratio File..........................................................................................................................175 
9.11.3. Tote File.........................................................................................................................................176 
9.11.4. Tanker Route Results....................................................................................................................177 

9.12. External Utilities (Merge Utility).....................................................................................................................178 
9.12.1. Using the Merge Utility..................................................................................................................178 

10. Drawings and Boundaries.............................................................................................................................179 
10.1. Draw Directly on a Map.................................................................................................................................179 
10.2. Open a Drawing File..................................................................................................................................... 179 
10.3. Text Tool........................................................................................................................................................180 
10.4. Line Tools......................................................................................................................................................180 

10.4.1. Polyline Tool..................................................................................................................................181 
10.4.2. Line Tool........................................................................................................................................181 
10.4.3. Arrow Tool..................................................................................................................................... 181 

10.5. Boundary Tools............................................................................................................................................. 182 
10.6. Polygon......................................................................................................................................................... 182 

10.6.1. Circle Tool..................................................................................................................................... 183 

©2026 Trimble Maps​ 5​ ​  Mar -26 



DirectRoute User Guide​ ​ 26.1 

 
10.6.2. Rectangle Tool.............................................................................................................................. 183 
10.6.3. Lock Tool.......................................................................................................................................184 
10.6.4. Hide Labels................................................................................................................................... 184 

10.7. Using Boundaries..........................................................................................................................................184 
10.7.1. Overlay Template.......................................................................................................................... 184 
10.7.2. Statistics Inside a Boundary..........................................................................................................185 

10.8. Build to Value................................................................................................................................................ 186 
11. Exporting Route Info To ERP/WMS/OMS..................................................................................................... 187 
11.1. Export with Web Services............................................................................................................................. 187 
11.2. Export an XML or Upload (UPL) File.............................................................................................................189 

11.2.1. Create an XML Upload File...........................................................................................................192 
11.2.2. Create a URP Format File.............................................................................................................194 
11.2.3. Create a UPL Upload File............................................................................................................. 195 
11.2.4. URP Field Names Table................................................................................................................197 

12. Custom Road Edits........................................................................................................................................210 
13. DirectRoute Use Cases................................................................................................................................. 210 
Should your fleet deliver an order or hire someone else to deliver it?...................................................................210 
Appendix A: DOT Hours of Service....................................................................................................................214 
Appendix B: Working With Spreadsheets......................................................................................................... 215 
Appendix C: Printing From DirectRoute............................................................................................................219 

 

©2026 Trimble Maps​ 6​ ​  Mar -26 



DirectRoute User Guide​ ​ 26.1 

 

Introduction 
DirectRoute is an automated fleet routing program with intuitive design, powerful mapping insight and 
drag-and-drop functionality. DirectRoute easily interfaces with most existing accounting or ERP software and 
allows the user to build fixed or dynamic daily routes. Capabilities include single or multi-day routes, one-way 
deliveries or backhaul rn-by-turn driving directions, and more. 
 
This file serves as a reference to help with the necessary steps involved in building optimal routes and the more 
common processes involved. While working in the DirectRoute program, the DirectRoute User Guide Help File 
can be accessed using the F1 key or select Help > Contents from the DirectRoute menu. For assistance, contact 
Trimble MAPS Support, support@trimblemaps.com, US (toll free): phone 1-800-663-0626, Monday-Friday, 
7am-5pm CST. 

 
DirectRoute installation 
For local machine installation, the DirectRoute install files, and any subsequent update files, are generally 
downloaded by licensed users from the Trimble ClientCenter.  
 
In addition to DirectRoute, licensing and access for additional Appian software modules (if purchased) will be 
included in the installation download. If the user system or network prevents the download and/or installation, a 
request should be made to provide an alternate installation method. Alternate methods may include mailing a 
copy of the installation (certified, registered mail) or onsite installation by an assigned Appian Implementation and 
Training Consultant.  
 
Each licensed customer (primary contact) will receive an email with specific instructions on how to access the 
download, installation instructions, and the product code/license number.  
 
It is important to note that the install cannot be done remotely, and one must have administrative rights on the 
machine to perform the DirectRoute installation.  
 
The download file generally includes the DirectRoute program and component files, including:  

•​ .NET 4.5 
•​ Crystal reports  
•​ PC*Miler embedded Map/Mileage System 
•​ Address Cleanup File 
•​ Zip9 Data File 
•​ Help File 
•​ ResourcePro Module* 
•​ SchedulePro Module* 
•​ TerritoryPro Module* 
•​ Transportation Modeler Module* 

 

Note: *Additional Appian software modules, if licensed for use. 

 
Assistance during the download and/or installation is available, if needed, by contacting Trimble MAPS Support, 
support@trimblemaps.com, Phone: (800) 663-0626. 
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DirectRoute Updates 
DirectRoute software updates, or releases, are issued to update or add/delete new, improved, or corrected 
features and functions. These updates usually occur a few times each year.  
 
When updates are released, customers will be notified via email with a brief description of what is included in the 
updated release and instructions on how to retrieve and install the update. Each release update will also include 
an updated Help File. 
 

System Requirements 
System requirements may vary depending on which software modules have been licensed for use, the number of 
licensed users, and the types of operating systems being used.  
 
The following table lists the standard requirements for operating DirectRoute from various platforms. Separate 
requirements are listed for PC standalone connections and server connections. 
 

PC Standalone System 

 Min Requirements Recommended 

OS Windows 11 / Windows Server 2022 Windows 11 / Windows Server 2022 

Processor 4 cores 4+ cores 

Memory 8 GB 16+ GB 

Hard Disk 125 GB 250 GB 

User Permissions Full control of DirectRoute folder, subfolder, 
and data directory (if not in the subfolder) 

Full control of DirectRoute folder, subfolder, 
and data directory (if not in the subfolder) 

Internet Access Required on startup and periodically 

 

Server 

 1–5 Users 6–15 Users 16+ Users 

OS Windows 2016 Server w/MS 
.NET 4.5/ newer 

Windows 2016 Server w/MS 
.NET 4.5/ newer 

Windows 2016 Server w/MS 
.NET 4.5/ newer 

Processor Quad core 2.8 GHz or higher Quad Core 2.8 GHz or higher Quad Core 2.8 GHz or higher 

Memory 4 GB 8 GB+ 16 GB+ 

Hard Disk 80 GB 160 GB+ 220 GB+ 

Network 
Card 

1 GB dedicated NIC for 
Terminal Services 

1 GB dedicated NIC for 
Terminal Services 

1 GB+ dedicated NIC for 
Terminal Services 

Figure 1–Systems Requirements Table 
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1.​ DirectRoute Components 
This section will help to familiarize you with the basic components of DirectRoute, including window tabs, map 
functions, customizations, menus and toolbars, and mouse pointers.  
 

1.1.​ DirectRoute Menu 
The DirectRoute menu contains numerous sub-menu items that, when chosen, present a dropdown list of 
action-based options. These items include:  

•​ File Menu 
•​ Edit Menu  
•​ Map Menu  
•​ ResourcePro Menu 
•​ Analysis Menu 
•​ DRTrack Menu 
•​ Window Menu 
•​ Help Menu  

 
And on the far-right side of the DirectRoute menu is the Module Menu, a drop-down list of add-on software 
modules available for use with DirectRoute, if licensed. 
 
Directly below the menu is the toolbar, containing various icons used to perform specific functions, each of which 
is explained later in this section. 
 

 
Figure 2–DirectRoute Menu  
 

Tip: If a menu or toolbar option is gray/faded rather than colored/clear, it is not accessible at that time. You may 
need to have specific files open and/or be in the routing mode to access certain functions, or it may be accessible 
only if licensed for additional Appian software modules (ResourcePro, TerritoryPro, etc.). 

 

1.1.1.​ File Menu 
The File Menu (Alt+F) contains commands for opening, closing and saving files in DirectRoute, as well as creating 
Upload and Extract Files, and generating Distance Files. 
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Figure 3–File Menu 
 
New (ALT+F+N)–Open and create new files. Choose Route File, Stop File, Truck File, or Distance File. When 
using modules other than DirectRoute, additional options may be present (i.e. Schedule, Shipment File, Solution, 
Pool Point File, etc.). 

Open (Ctrl+O)–Open any existing or previously saved DirectRoute file. The file type, directory location, and file 
name can be chosen from the dialog box that appears.  

Open Drawing–Open any drawing files that were previously created and saved in DirectRoute.  

Save/Save As (Ctrl+S)–Save any open file. To save as a new file or assign a new name, select Save As. 

Save Drawing–Map drawings can be created to set boundaries, territories, or assign drivers, etc., then saved 
(with a .DRW file extension) to use during the routing process. They can be used with more than one route file, 
and are editable.  

Close All–Close all open files with one action.  

Print (Ctrl+P)–Print the Route Book, Map, Stop File, or Truck File. Select the file using the expanded menu 
(arrow). 

Print Setup–Set up a printer/directory (print to file) to use with DirectRoute, change settings. 

Preferences–Change program settings/configuration of data files. See Routing Preferences for additional 
information. 

Generate Distance File–Without a Distance File, the software will use a straight-line distance and scale factor to 
calculate distances between stops. When a Distance File is generated, the miles calculated from the available 
mileage system will be used instead. See Generate a New Distance File for additional information. 

Update Stop File–Update the Stop File with data from another Stop File.  

Extract–Create a Stop File with an extract from an order management system.  
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Upload–When the routes have been finalized, create an Upload File that can be sent back to the order entry 
system for processing. See Creating Upload Files for additional information and instructions. 

Upload to PeopleNet–Send stop, vehicle, and route information to the internet for use with an active PeopleNet 
license. 

Export to DRTrack–Send route information to the internet for tracking of vehicles and routes through the 
DRTrack module (additional license required).  

Recent Files/Recent Projects–Select recently viewed files and/or projects. 

Recent User Data Directory–Quickly switch to and use another data directory that has been used recently, 
instead of switching via File > Preferences > File Names/Paths. 

Exit (Alt+F4)–Exit and close the program. 

 

1.1.2.​ Edit Menu 
The Edit Menu (Alt+E) is only displayed and available when one or more spreadsheet files (Stop or Truck File) are 
open. The options included in this menu are used to manipulate and edit the spreadsheet files, and for plotting 
(Geocoding) records on the map.  
 

 
Figure 4–Edit Menu 
 
Cut (Ctrl+X)–Move cells or cell content to another cell or spreadsheet; places cut data in the clipboard until it is 
pasted into another cell or discarded. 

Copy (Ctrl+C)–Copy cells or portions of cells from a spreadsheet to another cell or spreadsheet. 

Paste/Paste Values (Ctrl+V)–Paste cut or copied content into cells; use Paste Values to paste formula results 
(sums).  

Template–Paste values or formulas into multiple cells within a spreadsheet; enables set up of Apply Defaults 
(enter changes in the sample spreadsheet, select Apply Defaults, then enter To Row and From Row to apply the 
new data). 
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Delete Records–Delete data from cells or rows. 

Address Cleanup–Correct addresses and/or locate 9-digit Zip Codes; prepares records for Geocoding. 

Geocode–Shortcut to the Geocode process; uses the address fields to locate Lat/Long coordinates of each 
record. 

Statistics–Calculates summary statistics for records within the spreadsheet, or to records within drawings on the 
map. 

Recalculate–Recalculate statistics. Use after changes have been made to valued cells.  

Font–Select font style and size. 

Apply Defaults–Sets default status for Time Windows, EqCodes, Unload Rates, Fixed Time, and Zone to a range 
of records on a Stop File. 

Order Selection–Select and apply priority routing/delivery to records within the Stop File. 

Query Builder–Build and save queried searches for records in the Stop File spreadsheet based on content 
values in the selected Stop Fields.  

Stop Filter–Apply a temporary or permanent mass update to a selected Stop Field column on records found by a 
saved query. 

 

1.1.3.​ ResourcePro Menu 
The ResourcePro Menu provides access to functions using the ResourcePro Module (ref: ResourcePro Module) 
(additional license may be required).  
 

1.1.4.​ Analysis Menu 
The Analysis Menu launches the Cross doc vs DC (Distributions Center) tool and corresponding statistics as well 
as the Scenario Manager tool which is utilized in DirectRoute while engaging in the review of a .ROUTE project. 
 

 
Figure 5–Analysis 
 

1.1.5.​ DRTrack Menu 
DRTrack is an optional Appian web-based GPS tracking program. If you have a DRTrack site, the DRTrack Menu 
provides several options to upload and download information from DirectRoute. 
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Figure 6–DRTrack Menu 
 
Upload/Download Account Master–Upload or download an Account Master File to/from DRTrack. 

Upload/Download Truck Master–Upload or download a Truck Master File to/from DRTrack. 

Upload/Download Email Accounts–Upload or download email accounts to/from DRTrack (If Email Manager is 
configured in DRTrack). 

Export to DRTrack–Export a routing solution to DRTrack; routing solutions can be sent from DRTrack via web 
services to an ERP/WMS/OMS. 

Export Master Routes to DRTrack–Enables the exporting of Master Routes to DRTrack. Uncheck the Skip 
Empty Routes box in the dialog if you want to also export empty routes/trucks. 

Download Master Routes–Download Master Routes from DRTrack.  

 

Note: See Import and Extract Records and Routing Preferences and Options Table for more info.  

 

1.1.6.​ Window Menu 
The Window Menu (Alt+W) enables switching between open files. A check mark identifies the current window 
view; select a window number to switch to another open window or use the shortcut, Ctrl+F6. 
 

 
Figure 7–Window 
 
DirectRoute allows single or multiple files to be opened at any one time. Each open file will produce a labeled 
window tab. When multiple files are open, the active window will appear layered over the inactive windows.  

©2026 Trimble Maps​ 13​ ​  Mar -26 



DirectRoute User Guide​ ​ 26.1 

 
To view one of the inactive window tabs, simply select the tab to bring it forward. 

 
Figure 8–DirectRoute Map Screen View 
 
The software also enables alternate positioning of multiple windows/files when more than one is opened. As an 
example, when in the routing mode, with the Route Book, Stop File, and Truck File all open at the same time, you 
can position the various window tabs to enable viewing three or more files on the screen together.  
 
Alternate positioning is simple to do; just grab the tab (with the mouse) of the window you want to move and drag 
it into the desired location. 

 
Figure 9–Alternate Positioning of Open Windows 
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Figure 10–DirectRoute Multiple Window View 
 

Tip: Use Ctrl+F6 shortcut to move between windows. 

 

1.1.7.​ Help Menu 
The Help Menu (Alt+H) can be accessed at any time, from any screen, while using the software. Options listed 
provide valuable access to guidance and instructions, and important information concerning the software program and 
system in use. 
 

 
Figure 11–Help Menu 
 
Documentation – Link to DirectRoute support documents. 

Contact Support – Contact information for Trimble MAPS Support, support@trimblemaps.com. 
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Content tools – Access the HTML Help File, for guidance and instructions on using DirectRoute.  

Ideas & Improvements – Link to a customer feedback portal to share ideas for improvements or identify pain points.  

1.​ Select the Application from the drop down menu at the bottom of the page. 

2.​ Enter suggestions and submit for consideration. 

About – Identifies the DirectRoute (software) license #, version # and date, and primary application path in use by the 
operating system, and easy links to important resources. 

●​ API Key (Previously known as Serial number) – Click on the Copy button for copy / paste purposes (See figure 
12 below). 

●​ Lease Expiration – Indicates when the next authentication is required (generally every 24 hrs). 

Licenses – Displays all of the account’s active licenses 

 

Tip: During Customer Support calls, users may be asked for the license# and version# installed on the system, to 
emulate operating environment and/or enable faster, more accurate resolution of issues.  

 
Figure 12–DirectRoute License & Version 
 

1.2.​ Map Menu and Map Tools 
Trimble maps provided by PC*Miler Web Services replace the older PC*Miler maps. These maps are provided via 
an active internet connection each time a new DirectRoute session is started. DirectRoute calls the web service to 
locate and retrieve the most current maps.  
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If an active internet connection is not available, DirectRoute will display a gray screen with no map, as it will not 
be able to retrieve any map data. However, all routing functions remain available without the maps or an internet 
connection, if the mileage system selected for routing is set to PC*Miler Direct (Preferences > Other > Mileage 
System > PC*Miler Direct). 
 
DirectRoute does not cache maps, except those used during a working session. If the internet connection is lost 
during a session, the maps in use at that time will be cached and remain available for use if the session itself is 
not terminated. If the internet connection is restored before the session ends, the maps will refresh automatically; 
if the session ends/is restarted before an internet connection is restored, a gray screen will appear in place of the 
maps, since any cached maps were deleted when the original session ended. 
 
The Map Menu (Alt+M) contains linked actions that can be performed while working in the map window. Additional 
functions within the map menu allow for customizing the map view and certain map zoom functions. 
 

 
Figure 13–Map Menu 
 

1.2.1.​ Default Map 
Select a custom Default Map (area and zoom level) to be displayed each time a DirectRoute session is started. 
The installed default view is set to show the entire United States. 
  

Example: If you work mostly with the eastern half of the USA, and most routes only span part of this area, then 
zoom in to the specific area and set the default map to this area. 
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Figure 14–Default Map View 
 

 
Figure 15–Customized Default View 
 
To reset the default view to a new area or region: 

•​ Zoom to the desired location/zoom level (closer in, farther out). 
•​ Select Map > Default Map from the menu bar. 

 
After moving about the map, and/or while zooming in/out of locations, use Map > Zoom > Restore (CTR+R) to 
return the screen to the default map.  
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You can also use the zoom control bar in the bottom right corner of the map to control your zoom level. Simply 
grab the bar with your mouse and slide it left or right to zoom in/out. 
 

1.2.2.​ Point Field Displayed 
Set and/or change the information displayed on the map for each stop that is geocoded when the zoom level is 
100 miles or closer. Any record column heading from the Stop File can be selected to display on the map. 
Includes option to choose which records are displayed (i.e. Display all, Display routed stops only, etc.).  
 

 
Figure 16–Point Field Displayed 
 

1.2.3.​ Map Tools 
Map Tools include functions for analyzing and displaying data, Drawing Tools to define boundaries or territories, 
and filter actions to search for specific records and streets. 

•​ Build to Value–Color-code locations based upon geographical area and a volume criterion (i.e. build 
a route based on area and volume). DirectRoute will apply a color and symbol to locations that fall 
within the criteria chosen. The software searches in concentric circles from the starting point.  

•​ Draw/Clear Drawings–Used to enable the Drawing Tools, which are used to place objects, 
boundaries, and text boxes on the map; use Clear Drawings to erase drawings from the map. 

•​ Find Streets/Clear Streets–Use Find Streets to search for or locate a street name on the map; use 
Clear Streets to remove the search results from view. 

•​ Unique Value–Assign a different color symbol to each unique value within a spreadsheet column. 
Quickly color code records based upon unique criteria (TerritoryID, Driver Name, etc.) 

•​ Select–Select specific records from the Stop File to plot on the map. 
 

Tip: Drawing Tools can also be activated by using the Drawing Tools icon on the toolbar.  

 

1.2.4.​ Zoom 
DirectRoute offers predefined zoom options as well as the ability to customize the zoom function. Select one of 
the predefined areas listed to set as the default zoom range, or customize with by changing the Settings.  

•​ USA. 
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•​ Region. 

•​ City. 

•​ 5 Digit Zip. 

•​ Settings to control quick zoom features. 

−​ Zoom Percent–Control zoom level (Zoom In %, Zoom Out %) applied when the (+plus) and (- minus) 
keyboard keys are used. 

−​ Zoom To–Set a specific map width to zoom to when you left click the mouse. 

−​ Double-click–Select the type of action that occurs when you double-click the primary mouse button. 

 

Tip: Select Restore (Ctrl+R) to return to the default map view. 

 

 
Figure 17–Predefined Zoom Areas 
 

Tip: Availability of cities is limited only by the types of maps installed on your system. If you do not have 
maps of other countries installed, this will not work for any city listed in those countries. 

 
Tool Tip Fields – Map Tool Tip (Stop Info Box) provides color coded results for quick identification. Detailed info 
related to each stop can be seen in the Stop Info box that appears on the screen when the mouse cursor is 
positioned/hovers over the stop. Any data column from the Stop File spreadsheet can be chosen to display on the 
screen in an info box that appears above the stop point on the map as the mouse cursor rolls over it. 
 
Filter–Use a map filter to isolate specific stops on the map. Filters can be identified using any Stop File field from 
the spreadsheet.  

•​ Select Map > Filter > Show Filter; use the Saved Queries drop down menu to select the saved filter. 

•​ Stop Filters applied and saved in the primary Route Book will also be available for use in any 
additionally opened Route Books (Route Book 2, Route Book 3, etc.). 

•​ Any saved filter can be accessed from any open file, as well as from the map. 
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Map Themes–Map Themes provide options for the type of map to use/display. Several options are provided, 
including Transportation, Datalight, Datadark, Terrain, and Satellite. 
 

 
Figure 18–Map Themes 
 
Map Region–Select from 9 specific map regions. When a region is selected/changed from the available 
drop-down menu, DR will automatically call web services (requires internet connection) to retrieve the most 
current map data available for the selected region. 

 

The 9 new options available from which to select include: 

●​ PCM_AF = Africa 
●​ PCM_AS = Australia 
●​ PCM_EU = Europe 
●​ PCM_NA = North America 
●​ PCM_OC = Oceanic 
●​ PCM_SA = South America 
●​ PCM_ME = Middle East 
●​ PCM_WW = Worldwide 

 
A related setting in Preferences > Trimble Maps > Data Version, enables selecting the map data version 
(PC*Miler 18 and later);  
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Figure 19–Map Region 

 
Plot Map Points–Opens a control box in which a specific address can be input to geocode, or just enter the 
Lat/Long coordinates to plot that point on the map. From the main Menu, select Map > Plot Map Points.  

•​ Add New Point–Add additional lines to the info box to enter additional addresses. 

•​ Clear All–Clear all the stops from the map and from the list of stops. 

•​ Zoom to All Stops–Zoom the map to all the stops. 

•​ Close–Close the Map Point info box. 

•​ Geocode–Geocode the address entered in the control. 

•​ Add Stop–Add the stop(s) to the map. 

 
Figure 20–Map Region 
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1.2.5.​ Additional Assorted Map Features 
Unlike other programs that have rigid zoom settings, DirectRoute’s map features assorted tools to enhance or 
define the map viewing area. In addition to the Map Menu options, the following map tools are also available.  
  
Map Scroll Bar–Located on the bottom of the map, the scroll bar can be used to zoom in or out on the map. Grab 
the cursor with the mouse and manually move it left (zoom in) or right (zoom out). Or left click and hold on the 
scroll arrows (on either side of the cursor) to zoom. 
  
Zoom to Selected Spreadsheet Record–Click once on a stop record in the spreadsheet to select it, then right 
click once and select Zoom To; the screen will switch to the map window, zoomed in to the stop.  
 

Note: If a stop is not geocoded, this function will zoom to the selected record’s Zip Code, instead. If no Zip Code 
is listed for the record, the Zoom To function will not work.  

 

Map Zoom Icon  –Located on the DirectRoute Toolbar, use the Zoom icon to zoom in closer on a selected 
area. Select the icon from the toolbar, then left click and hold the mouse button and drag the mouse outward to 
encapsulate the desired area. When the mouse button is released, the screen will jump to the area that was 
selected.  
 
Zoom Using Mouse Double-click–Double-click the mouse over any area to zoom in or out (percentage setting 
defined in Map > Zoom > Settings).  
 
Cursor Panning–To pan the map left, right, up or down, Click and hold on the mouse, moving the cursor to the 
location you want to view, then release.  
 
Locate Latitude/Longitude–Lat/Long coordinates are always displayed in the bottom left corner of the map. As 
you move about the map with the cursor, the coordinates change and will display the coordinates at which the 
cursor is located. To search for coordinates without a specific address, zoom to a level that enables viewing the 
point of interest, then glide the cursor into position to display the coordinates for that location.  
 

1.3.​ Map Symbols and Color Chart 
Symbols and colors are chosen and saved in the Stop File to represent stops as they are displayed on the map 
with the Stop File open. There are several ways to use symbols and colors to quickly identify types of stops. Use 
colors and/or symbols to identify customers who receive deliveries on specific days of the week (red for Mondays, 
yellow for Tuesdays, etc.) or a circle for convenience store deliveries and a square for grocery store deliveries. 
With 30+ symbols and 40+ colors to choose from, numerous combinations can be used to customize the map 
display.  
 
Symbols–Symbols are used to represent each stop (or Truck) displayed on the map when the Stop File (Truck 
File) is open. The symbols are chosen from within the file during the edit process. 
 
To change or add a symbol type for any record: 

•​ Double click on any cell or column within the Stop File to open the Stop Dialog box.  
•​ On the right side of the Stop Dialog box under Location, locate the Symbol box and use the 

drop-down arrow to select from the options listed. 
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Figure 21–Symbol Chart 

 

1.3.1.​ Color Chart 
The map symbol color chart lists the various colors available to assign to each symbol chosen for display on the 
map. To choose or change the symbol color: 

•​ Double-click any cell on the line of the record to be edited to open the Stop Dialog box. 

•​ On the right-hand side of the dialog box under Location, locate the Color box and use the drop-down 
arrow to select from the options listed.  
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Figure 22–Color Coding Chart 

 

1.3.2.​ Display/Edit Stop Info on the Map 
DirectRoute allows you to display and edit the spreadsheet data for a symbol that you point to on the map. The 
Stop Info box displays the spreadsheet row and focuses the corresponding symbol on the map. 
 
Detailed info related to each stop can be seen in the Stop Info Box that appears on the screen when the mouse 
cursor is positioned/hovers over the stop (Ctrl+click). 
Info in the center of the box (custom user defined fields) will always be white text on black background. 
Header color indicates a stop's status.  

•​ Yellow = unloaded stop prior to routing; no footer. 
•​ Red = unloaded stop in routing mode; footer reads Unloaded. 
•​ Blue = loaded stop in the routing mode; footer message reads Route, Leg, and Sequence #. 

 
When stops (routing mode) are tightly grouped on the map, all stop info is displayed in one box; the footer lists the 
number of stops loaded vs. total stops displayed. 
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Figure 23–Display Stop Info on the Map 

 

Tip: While we use the Stop File as our example in this section, the same can be applied to the Truck File and/or 
Route File (Truck Info box, Route Info box), as this option is available for any spreadsheet record. 

 

1.4.​ Toolbar and Icons 
The DirectRoute toolbar contains shortcut icons for performing frequent or critical tasks. Some of the icons will not 
be active or cannot be used unless specific files are open, certain actions have already been completed, or one of 
the additional software modules has been installed and is in use. 
 

 
Figure 24–DirectRoute Toolbar 
 

Tip: If a menu or toolbar option is gray/faded rather than colored/clear, it is not accessible at that time. You may 
need to have specific files open and/or be in the routing mode to access certain functions, or it may be accessible 
only if licensed for additional Appian software modules (ResourcePro, TerritoryPro, etc.). 

 

File Open–  Use to open a spreadsheet, data, or Route File. The file type, directory location, and file name 
can be chosen from the dialog box that appears.  

File Save–  Use to save an active spreadsheet and/or route.  
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Clipboard–  Enables copying a portion of the map and drawings you are viewing to the Windows clipboard. 
Click/drag the mouse in the map window to copy a portion of the Map window to a photo image program 
(Microsoft Paint, Paintbrush, etc.) or to a Word application. 

Print–  Print the map (active), records from your spreadsheets, or routes.  

Geocode by Zip–  Locates the Lat/Long of records within the Stop File and Truck File, and updates the 
records according to their 5-digit Zip Code centroid. 

Geocode by Address–  A shortcut to geocoding, which locates the Lat/Long of records within the Stop File 
and Truck File according to their exact address and ZIP+4. 

Address Cleanup–  Provides a quick and easy means for correcting address information and attaching the 
4-digit extension (ZIP+4) to the Zip Code. Address Cleanup should be used prior to Geocoding records.  

Stop Filter–  Enables selection and separation of unique records from the Stop File to display on the map 
alone (without all others). The clear function allows the filter to be cleared when done. When filters are used and 
saved in the Primary (P) Route Book, the filter becomes available for use in each additional Route Book, as well 
as in any other open file, and from the map. To access a saved filter: 

•​ While viewing the map, select Map > Filter > Show Filter; select the saved filter from the drop-down 
menu. 

•​ While in the Stop File and/or Truck File, select View > Stop Filter; select the saved filter from the 
drop-down menu. 

  
Additionally, Stop Filters can be applied and used in the Preprocess function (route selected records only, versus 
all records in the entire Stop File). See Routing Preferences and Options Table for additional information on 
how to use a Stop Filter in the Preprocess function. 

Normal Cursor–  Used to cancel a DirectRoute action. For instance, to end a drawing tool action such as 
the circle-drawing tool, select the normal cursor icon on the toolbar.  
 

Tip: Can also be used to cancel the Zoom or Pan Map function. 

 

Map Zoom–  Use to zoom in closer on a selected area. Select the icon from the toolbar, then left click and 
hold the mouse button and drag the mouse outward to encapsulate the desired area; when the mouse button is 
released, the screen will jump to the selected area.  

Lasso–  Use to encircle (select) a group of stops on the map. Can be used to select and edit stops, load or 
unload stops, move stops to additional routes, etc. See Using the Lasso Tool for additional information.  

Manual Routing –  Selects specific stops to route. 

Drawing Tools–  Activates the tool bar, enabling the drawing of shapes, selection of records, and 
placement of text boxes on the map.  

Get Directions –  Provides turn by turn directions for each selected route, while in the routing mode.  
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Generate Route Directions on Route Edit–  Regenerates new directions if routes are edited after 
directions were initially produced. When Generate Route Direction on Route Edit is selected on the DirectRoute 
menu, the button will be outlined in black ink. When a stop on any route is edited or modified, as soon as that 
action occurs, the Generating Route Directions info box should appear in the lower left side of the screen, 
indicating new directions are being generated. 

Priority Routing–  Used to activate Priority Routing, a tool used to build routes manually.  

Selective Routing–  Used to reopen the Truck and Stop Grids when working with routes created with 
Selective Routing. 
 
Sync Map–Sync with other windows. When in the routing mode, use this after editing any data to sync all open 
windows. 

External Utilities–  Provides additional configuration utilities for some users. Options are defined in 
“utils.config.” 

Minimize All Info Grids–  Will minimize all info panels that are open in the Route Book and create a tab to 
each on the left side of the screen. 

Rate Orders–  Used with Transportation Modeler to apply rates from a designated Rate File to a Shipment 
File (this icon is normally only visible when using the TM module). 
 

1.5.​ Mouse Pointer Symbols 
The Mouse Pointer assumes different shapes and sizes to let you know what functions are currently being 
performed.  
 
Unlike your PC’s theme options, the Mouse Pointer symbols in DirectRoute are not interchangeable or 
customizable. In other words, you cannot select which pointer you would like to use while working in DirectRoute. 
The types of pointers available while working in DirectRoute are dependent on the module and/or process that are 
currently activated.  

Arrow Pointer– Pointing to the toolbar, menus, scroll bars, mini-map, spreadsheet, or status bar.  

Map Pointer– Working in the Map window; used to point at symbols displayed on the map. Lat/Long 
coordinates, in relation to the pointer’s location, are displayed in the bottom left corner of the status bar.  

Spreadsheet Pointer– Pointing at spreadsheet cells. Click on any cell or use the keyboard arrow keys to 
move between cells.  

Frame Hand Pointer– Indicates that the Pan Map icon is active. To cancel, select the normal cursor icon.  

Hourglass Pointer– DirectRoute is performing a task.  

Magnifying Glass Pointer– Use to zoom in on an area. To cancel, select the normal cursor icon.  

I-Beam Pointer–  Mouse is positioned over a selected cell, or mouse is over the formula bar (just below the 
toolbar, while a spreadsheet file is active.)  
Two-Headed Arrow Pointer– Resizing drawings, spreadsheet cells, or windows.  

Four-Headed Arrow Pointer– Moving a drawing or text box.  
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Clipboard Pointer–  The clipboard icon is active.  

Manual Routing Pointer–  When the Manual Routing icon is active.  

2.​ Routing Overview 
DirectRoute’s routing technology provides one of the fastest optimal route planning algorithms now available in 
routing solutions on the market today. Utilizing DirectRoute to plan and develop routes can improve efficient 
workflows in every step of the logistical arena, from planning and analysis to dispatch, tracking and reporting. 

•​ Improve capacity usage. 

•​ Reduce empty miles. 

•​ Less manual routing through advanced algorithms. 

•​ Save time planning/routing. 

•​ Build various routing scenarios with the Scenario Manager tool. 

•​ Automate load and optimization of routes. 

•​ Download order and customer files. 

•​ Route modifications from the map screen. 

•​ Route modifications from the Route Book. 

 
As each stop is loaded, DirectRoute uses the routing parameters defined in each project to determine truck 
departure and arrival times, and distances between stops and depot. As the routes are built, key statistical data 
pertaining to each route is summarized and provided with each routing solution, including:  

•​ The total miles driven on each route and time required to complete. 

•​ Total volume (i.e. weight, cube, etc.) and cost. 

•​ Combined totals (all the above) of all routes and averages. 

 
Once routes have been established, DirectRoute provides several options that allow routes to be immediately 
viewed, modified, printed, and saved. Additional options include: 

•​ Maintain key route statistics (total drive time, work time, miles driven, capacity utilization, costs, etc. 

•​ Display and print detailed delivery schedules with arrival/departure time. 

•​ Upload routes to an Order Management System, GPS tracking system, or other. 

•​ Download orders from an Order Management System to update or build additional routes. 

 
DirectRoute utilizes a few primary components to develop an effective routing solution.  

•​ Routing data provided in the form of Route Files determines the ‘who’, ‘what’, ‘when’ and ‘where’ of 
routing. 

•​ Types of routes, or the type of results expected, in the routing solution (fixed, skeletal, zone based, or 
dynamic). 

•​ Routing Parameters, or Routing Preferences, help DirectRoute determine the ‘how’ to route, or 
routing environment, which may include various constraints (work rules, travel restrictions, delivery 
windows, available equipment, etc.) that must be followed. 

©2026 Trimble Maps​ 29​ ​  Mar -26 



DirectRoute User Guide​ ​ 26.1 

 
 

2.1.​ Routing Data 
Before DirectRoute can assist in developing routes, it must know something about your routing environment and 
the deliveries to be made (routing data). This routing data (fleet and customer delivery information) is provided 
within Route Files (Stop File, Truck File, Distance File, etc.). The more you understand the way DirectRoute uses 
the data you provide, the more effective you will be in using DirectRoute.  
 
Some of the data fields in the Stop File relate to data fields in other files, and vice versa. For instance, the Truck 
File contains a data field that relays vehicle capacity information to DirectRoute for use during the routing process. 
 

Example: Assume that each truck has a capacity of 45,000lbs. For DirectRoute to know when the truck is full, it 
must also know the delivery quantity (weight) assigned on each Stop Record. Therefore, the Stop File must 
include a data field that indicates the quantity (weight) of each delivery.  

 
The Quantity Fields in DirectRoute can be used for any Quantity Value (weight, cube, pallets, etc.).  

•​ Users assign the type(s) of Quantity Fields that will be used (Routing Preferences, next section). 

•​ More than one (additional) Quantity Fields can be used together (weight, cube, pallets, etc.). 

•​ Remember to use the same Quantity Value in both the Truck and Stop Files. 

 

2.2.​ Types of Routes 
Typically, the most common types of routes used are Fixed, Dynamic, Skeletal, and Zoned. The type of routing 
you perform will depend largely on your type of operation and may include more than one of these, or a 
combination of these, to get the optimal results for your business. 

•​ Fixed Routes–Fixed Routes are performed when all customers are pre-assigned to a route and the 
number of routes run each day is pre-determined; the customer base is very static, and order patterns 
are very predictable with only occasional fluctuations. Fixed Routes are also used when drivers also 
perform sales functions or a two-step delivery process with merchandisers following the delivery 
route. 

•​ Skeletal Routes–Skeletal Routes are performed when primary customers are pre-assigned routes 
and typically have very tight delivery times so routes can only be run a certain way, and the number of 
routes run each day is pre-determined. Skeletal Routes are used to keep primary customer deliveries 
very consistent and non-primary customers will be routed within their time window, but not always at 
the same time. This type of routing requires a core set of customers, generally 80%, all with very 
predictable order patterns. 

•​ Zone Based Routes–Zone Based Routes are performed when routing is based on geographically 
set areas, or zones, and driver assignment is by zone/area. Areas can be defined as small as one 
truck or larger, with multiple trucks assigned, and user set rules and constraints are set to enforce 
assignments (hard or soft time windows, length of workday, etc.). This encourages driver familiarity 
with route and clients, and aides in focusing on managing cost and customer service. While similar to 
Dynamic Routing, it facilitates a first shift picking before final order cutoff, and can be used for jobsite 
type deliveries while still keeping drivers in zones Depending on how the zones are created, there is 
opportunity to reduce the number of routes required.  

•​ Dynamic Routes–Dynamic Routes are performed when routes vary from day to day, with ability to 
adapt to a very dynamically changing customer base with the greatest customer flexibility. Routes are 
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built based on the lowest overall cost without violating any delivery rules associated with customer 
requirements. This type of routing can offer improved customer service through flexibility, offers the 
highest reduction in transportation costs, and works best when used in conjunction with DRTrack for 
schedule visibility and re-time tracking. 

 

2.3.​ Routing Preferences 
Routing Preferences, or parameters, help DirectRoute determine the ‘how’ to route, or routing environment, which 
may include various constraints (work rules, travel restrictions, delivery windows, available equipment, etc.) that 
must be followed. 
 
Routing Preferences are used to supply the software with necessary information about your routing environment 
and the type of results expected in the routing solution. These settings help DirectRoute identify specific data 
fields, volume types, and delivery windows used in the Truck File and Stop File, and direct specific actions, 
behaviors, or special considerations that the software should perform or consider when building routes. 
 

Tip: Upon initial installation of the DirectRoute software program, the assigned Appian Implementation and 
Training Consultant will help identify and update all settings that best fit your specific routing environment.  

 
Routing Preference and Option Table identifies and explains each setting and available options more 
completely. To access and update Routing Preferences in DirectRoute, select File > Preferences from the main 
menu.  
 
While all the preference settings are important to each routing solution, some settings are more critical, and 
depending on your routing environment, some settings may not be used at all. Preference settings are divided into 
multiple sections, as briefly identified below. 

•​ Configuration – Settings specific to the Truck and Stop Files. 

•​ Defaults – Default options applied during the extract process. 

•​ DRTrack – For DRTrack users; identify URL path and IDs for uploading routes. 

•​ ETS Provider – For users of TMW ETS or TMW Innovative services. 

•​ Extract – Extract settings for use with an Order Management/Host system. 

•​ File Names/Paths – Identifies location paths of key files used in the routing process. 

•​ Geocode Options – Select Secondary Geocode processes and options (ex. Google).  

•​ Import – Settings used to import XML Files from integrated TMW Systems software. 

•​ Mode Selection – Options used in conjunction with Transportation Modeler software. 

•​ Other – Identify mileage system and custom Geocode Files or special Map Files to use. 

•​ PC*Miler– Routing and vehicle options for use WITH a PC*Miler license. 

•​ PC*Miler Direct – Routing and vehicle options for use WITHOUT a PC*Miler license.  

•​ PostProcess – Accelerates after-routing processes when Upload Files is used. 

•​ Preprocess – Accelerates routing process with selected automatic actions. 

•​ ResourcePro - Licensed ResourcePro users can set their ResourcePro Scheduling Parameters to 
override the DirectRoute factory default settings.  
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o​ Consecutive Days Off used in conjunction with Max Number of Duty Cycles allows the scheduler to 

ensure 2 or 3 days of consecutive off-duty time during the Scheduling Period (e.g., 2 consecutive 
days off during a 7 or 8 day cycle). 

o​ Consecutive Days Off are measured in hours - 48 hrs or 72 hrs. 
o​ Users can also adjust the settings for a single use, save the adjustments to Preferences, or toggle 

between your preferences and the Factory Defaults.  
o​ Changes made in DirectRoute are reflected in ResourcePro and vice versa. 

•​ Routing – Options used in the automatic load building and optimization processes. 

•​ Tanker – Load building options for compartments, used with the Tanker Algorithm. 

•​ Trimble Maps – Route and Distance File options for use with PC*Miler Web Services. 

•​ Update Stop File – Select Stop Fields to update automatically during the Upload process. 

•​ Upload – Upload settings for export to an Order Management/Host system. 
 

 

Scheduling Parameters dropdown 
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2.3.1.​ Routing Preferences and Options Table 

FIELD SAMPLE ENTRY EXPLANATION 

CONFIGURATION  Config settings applied to the Stop and Truck Files 

ID1 Acct# A unique field to identify a stop (customer#, account#, 
invoice#, etc). 

ID2 Order# Optional secondary field identifying a stop (order#, SKU#, 
etc.) 

ID3 ID3 Optional tertiary field (item#, etc.) 

Name Name Customer name, Account#, etc. 

Address 2 Addr2 Optional secondary address info (bldg#, dock#, door#, 
etc.) 

Contact Tom Jones Contact info for delivery 

Phone 516-222-1234 Contact info for delivery 

Volumes 
(Collection) 
(weight, cases, pallets, units, 
etc.) 

Volume type used in the Stop File  

Stop User Fields 

(Collection) 
 
Ex: Comments, Style, 
Descript, Order Status, etc. 

Optional additional fields to list in the Stop File; use to 
collect info for reports, display in Route File, etc.  

Truck User Fields 

(Collection) 
 
Ex: Driver, Shift, Maint. Cat, 
etc. 

Optional additional fields to display in the Truck File; use 
to collect info for reports, display in Route File, etc. 

Number of Time 
Windows 2 Number of delivery time windows (1 thru 10) 

DEFAULTS  Applied to all stops 

Time Window (Collection) Default delivery time window applied to ALL stops 

Fixed Time 15 Standard fixed time (minutes) applied to ALL vehicles at 
each delivery 

EQ Code 
LG-BH-002 

See 9.1. Special Equipment 
Codes for more information. 

Special identifier for vehicles and/or requirements (lift 
gate, backhauls, priority codes, OD Pairs, etc.) 

Unload Rates ( Collection) 
weight, #cases, #pallets, etc. Standard number of Volume quantity unloaded per hour  
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FIELD SAMPLE ENTRY EXPLANATION 

Zone 

100 
  
Note: Increase or decrease 
applied as percentage to drive 
time to affect speed of vehicle 
 
Ex: 110 = increase drive time 
by 10%, decreases speed; 90 
= reduce drive time by 10%, 
increases speed 

Zone, when applied in the stop file affects a stop 24 hours 
a day and adjusts truck speed as that truck approaches 
that specific stop when it crosses over the 8 mile radius 
threshold. Zone when applied to the truck file affects a 
truck 24 hours a day and adjusts truck speed as that 
truck departs or arrives at the depot within the 8 mile 
radius. 

Earliest Date 1 Jan 2016 Earliest date of delivery 

Latest Date 3 Jan 2016 Latest date of delivery 

Early Buffer 

.25  
Ex: 1.00 = 1 hour, 0.25 = 15 
min, 0.5 = 30 min, 0.75 = 45 
min 

Time before the actual delivery window allowed for early 
delivery. The penalty cost applies when the delivery is 
within the early or late buffer period. The penalty is 
prorated and a value of 60 is suggested, equaling $1 per 
minute of buffer time used.  

Late Buffer 

.25 
Ex: 1.00 = 1 hour, 0.25 = 15 
min, 0.5 = 30 min, 0.75 = 45 
min 

Time after the actual delivery window allowed for late 
delivery. The penalty cost applies when the delivery is 
within the early or late buffer period. The penalty is 
prorated and a value of 60 is suggested, equaling $1 per 
minute of buffer time used. 

Penalty Cost 50 
(50 = $50) Fee ($) assessed when delivery Time Window is violated 

Max Splits 

2 
Note: When Apply Defaults is 
set to TRUE, then Max Splits 
value is applied to each stop 

Maximum # of times any stop (volume) can be split 

DRTRACK  Use with DRTrack license 

DRTrack URL http://companyname.routetrac
king.com/Login.aspx URL to DRTrack site; used for uploading data/files 

Company Name Johnson Tile Used for importing and exporting 

DRTrack Username  
Username for DRTrack. We recommend setting a 
Username and Password to help ensure only authorized 
users pass data to and from DRTrack. 

DRTrack Password Enter DRTrack password 
Password for DRTrack. We recommend setting a 
Username and Password to help ensure only authorized 
users pass data to and from DRTrack. 

DRTrack Proxy 
Server (If used to filter internet traffic) Name of the proxy server 
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DRTrack Proxy Port  Port for proxy server 

DRTrack Proxy 
Username  Proxy Username 

DRTrack Proxy 
Password  Proxy password 

DRTrack Timeout 10 System time-out value, in minutes 

Branch (Collection) Branch names, if used 

Default Branch  Default branch name 

Profiles (Collection) Truck profiles, if used for different routing days 

Route Upload Version 5 Upload version#  

Master Profiles  Master Profile names. More than one can be recorded 
and used 

Shift 
(Collection) 
(Shift name, From time, To 
time, Truck Profile) 

Enter Time Shifts when routing occurs (if used) 

Account Master 
Upload Version 1 Upload version#, if more than one is used 

Use LoadID From 
Stop File TRUE (FALSE) Default is FALSE 

Compression Method None (Zip) File compression method  

Manage Master 
Profile Routes  Set the start and end dates for each Master Profile 

ETSPROVIDER  Interface settings for additional TMW software modules 

TMW ETS Truckmate Select product family for interface 

TMW INNOVATIVE 
LOGIN Username  Login credentials (requires additional license) 

 Password Enter Password 

 SCAC code Enter SCAC code 

 Service Version Version 1 

EXTRACT  Use with OMS to extract data for Route Files 

Account Master File Master.xls Master File name 

Append New 
Accounts to Account 
Master  

TRUE (FALSE) Set to TRUE, will append (add to) the Master File with 
new account data found in the Extract File.  
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Extract Option CreateStopFile Creates a Stop File from the Master File with all account 
information, or Update Account Master File 

Get Address from 
Account Master  TRUE (FALSE) Gets address information from the Master File 

Overwrite Address in 
Account Master  TRUE (FALSE) Overwrites address in the Master File with address from 

Extract File 

Primary Identifier ID1 ID1 from Configuration setting 

Secondary Identifier None ID2, if used 

Tertiary Identifier None ID3, if used 

Update Blank 
Account Master 
Fields 

TRUE (FALSE) If TRUE, will update blank fields (existing customers only) 
in the Master File with data from the Extract File. 

Use Defaults for New 
Accounts 

TRUE (FALSE) 
 

If TRUE, will populate the default field settings (Time 
Windows, Unload Rates, etc.) to any new accounts in the 
Master File. 

Zero Coordinates if 
Address doesn’t 
match 

TRUE (FALSE) 
If TRUE, will clear the Lat/Long from the Stop File if the 
address in both the Master File and Extract File does not 
match 

Populate LoadID in 
Truck File 

TRUE (FALSE) 
 
Note: Applies when an Extract 
is performed with a new Route 
Build, and LoadID columns are 
populated 

If TRUE, copies LoadID from Extract File to Truck File 
when routes are initialized  

LoadID Column 
Name  Column that contains LoadID in Extract File 

Interface  Interface 

FILE NAMES AND 
PATHS  Identifies location of files used in the routing process 

User Data Directory C:\Program 
Files\Appian\DirectRoute\Data Location of the User or project DirectRoute Data Folder  

9-Digit Zip Directory 

C:\Program 
Files\Appian\DirectRoute\ 
ZIP9 Data 
 
Note: Should be in the 
DirectRoute folder that was 
created during the installation 
process 

Name and location of the ZIP9 Data File  
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Account Master File 
C:\Program 
Files\Appian\DirectRoute\Data\
Acct Master File.xls 

Location and name of the Account Master File 

Base Map Directory 

C:\Program 
Files\Appian\DirectRoute\ 
Base Maps 
 
Note: Should be in the 
DirectRoute Data Folder that 
was created during the 
installation process 

Location of the Map File 

Cross Dock File Path 
C:\Program 
Files\Appian\Direct 
Route\Data\Cross Dock.xls 

Location and name of Cross Dock File 

Custom Geocode File 
Path 

C:\Program 
Files\Appian\Direct 
Route\Data\Geo File.xls 

The path to the Custom Geocode File 

Drawing File Name 
C:\Program 
Files\Appian\Direct 
Route\Data\ Drawing File.drw 

The path of the Drawing File 

Geoset 

C:\Program 
Files\Appian\Direct 
Route\BASEMAPS\USA\USA.
GST 

The location of the .gst File 

OBC Folder Path  OBC upload output folder path 

Product Family File 
Path (*.xls) 

C:\Program 
Files\Appian\DirectRoute\PFF
P File.xls 
 
Note: File should contain 
populated ProductFamilyName 
column {mapped with 
TankSpEq column in Truck 
File} and populated 
ProductName column 

Select Product Family File for Tanker Algorithm 

Relay File Path 
C:\Program 
Files\Appian\DirectRoute\Data\
Relay File 

Enter the path name to the Relay Truck File 

Upload File Name Upload File Enter the name of the Upload File 

Upload File Path 
C:\Program 
Files\Appian\DirectRoute\Data\ 
Upload File 

Enter the path to the Upload File 
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Upload Format File 
(*urp)  URP File name and location; input here will remove 

prompt during every upload session 

Z1 Path 

C:\Program Files\Appian\ 
DirectRoute\Address 
Cleanup\Z1.DAT 
 
Note: Should be in 
DirectRoute\Address Cleanup 
folder 

Name and location of the Z1 File  

Z8 Path 

C:\Program Files\Appian\ 
DirectRoute\Address 
Cleanup\Z8.DAT 
 
Note: Should be in 
DirectRoute\Address Cleanup 
folder 

Name and location of the Z8 File 

GEOCODE 
OPTIONS  Used to find and validate location coordinates 

Secondary Geocoder 

None, Google 
 
Note: Limited to 2,500 
requests per 24hr period, and 
10 requests per second.  

Use Google to validate geocode results, or to obtain 
Canada or Australia geocode results. 

Fallback to secondary 
geocoding after 

Always, Never, Level 1, Level 
2 
Level 1: Recheck if result = 
other than Level 1 
Level 2: Recheck if result = 
other than Level 1 or 2 
Never: Never recheck 
addresses 
Always: Always recheck 
addresses 

Default is Always  
  

GOOGLE SETTINGS  Required when Google is Secondary Geocoder 

Google API Key 

800900700601  
 
(Alphanumeric key issued 
when User initiates a Google 
Maps account) 

Google API address 

Google Geocode 
Accuracy Level 

Rooftop 
 Default is Rooftop 
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Rooftop–(High Accuracy) 
Precise down to street address 
precision 
RangeInterpolated–(Same 
Street) Reflects an 
approximation (usually on a 
road) interpolated between 
two precise points (such as 
intersections); 
Geometric Center–(Same 
Region) Result is the 
geometric center of a result 
such as a polyline (ex. a 
street) or polygon (region); 
Approximate–(Approximate) 
Indicates the result is 
approximate 

IMPORT  Use with Integrated TMW Systems to Import files 

Enable Order 
Selection TRUE (FALSE) Set to TRUE if downloading orders for next dispatch date 

+ additional days 

Overwrite Quantity 
Fields TRUE (FALSE) Set to TRUE if not passing required fields 

Overwrite User Fields TRUE (FALSE) Set to TRUE if not passing User Fields 

Ignore Trucks passed 
in XML TRUE (FALSE) If FALSE, will prompt the user to pick a Truck File 

Enable Preprocess TRUE (FALSE) If set to TRUE, enables Preprocess to run when importing 
from an XML File 

MODE SELECTION  For use with Transportation Modeler, identifies mode 
types available, files, costs, and limitations 

MaxRoutesPerShipm
ent 3 Max# of routes per shipment; default is 3 

Rate File 
C:\Program 
Files\Appian\DirectRoute\Data\
Rate Table 

Path to Rate File 

Distance File 
C:\Program 
Files\Appian\DirectRoute\Data\ 
Data.dist 

Distance File name/path; usually the DirectRoute Data 
Folder 

Default TLRate 1.5 Default truckload rate 

Weight (Primary Qty 
Field) Weight Primary Qty field used 
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Volume (Secondary 
Qty Field) Cube Volume field used 

Count (Trichiary Qty 
Field)  Skids Quantity count (WT, Cube, Skids, etc.) 

SECURITY 
CREDENTIALS  USER CREDENTIALS Use with Rateware, UPS 

FEDEXCONFIGURA
TION SERVICE TYPE Use with FEDEX service 

Wait cost in LTL 
shipments 150.5 Wait cost in LTL shipments 

Border crossing delay 90 Border crossing delay (minutes) 

Max Allowed Work 
Hours in DOT Cycle 0 Max allowed work time on multi-day route (ex. 60 hrs) 

Team Rate Premium 890 Team Rate Premium 

Aggregate LTLCost 
on Consolidate TRUE (FALSE) Default is FALSE 

LTL Consolidation 
Type Costs or Miles Consolidation type for LTL Shipments 

LTL COST 
ADJUSTMENT  Cost adjustments (LTL Rate) 

Quantity Name Weight Volume type 

Quantity Over 0 Threshold after which LTL Cost Adjustment is added 

Additional Cost 0 Additional cost when threshold is reached 

OTHER  Mileage System and Map Files  

Mileage System 
Trimble Maps 
(PC*Miler Direct, PC*Miler, 
MapInfo, MapInfoCV, or None) 

Name of the Mileage System to be used with the 
software. Trimble Maps is the default and recommended 
setting. PC*MilerDirect is used for offline DirectRoute. 
PC*Miler can be used if the user is licensed for the PCM 
Connect utility and wants to connect DirectRoute to a 
stand-alone version of DirectRoute. 

Date Format  MM/dd/yyyy, dd/MM/yyyy, MMMM dd yyyy, or 
yyyy-MM-dd 

Time Format  

Time format used when passed to a primary business 
system using an Upload File and also used to specify 
whether times displayed in the Route Book include 
seconds. 
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Custom Geocode File 
Path 

C:\Program 
Files\Appian\DirectRoute\Data\ 
Geo File.xls 

Location of custom Geocode File, if used 

Geocode File Col 
Identifier CTY Name of the column in custom Geocode File, to be 

examined when applying custom geocoding 

Distance Options Miles Miles or Kilometers, used in map bar display 

Coordinate Option Decimal Degrees Decimal degrees, (Degree:Minute:Seconds) used in the 
map status bar 

Convert STP/xls File TRUE (FALSE) If TRUE, converts .STP and older .xls Files to newer 
format 

FIND STREET 
LAYER  Designation of street level GST layer used in Find Street 

utility 

Major Road Main Street Name of the road 

Street 1 Usa_dap  

Street 2   

Country En-AU (English) Australia For use with Google Maps API Geocoding, select 
applicable country code, if needed 

Company Name Parks Name 

Auto-save solution 
after generating 
directions 

TRUE (FALSE) If TRUE, saves solution after direction generation 

Auto-save Route 
Book layout files TRUE (FALSE) If TRUE, saves Route Book layout (F8 key) when the 

Route Book is closed 

Clone Stop and Truck 
File while saving 
Route File with Save 
As option 

TRUE (FALSE) 

If TRUE, saves and copies Stop, Truck, and Route File, 
when using Save As option to close files; copied files are 
assigned a new (same) name as the Route File, while 
original Route Files are left intact and unchanged 

Store distance entries 
in: 

File 
 
Note: If entries are stored in 
Database {Db}, use the 
following app settings in the 
exe.config File:  
Use Database for 
DistanceEntries =TRUE 
ConnectionStringName = 
Name of the string configured 

Select File or Database (PC*Miler route type) 

©2026 Trimble Maps​ 41​ ​  Mar -26 



DirectRoute User Guide​ ​ 26.1 

 

FIELD SAMPLE ENTRY EXPLANATION 

{Connection Strings section} 
CompanyID =1 {default}) 

ORDER CRITERIA  Enables Order Selection Filter for DRTrack download, 
and Selective Routing 

Query by User Field 
 

Status 
 

Enter each Stop User Field (Configuration > Stop User 
Fields) to enable use as a filter for stop selection  

Query by Values 

Ready / Not Ready 
 
Ex: Stop User Field chosen is 
Status. 
Values found in the Stop File 
(in this field) are Ready and 
Not Ready  

Enter all Values separately, as found in the selected Stop 
User Field 

Stop Selection Color Choose color for stop selection Blue 

Auto open Stop Grid 
on Routing TRUE (FALSE) When set to TRUE, automatically opens the Stop Grip in 

a routing solution 

Replenishment Point 
Name 

Default 
TruckID Choose refuel point name to be displayed 

PC*Miler Use with a PC*Miler license PC*Miler routing options 

Route across borders TRUE (FALSE) If TRUE, will allow routes to cross international borders; 
default is FALSE 

Route Type Practical Practical, Shortest or Fastest 

Route Type option Default Default, National, Avoid Toll, or Fifty Three 

Hazardous option None None, General, Explosive, Inhalant, Radioactive, 
Corrosive, or Flammable 

Thread Single For use when generating Distance File, for multi-core 
CPU, set threading to Multiple; otherwise set to Single 

PC*Miler DIRECT Use without a PC*Miler license PC*Miler routing options 

Route across borders TRUE (FALSE) If TRUE, will allow routes to cross international borders; 
default is FALSE 

Route Type Practical Practical, Shortest or Fastest 

Avoid Toll TRUE (FALSE) If TRUE, will avoid toll roads when possible during the 
routing process; default is FALSE 

Hazardous option None None, General, Explosive, Inhalant, Radioactive, 
Corrosive, or Flammable 

Thread Count 0 16 max threads 
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Distance Generation 
Mode Pair Option to change how PC*Miler generates distance 

entries. Default is Pair 

Vehicle Profiles 

(Collection) 
 
Profile allows edit of vehicle 
height, length, width, weight 
limit, and # of axles (no less 
than 2). 
 
Ex: Light Assets, Full Sized 
Van, Double Trailers, Straight 
Truck, 48’ Semi Trailer, 53’ 
Semi Trailer, or Custom 
(PC*Miler Direct/Vehicle 
Profiles). Add additional if 
necessary, under ‘Custom’. 

Add/Enter all vehicle profiles used in the Truck File. Only 
those profiles entered will be available for selection as a 
Default Vehicle Profile.  

Default Vehicle Profile 
Only vehicles entered in 
Vehicle Profiles will be 
available for selection. 

Select the default vehicle profile to use during the route 
building process. 

Map Region Default Map Region N/A (not used at this time) 

Use Historical Traffic 
Data 

Requires additional Appian 
licensing. 
 
When not used, the system 
will default to DirectRoute 
Drive Time (or other installed 
Mileage System).  

If TRUE, generates drive times and distances based on 
historic traffic time estimates and collected real-time 
traffic data, instead of DirectRoute’s calculated drive 
time/distances. 

POSTPROCESS  Use to accelerate additional processes after routing 

Upload TRUE (FALSE) If TRUE, will pass orders/routes in an upload file (UPL) 
after routing 

Upload DRTrack TRUE (FALSE) Set to TRUE, will pass orders/routes to DRTrack after 
routing 

Print Route Book TRUE (FALSE) If TRUE, will automatically print the Route Book upon 
completion of the routing process 

PREPROCESS  Use to accelerate the routing process 

GENERATE 
DISTANCE FILE   

Generate Distance 
File TRUE (FALSE) If TRUE, generates Distance File during Preprocess 

Minimum Distance 
Between Stops 0 Minimum distance the software will compute distance 

between stops 
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Maximum Distance 
Between Stops 800 Maximum distance the software will compute distance 

between stops 

Speed Adjustment 100 Adjust drive time by this factor (100 is baseline, 120 
increases drive time by 20%, etc.) 

Maximum Speed 60 Maximum allowable speed by vehicle on a route 

Generate 2-way 
entries for stops less 
than (x miles) 

5 Add a return distance, between two stops within X miles 
of each other  

Generate 2-way 
distance entries TRUE (FALSE) If TRUE, will calculate distances To and From stops 

Stem Distances Only TRUE (FALSE) If TRUE, will calculate distance between the Terminal and 
City where the stop is located (not the stop itself)  

In Cone 

TRUE (FALSE) 
 
(Angle and radius created from 
the terminal, defaulting to 57º) 

If TRUE, only stops within the Angle or Radius may be 
added to the selected route  

Overwriting Existing 
Entries TRUE (FALSE) If TRUE, will overwrite any Distance File in the 

DirectRoute Data Folder 

Within Territories TRUE (FALSE) Set to TRUE, will generate a Distance File with distances 
listed between EqCodes of the same type 

Route Across 
National Border TRUE (FALSE) 

If TRUE, will allow route to cross Canada and/or Mexico 
borders; if FALSE, will prevent routes from crossing 
borders (may result in more miles) 

Commercial 
Restrictions TRUE (FALSE) Option for Prophesy to use only roads permitted for 

commercial vehicles 

Avoid Toll Roads TRUE (FALSE) If TRUE, keeps trucks from using toll roads 

Use DirectRoute 
Drive Time TRUE (FALSE) 

If TRUE, will generate distances and drive times using 
DirectRoute calculations (instead of any optionally 
installed Mileage System or Historic Traffic Data. 

Threading Single Thread For use when generating Distance File, multi-core CPU = 
set threading to Multiple, otherwise set to Single 

Distance File  Location to save Distance File, generated during 
pre-process 

Use Mileage System 
Drv Time if it is > 
DirectRoute Drv Time 

TRUE (FALSE) 

If TRUE and an optional Mileage System is installed, it 
will use the optional Mileage System’s drive times when 
generating the Distance File if those drive times are 
greater than DirectRoute’s calculated drive times. 

GEOCODING   
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Geocode Stops TRUE (FALSE) If TRUE, will Geocode Stop File before routing 

Clean Address TRUE (FALSE) If TRUE, calls the Address Clean up module to clean the 
records prior to Geocoding 

Skip Geocoded 
Records TRUE (FALSE) If TRUE, will skip any records that have been previously 

Geocoded 

Color Code Stops TRUE (FALSE) If TRUE, color codes stops  

Update Address, City, 
and Zip TRUE (FALSE) If TRUE, updates corrected Address, City and Zip 

APPLY BOUNDARY   

Apply EqCodes to 
stops TRUE (FALSE) If TRUE, applies EqCodes to stops 

Drawing File Name  Name of the Drawing File (if used) 

Overwrite Existing 
EqCodes TRUE (FALSE) If TRUE, overwrites existing EqCodes 

APPLY DEFAULTS   

Apply Defaults TRUE (FALSE) If TRUE, enables the Stop Filter selection during the 
routing process (activates the Stop Filter Pop-up menu). 

Overwrite Existing 
Entries TRUE (FALSE) If TRUE, overwrites existing entries in Stop File 

FIXED ROUTE   

Run Fixed Routes TRUE (FALSE) If TRUE, stops are matched to trucks based on the fields 
selected to get route assignments 

Truck File Matching 
Field Trk ID Select a field from the Truck File 

Stop File Primary 
Matching Field Trk ID Select field in the Stop File that corresponds to the field in 

the Truck File 

Stop File Secondary 
Matching Field Driver Select the field in the Stop File that corresponds to the 

field in the Truck File 

Copy Sequence TRUE (FALSE) If TRUE, sequence number will be copied from the 
selected field to the SEQ field 

Stop File Sequence 
Field  Select the field that has the sequence number 

Get DOW Sequence 
Code Based Upon 
Pattern 1 

TRUE (FALSE) For fuel-specific functions 
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Overwrite Route and 
Sequence TRUE (FALSE) If TRUE, will overwrite existing Route and Sequence, if 

any, already in the Stop File 

Generate Route 
Directions TRUE (FALSE) If TRUE, will generate route directions after routes are 

built 

Enable Stop Filter 

TRUE (FALSE) 
(Applies to selected records 
only, versus all records in the 
Stop File) 

If TRUE, will enable the Stop Filter during the route 
building process 

ROUTING  Options for Automatic Load Building and Optimization  

ALGORITHM 
SETTINGS   

Add Turn Time TRUE (FALSE) 
If TRUE, and redispatch is selected in the Truck File, 
DirectRoute will add the specified turn time to the route 
work time 

Algorithm  

REGULAR–Normal two-way 
routes 
DOW–Day of Week, for fuel 
specific functions 
INBOUND–Route from stops 
back to depot, similar to a 
one-way inverted route 
FARTHESTIN–Two-way 
routes from the farthest stop 
back to the depot 
OUTBOUND–Farthest stop is 
the last stop, with return to the 
depot 

Select the desired Algorithm type to use 

Box Expand 

5  
Note: When optimizing, the 
software constructs the 
smallest box that will contain 
all the stops on a route; 
parameters affect the 
optimization process. 

Number of miles (size of box around stops); default is 1 

Check In Cone 

TRUE (FALSE) 
 
(Not recommended for 
One-way routing) 

If TRUE, forces the software to select and group stops in 
a geographical direction  

Cone Angle 55 Angle of cone, with depot at center; default is 55 

Depot Radius 10 Radius around depot (miles) to which stops can be 
loaded on same route out of cone; default is 10 
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Lambda 

2 
 
(Determines how much weight 
to give cone expansion vs. 
distance from depot) 

Used by Algorithm when deciding which stop to load on a 
route next. Lambda should never be less than 0.1 or 
greater than 2.0. 

Lambda Increments 

0.2 
 
Ex: If Lambda is = .6, 
increments = .2, and iterations 
= 4, the software will construct 
routes four times (iterations) in 
increments of .2, starting at .6 
(ex .8, 1, 1.2) 

Incremental value added to LAMBDA for each iteration, 
when constructing routes 

Lambda Iterations 

1 
(To find which value yields the 
lowest cost solution, run 
several routes using 1 thru 4) 

The number of times the software will build routes using 
the Lambda Values  

Max Redispatch 
Iterations 

4 
 
(How the software determines 
the feasibility of redispatching 
a route) 

If set to 4, the software creates up to 4 load passes to 
determine the best scenario 

Max Wait Time 2 Maximum amount of time in hours a vehicle will be 
allowed to stay at a stop 

Max Dist Between 
Stops 250 Prevents stops that are more than X miles apart from 

loading on the same route 

Optimize Stops After 
Loading TRUE (FALSE) If TRUE, moves stops between and within routes to 

minimize cost 

Optimize Trucks After 
Loading 

TRUE (FALSE) 
 
**Cost must be lower in the 
Truck file for these smaller 
assets in order for optimization 
to occur 

If TRUE, moves loads from bigger to smaller trucks to 
minimize cost; if using various vehicle sizes in the Truck 
File, set to TRUE 

TW Gap For Buffers 1.75 

If early and late buffer overlaps the gap between time 
windows, then they are adjusted to have the specified 
amount as gap between time windows. Value is entered 
as decimal miles. 

Load Backhaul Stop 
on Empty Truck TRUE (FALSE) If TRUE, loads backhaul stop on empty trucks 

Max Out of Route 
Miles For Backhaul 1000 Set max miles to consider for backhaul route; if stop is 

farther than this, it will not be considered for backhaul 
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Max Percent Out of 
Route Miles for 
Backhaul 

50 Set max percentage of route miles, instead of distance, to 
consider for backhaul 

Max Closest Stops 200 
After the Route seeding process by the algorithm, it will 
analyze this number of the closest stops to determine 
which are candidates to load next onto the same route 

Refuel Algorithm 

Original, Distance Based 
 
Original - Default option, works 
using the existing algorithm; 
will insert refuel points based 
on location, in reference to 
stop locations. 
Distance Based - Will keep 
track of route capacity and 
adds refuel points only when 
capacity is available and still 
30% of work time left in a 
route. This option will also 
remove refuel points when not 
needed. 

Select which algorithm to apply during routing.  

Add Pre-Post time on 
redispatch TRUE 

When TRUE, adds Pre/Post time on all legs. When 
FALSE, adds only for the starting and ending terminal on 
the whole route. 

Use Terminal as 
Refuel Point TRUE When TRUE, considers the terminal as a refuel point. If 

false, DR does not consider the terminal as a refuel point. 

Max Routes Per ID1 -1 
Max number of routes for which 1 unique ID1 could be 
placed onto separate routes if multiple orders exist for the 
same ID1. Less than 1 will disable this feature. 

GENERAL   

Enable Start Time 
Column 

TRUE (FALSE) 
 
Using this function removes 
the necessity to edit individual 
routes each time a change is 
needed to the actual route 
start time.  

When TRUE and Start Time column is added to the Stop 
File, DirectRoute will use the Start Time listed in the Stop 
File as a route dispatch time when initializing routes. 

Allowing Logging TRUE (FALSE) If TRUE, sets tracking mechanism for algorithm xml 

Display Build Route 
File tab option 

TRUE (FALSE) 
(For DRTrack users) 
 

Show/Hide Build Route File tab on New Route dialogue 
box 

Distance Cache 1000000000 Max size of cache used for Distance File records 

©2026 Trimble Maps​ 48​ ​  Mar -26 



DirectRoute User Guide​ ​ 26.1 

 

FIELD SAMPLE ENTRY EXPLANATION 

Drop Count 0 

The Drop Count setting affects the DropCost calculation 
for each route by reducing the number of stops on each 
route that will incur a DropCost. Route DropCost = 
(number of stops on route – Drop Count setting) x 
DropCost from the TruckFile. Note that if the number of 
stops on a route is less than the Drop Count setting, then 
that route’s DropCost will be negative.  

Field used in 
Distance File Lat/Lon Field other than city (account, zip, etc) to use in Distance 

File 

Lock on Init and Load   
Options are: No lock, Prevent removal, Prevent addition, 
Prevent removal and addition, Prevent any changes. 
Read more about Init and Load and Lock Routes. 

Make Empty Trucks 
Unavailable after 
loading 

TRUE (FALSE) If FALSE, allows empty trucks to be loaded during the 
Modify Load process 

Maximum Stops Per 
Route 50 Set max number of stops per route. Affects Load 

algorithm, not Optimization 

Mileage Adjustment 100 Percentage to adjust calculated mileage; default is 
baseline 100. Ignored if distance entries are used. 

Minimum Time 
Between stops 
(minutes) 

0 Minimum time between stops; overrides drive time 
calculations if calculated time is less than this number 

Apply Min Time 
Between Stops after 
directions 

TRUE (FALSE) If TRUE, will automatically apply the Min Time Between 
Stops (Min)  

Route Colors (Collection) Define colors for each route 

Route Line Width  Use the dropdown menu to select the width of the line 
displayed on the map (planned routes on the map) 

Color Empty Miles  Use the dropdown menu to select a color to apply on the 
map to portions of a route performed by an empty vehicle 

Scale Factor 0 Used to increase miles on a route using percentages. Ex: 
1.1 = 110% 

Secondary Route 
Identifier TrkID Secondary Identifier for a Route 

Speed  50 
(50 =50 mph) Sets an average speed on a route  

Speed Adjustment 
(Drive Time) 

95 
 

% to increase or decrease Drive Time; default is 100. 
10% increase = 110 
10% decrease = 90 
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FIELD SAMPLE ENTRY EXPLANATION 

Increase drive time = 
decreases vehicle speed  
Decrease drive time = 
increases vehicle speed  
Ex: 95 = Decreases drive time 
5% by increasing vehicle 
speed by 5% 

Use DirectRoute 
Drive Time TRUE (FALSE) If TRUE, used DirectRoute drive times instead of other 

installed Mileage System 

Rush Hour Distance 

0 
 
Required if the user is 
attempting to use AM/PM 
Speed Adjustments as found 
in either the Truck File or Stop 
File. Sets a radius around 
either the Truck originating 
point or the stop location  

Distance in which adjusted speed is implemented to 
account for traffic delays; used in conjunction with Speed 
Adjustment and AM/PM Adj fields in the Stop File and/or 
Truck File. 

Dispatch Date Offset 1 Number of days out from the date routes are run, to begin 
dispatch/delivery 

CONSOLIDATE 
SETTINGS 

Note: Consolidation settings 
are validated each time the 
settings are updated 

If TRUE, consolidates stops with same settings  
(Time Windows, EqCodes, Lat/Long, Size Restrictions, 
etc.) 

Consolidate by ID1 TRUE (FALSE) If TRUE, consolidates stops by value in ID1 

Consolidate by ID2 

TRUE (FALSE) 
 
Note: An error message will be 
generated if Consolidate by 
ID2 is set to TRUE and both 
Consolidate by ID1 & 
Consolidate by Address is set 
to FALSE; this setting must be 
corrected to save/close the 
dialog box, or select Cancel to 
exit without saving the 
erroneous setting changes) 

If TRUE, consolidates stops by value in ID2; set to 
FALSE if Consolidate by ID1 and Consolidate by Address 
are both set to FALSE 

Consolidate by 
Address TRUE (FALSE) If TRUE, consolidate stops by address 

Consolidate (Sum) 
Fixed Times TRUE (FALSE) If TRUE, will consolidate all stops to the Fixed Time of 

first stop in the group 

Consolidate on 
Initialize TRUE (FALSE) If TRUE, consolidates routes upon initialization 
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FIELD SAMPLE ENTRY EXPLANATION 

STATIC SPLITTING  Restrictions for Split Loads 

Split Size 0 Sets minimum size of load to split. Generally, set with 
split stops 'TRUE' and split orders 'FALSE' 

Split Stops TRUE (FALSE) If TRUE, allows splitting a stop between routes 

Split Orders TRUE (FALSE) If TRUE, allows splitting an order (by line item) between 
stops 

Split Line Items TRUE (FALSE) If TRUE, allows splitting of line items between stops 

Quantity Field To Split None Qty field used to calculate splits (i.e. weight, cube, 
Pallets, etc.) 

DYNAMIC 
SPLITTING  Restrictions for Routes with low stop counts 

Split Stops While 
Loading TRUE (FALSE) 

If TRUE, will split the load to ensure delivery of the 
product; if FALSE, the remaining parameters for Dynamic 
Splitting are inconsequential 

Split Orders TRUE (FALSE) 
If TRUE, software will consider splitting an order by line 
item, between routes; if FALSE, will only split stops by full 
orders 

Split Line Items TRUE (FALSE) 
If TRUE, software will consider splitting stops at the line 
item level; only valid for stops that have just one order 
with one Line Item  

Evaluate All Splitting 
Options TRUE (FALSE) Evaluates splitting options during optimization process 

Max Splits Per Stop 0 
(generally, just 1 or 2 times) Max number of splits per stop  

Min Split Size 0 Minimum size (Quantity 1 field) for a split order 

Splits-Truck Full 0 Used in conjunction with Min Split Size; determines 
vehicle capacity percentage used for split loads 

GRAPH  Fields from the Truck File, to appear on the Graph Chart 
in the Route Book 

Route Identifier 1 None Route identifier, from the Stop File 

Route Identifier 2 None Route identifier, from the Stop File 

Route Identifier 3 None Route identifier, from the Stop File 

Route Identifier 4 None Route identifier, from the Stop File 

Route Identifier 5 None Route identifier, from the Stop File 

Route Identifier 6 None Route identifier, from the Stop File 
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FIELD SAMPLE ENTRY EXPLANATION 

STOP CAPACITY 
ADJUSTMENT  Allows lowered vehicle capacity based on the number of 

stops 

Capacity Field None Qty field to use for stop capacity adjustment 

Stop Adjustment 0 Amount of Qty to reduce capacity 

CROSS 
DOCK/RELAY 
ROUTES 

 Use with Relay and Cross Dock Files 

Cross Dock Col 
Identifier  Column heading in Cross Dock File to identify cross dock 

location  

Cross Dock File Path  Location of the Cross Dock File 

Relay File Col 
Identifier  Column heading in the Truck File that identifies a Relay 

Route 

Relay File Path (.xls, 
*.xlsx)  Location of the Relay Truck File 

PASSWORD 
PROTECTION  Pswd protection for Routing Category 

Enable TRUE (FALSE) Default is FALSE 

Password TRUE (FALSE) Add/Edit password 

TANKER  Used for load building compartmentalized vehicles 

Weight  Choose from Volume fields 

Volume  Choose from Volume fields 

Count  Choose from Volume fields 

Tote File Name C:\Program Files\Appian\ 
DirectRoute\Data\ Tote.xls 

Name and path of the Tote File, typically found in the 
DirectRoute Data Folder 

Product Ratio File 
Name 

C:\Program 
Files\Appian\DirectRoute\Data\ 
Ratio.xls 

Name and path of the Ratio File, typically found in the 
DirectRoute Data Folder 

Use Tanker Algorithm 
for Product 
Assignment 

TRUE (FALSE) If TRUE, uses tanker algorithm to ensure products loaded 
on trucks are placed in designated compartments 

Max Number of Totes 
Per Order 10 Max number of totes allowed on each order 

Split Orders to Totes TRUE (FALSE) If TRUE, allow splitting of orders into totes; if FALSE, 
attempts to split the order will only be done on tanks 
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FIELD SAMPLE ENTRY EXPLANATION 

Split unloaded stops 
and try loading FALSE Split unloaded stops and try loading 

Trimble Maps   

Thread Count 8 

Sets the number of threads to use during the distance 
generation process. Max threads = 16. Enter 0 to use all 
threads possible. This can slow down your computer 
during processing. 

Elevation 30000 

Sets the elevation limit for routing. The unit of measure is 
based on Other > Distance Options. If the Distance 
Option is set to Miles, elevation is entered as feet. If set 
to KM, elevation is entered as meters. 

Route Across 
National Border TRUE (FALSE) 

If TRUE, will allow route to cross Canada and/or Mexico 
borders; if FALSE, will prevent routes from crossing 
borders (may result in more miles) 

Route Type Practical, Shortest, or Fastest Sets the routing type when getting directions 

Avoid Toll Avoid Options are Avoid, Discourage, or Use 

Hazardous Option None Indicates the directions hazard options 

Vehicle Profiles (Collection) Vehicle profiles (sizes) 

Distance Generation 
Mode Pair (Matrix) Option to change how Trimble MAPS generates distance 

entries 

Default Vehicle Profile Select one from Vehicle 
Profiles (above) Default vehicle profile to use 

Use Historical Traffic 
Data FALSE (TRUE) Use historical traffic data 

Highway Only FALSE (TRUE) Indicated if the route should travel on highways and/or 
primary roads only. 

Data Version Current The PC*Miler version to use for route calculations. 
Options are PCM18 to Current 

UPDATE STOP FILE   

Primary Identifier ID1 Primary Stop File field 

Secondary Identifier ID2 Secondary Stop File field 

Third Identifier ID3 Tertiary Stop File field 

Convert TW TRUE (FALSE) Convert old style time windows to new 

UPLOAD  Options for uploading Route Files to OBCs, terminal 
systems, etc. 
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FIELD SAMPLE ENTRY EXPLANATION 

Upload Consolidated TRUE (FALSE) If TRUE, consolidated orders will be uploaded in 
consolidated format  

Upload Displayed 
Only TRUE (FALSE) 

If TRUE, will write (to the Upload File) only those routes 
that are locked and displayed on the map; if FALSE, will 
write ALL routes  

Upload Header 
Record TRUE (FALSE) If TRUE, adds Header row at top of the Upload File  

Upload Starting 
Terminal TRUE (FALSE) If TRUE, adds the beginning terminal/distribution center 

to the Upload File 

Upload Ending 
Terminal TRUE (FALSE) If TRUE, adds the ending terminal/distribution center to 

the Upload File 

Upload Date Format MM/DD/YYYY Choose date format 

Upload Format File 
(*urp)  Enter path and file name of URP File; If used, system will 

not prompt for the info during upload process 

Upload File Name RTUPLOAD Default name for the file it can be changed later in the 
Data Folder) 

Upload File Path (Blank) Location of the Upload File, if different than current Data 
Folder  

Upload File Type *.UPL Enter type (Upload File) used 

Upload XML Version 5 XML version number used 

Upload Sequence TRUE (FALSE) Set to TRUE, will list the route and sequence number 

OBC Upload None Allows choice of onboard computer system (XATA, 
PeopleNet, etc.) to Upload File format for OBC File 

OBC Folder Path  Path to OBC File 

OBC Upload File 
Name RTUPLOAD OBC Upload File name 

Upload Time Format Hmm, HHmm, H:mm, HH:mm Choose time format 

V8 Compatible TRUE (FALSE) Backwards compatibility with DR Version 8 

Display Arrival and 
Departure Time on 
Consolidated Order 

TRUE (FALSE) If TRUE, will display the same arrival and depart time for 
consolidated orders on the same stop  

Display Miles on 
Consolidated Order TRUE (FALSE) If TRUE, will display the same miles for consolidated 

orders on the same stop  

Display Unload Time 
on Consolidated 
Order 

TRUE (FALSE) If TRUE, will display the same unload time for 
consolidated orders on same stop 
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FIELD SAMPLE ENTRY EXPLANATION 

Ignore Terminal in 
XML Upload TRUE (FALSE) If TRUE, ignores the terminal stop in the Upload File 

when appropriate 

Display Drive and 
Work Time on 
Consolidate 

FALSE (TRUE) Displays drive and work time on consolidated orders 

Abbreviate Rt 
Violation FALSE (TRUE) Abbreviate Route Violation 

Display Total 
Distance on 
Consolidated Orders 

FALSE (TRUE) Display route total distance on consolidated orders 

Figure 25–Routing Preferences and Options Table 
  

2.3.2.​ Lambda and Lambda Values 
Lambda is a variable factor that controls how much weight to give a potential stop based on how far it is away 
from a depot (cone expansion vs. distance from the depot) during the loading phase of the algorithm. The routing 
algorithm uses lambda when it is deciding on which stop to load on a route next. 
 
Lambda Values are typically between 0.5 and 2.0, depending on the density of the stops in your delivery area (a 
high density of stops usually calls for a lower Lambda value).  

•​ The default setting for Lambda is 2, which provides the best results over a large range of problem 
types. 

•​ Setting Lambda Value to less than 2 will cause DirectRoute to build tighter routes (less expanded 
cones) but might result in an overall increase in miles.  

•​ For high stop count routes (very dense), you might consider lowering the Lambda Value, but it would 
be best to run a few scenarios with various Lambda Values (1 thru 1.5) to determine the right number. 

Example: Assume that the depot is represented by the green diamond and the three red dots are stops to be 
routed. Each stop has a volume equal to one half of a vehicle’s capacity. Given this set of facts, it will require two 
vehicles to service the three stops. The algorithm will typically load the farthest stop from the depot first, in this 
case that is Stop A. The next decision is to determine which of the remaining stops to load. This decision is based 
on a combination of how much mileage the prospective stop will add to a route and how far the stop is from the 
depot times the Lambda factor. 
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If Lambda were set to zero (thereby giving no weight to how far the stop is from the depot) the stop selected to be 
loaded next would be Stop C, since it adds almost no additional mileage to a route already going to Stop A. This 
vehicle would now be full and require the second route to service Stop B. This solution would have higher miles 
than the solution that paired Stops A and B, and a second route containing Stop C. 
 
The following (High Lambda, Low Lambda) depict two sets of routes running the same stops with a low and high 
Lambda Values. 
 

 
Figure 26–Lambda 
 
You can see that the routes ran with the higher Lambda attempt to pick up the stops farther away from the depot. 
Although the high Lambda routes may not look as good as the low Lambda routes they are actually 3% fewer 
miles because they are only running two trucks to the outer perimeter stops (the red and black routes) versus 
three routes in the low Lambda scenario.  
 
To edit Lambda settings, select from the DirectRoute menu: File > Preferences > Other. There are three values 
to set; experiment with the value of Lambda and decide which setting is best for your routing environment: 

•​ Lambda Setting–Specifies the initial value of Lambda, or the value of Lambda to use for running 
Iteration 1; default value is 2 and ranges can vary from .1 up thru 2.0. 

•​ Lambda Iterations–Number of times to calculate routes using increments. 

•​ Lambda Increments–Value used to increase Lambda while calculating routes; allows several 
attempts at a routing solution that yields the lowest cost.  
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Example: Suppose Lambda is set to 0.6 and Lambda Increments and Iterations were set to 0.2 and 4, 
respectively. DirectRoute will construct routes four times using Lambda Values of 0.6, 0.8, 1.0, and 1.2 and 
display the solution that yielded the lowest cost.  

 

Tip: Once the best settings are discovered, the Iterations should be set back to 1. Keeping a higher iteration 
setting will cause the route to be re-run several times, even once the best Lambda Settings have been found. 

 

Note: When using Redispatch, it is recommended that Lambda Iteration 1 be used. 

 

Caution: When using Lambda with Iterations, and cancel is pressed, the user must cancel each of the iterations 
as they begin. When one is canceled, the next route begins to load. 

 

2.3.3.​ Box Expand and Box Expand Values 
Box Expand is a parameter that defines which routes are considered for between route optimization. During 
optimization, DirectRoute constructs the smallest box that will contain all the stops on a route. When DirectRoute 
considers making moves, the logic does not consider moving stops between routes, unless their boxes intersect. 
This includes routes that are in the same vicinity. 
 

 
Figure 27–Box Expand 
 
The Box Expand Value is represented in miles and determines how far to expand the box. Larger numbers 
increase the time it takes for the system to complete optimization; adjusting the parameter allows the system to 
consider more routes during optimization.  
 
The miles would be saved if Stop 4 (black route) was placed on the red route. By increasing the parameter to 25, 
the boxes now intersect, thus allowing more moves to be evaluated. The increased value of Box Expand will also 
increase the amount of time the system takes to complete the optimization process. 
 
To edit Box Expand Values, select from the DirectRoute menu: File > Preferences > Other. Enter the number of 
miles to identify how far to expand the box. 

 

©2026 Trimble Maps​ 57​ ​  Mar -26 



DirectRoute User Guide​ ​ 26.1 

 

3.​ Route Files 
The Route Files are used primarily to provide fleet (truck) and customer delivery information to DirectRoute. While 
directions for creating these files are covered in the following section (Creating Route Files), below is a brief 
description of each of the files used.  

•​ Account Master File–The Account Master File, sometimes referred to as the Customer File, is an 
Excel spreadsheet, an .xls file, with all of the standard information about each of your customers, and 
their locations. This is not an order file, but more of a contact list, with static information that does not 
change with each order received by the customer (i.e. point of contact, address, account number, 
etc.). Each location you deliver to for each customer will have a record entry in the spreadsheet, 
containing all permanent information about the customer location; address, Lat/Long coordinates, 
time windows, time at the stops, and any other pertinent info necessary for delivery to each location. 
The data for this file is usually exported from an Order Management/Host system (OMS) or 
ERP/WMS and copied into or formatted as .xls spreadsheet. Each location will have a record entry in 
the spreadsheet, containing all permanent information about the customer location; address, Lat/Long 
coordinates, time windows, time at the stops, and any other pertinent info necessary for delivery to 
each location.  

•​ Stop File (Daily Order File)–The Daily Order File, also referred to as the Stop File, is used in the 
extract process, along with the Customer Master File, to correctly set up orders to Route. It too is 
normally extracted from an Order Management/Host system (OMS) and copied into or formatted as 
.xls spreadsheet. It may come out of the OMS as a tab delimited text file, with an .xls extension, or a 
comma delimited file with a .csv file extension. It is not as detailed as the Customer Master File and 
will only contain the current order info (order quantities, loading instructions, etc.) for each customer 
that will be used to create routes for the day.  

•​ Truck File–The Truck File is a spreadsheet that will contain all the information about each truck in 
your fleet, and the drivers to whom routes will be assigned. In the Truck File, every row represents 
one Truck/Driver combination to which stops can be assigned/loaded. The key fields in the Truck File 
are truck availability, driver availability, vehicle start time and end times, truck capacity, variable cost 
factors, and work rules for both the trucks and drivers. 

•​ Distance File – The Distance File contains a record of distances and drive times between the pickup 
point and every city in the Stop File, and/or pick up every Stop, to include from, to, and in between. 
When a Distance File is used in the routing process, DirectRoute will calculate the distances and 
times between each stop location based on the entries in this file. If a Distance File is not used, 
DirectRoute will calculate distance and drive times using an adjusted straight-line distance between 
locations. 

 

3.1.​ Creating Route Files 
The Route File used to provide DirectRoute specifics concerning your customers and fleets are necessary to 
create any route. Creating and/or updating these files are key steps that must be done to initiate a routing project. 
The following sections will guide you through the process of creating and or updating the regular used files.  
  

3.2.​ The Stop File 
The Stop File is a spreadsheet that contains the customers’ order and delivery information. Key fields represented 
in the Stop File include order volume, required delivery dates, customer address, and any special delivery rules; 
all critical information the software needs to build the routes. Optional data fields can also be used to manage 
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customer schedules and territories, provide statistical data, or generate reports, and/or generate additional Route 
Files. 
 
If you already have a Stop File, or a spreadsheet with the required customer information, it can be used in the 
project so long as it contains the required data columns. If you do not already have a Stop File, a new one can be 
created that will automatically populate the necessary header columns and allow manual input of all customer 
data.  
 

3.2.1.​ Create a New Stop File 
•​ From the menu, select File > Open > Stop, or File > New > Stop. 

•​ Enter each customer’s data directly into each column of the spreadsheet, or double-click each row to 
launch the Stop Dialog box and enter all the data for each customer in one window. 

•​ Stop File Fields and Descriptions Table identifies and explains each field that is required or 
recommended to be used in each Stop File. 

 

The Stop Dialog box is divided into five sections:  

•​ General–Add the General information, including customer name, account number (unique identifiers), 
address, type of symbol, route and stop numbers (if predetermined), fixed time, EqCodes, and truck 
size restriction. 

•​ Location–Add Location information, symbol, and color code options. Long/Lat will be added later 
when the completed Stop File is geocoded. 

•​ Stop Volume–Add Volumes and unload rate information. 

•​ Time Windows–Add Time Windows (Open/Close) and pattern (days of the week); use military time 
(1:30PM = 1330), and enter Earliest/Latest Date, Buffers and Penalty (if used). 

•​ User Fields–Add the field data for each field listed (Preferences > Configuration). 

 
Figure 28–Stop File Dialog Box 
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When all entries have been completed for the customer, select Close > Accept to close the box. 
Repeat as necessary for each individual record. 
 
After all customer data has been entered into the Stop File: 

•​ Geocode the Stop File to locate the correct Lat/Long for each record in the file (see Geocoding 
Records). 

•​ Save the updated Stop File in the DirectRoute Data Folder. 

•​ Select File > Save, or File > Save As, and assign a name to the file. 

 

3.2.2.​ Stop File Fields and Descriptions Table 

FIELD NAME DESCRIPTION REQUIRED 
OR OPTIONAL 

Name The name of the customer/business (stop) to be delivered. Required 

Contact The name of a contact at the customer stop. Optional 

Phone Telephone number at the stop location. If the Area code is included, 
the software can use it for geocoding. Optional 

ID1 
Primary unique identifier for the customer/stop.  
Ex:: Account#, Customer#. User defined field in Preferences > 
Configuration. Used in the extract files process. 

Required 

ID2 
Secondary unique identifier for the customer/stop.  
Ex: Store#, Stop#. User defined field in Preferences > 
Configuration. 

Optional 

ID3 
Tertiary unique identifier for the customer/stop.  
Ex: Line Item, SKU. User defined field in Preferences > 
Configuration. 

Optional 

Address 
Street Address for the customer. Address, along with City, State, and 
Zip are used to geocode by address. Also used by the Address 
Cleanup module. 

Required 

Address2 Additional Address information.  
Ex: Suite#, building#, Door#, Dock#. Optional 

City 
Name of the city (Address). This field can be used in conjunction with 
the Distance File to determine distances and drive time. Required to 
geocode. 

Required 

State 2 letter state (Address) abbreviation.  
Ex: WA, CA, OR. Required to geocode. Required 

Zip The zip code (Address). Can be used for geocoding in conjunction 
with the Address field or geocoding by 5-Digit or 9-Digit Zip. Required 

Country This column will be used during the geocoding process for passing 
country code to the mileage system. If no value is present in this USA/US 
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FIELD NAME DESCRIPTION REQUIRED 
OR OPTIONAL 

column, the country code set in the Preferences will be used. The 
value in this column should be ISO2 or ISO3 country code format 
(i.e. valid country code for the US is USA/US and for Canada 
CAN/CA). If no address information is given in the file, DR will try to 
geocode the stops using City, State, and Zip. 

FixedTime 

Used to identify a required/mandatory time that all vehicles must 
spend at the stop (in addition to unload rate/time). Can be used to 
account for completing required paperwork. Input Fixed Time in 
minutes; may be different for each customer.  
Ex: An entry of 15 would require the truck to be at the stop for 15 
minutes, in addition to the time calculated by the UnldRate. Total time 
at the stop will be calculated by the software by adding these two 
fields together.  
 Note: DR will route without this field, but in practice a Fixed Time is 
needed as the truck will have to stop for a certain amount of time to 
unload (and perform other activities). Typical range is 15-45 (15 to 45 
minutes). Enter the number in minutes. 

Optional 

SzRestriction 

Size Restriction will inform the software that this is the maximum size 
or volume for a vehicle that may deliver to this stop. Using a size 
restriction will limit which truck size the customer load can be put on.  
Ex: A quantity of 20,000 would mean that the customer load could 
only be put on trucks with a capacity of 20,000 or less in (Volume 1 
field) the Truck File. 

Optional 

EqCode 

An alphanumeric code used to designate special equipment or 
requirements for a stop (lift gate, refrigerated compartment, etc.). 
Corresponding Truck File field: SpEq. When EqCodes are used, the 
software will only load the stops on a vehicle with a matching SpEq 
code listed in the Truck File.  
Ex: If a stop requires a lift gate in order to complete delivery, place a 
code in the EqCode field that designates lift gate, and use the same 
code in the SpEq field on a truck in the Truck File. It is possible to 
combine the use of several EqCodes, but each code should be 
separated by a dash (i.e. AJ-BH-HH-XX). If there are no special 
requirements for a stop, this field should be blank.  
Note: There are also special EqCodes that can be utilized for Back 
Hauls, prioritizing and sequencing of stops, territory codes and 
exclusion codes.  
 

See 9.1. Special Equipment Codes for more information. 

Optional 

Volume1 

The volume to be delivered; user defined field (Preferences > 
Configuration) can be any quantity type (weight, cube, pallets, 
cases, etc.). If no volume type is entered, the software will load all 
stops on one route, or until it reaches the maximum stops per route, 

Optional 
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FIELD NAME DESCRIPTION REQUIRED 
OR OPTIONAL 

as defined by the user. The capacity fields in the Truck File 
correspond to the volume fields in the Stop File.  
Ex: Volume used is Cases; the column heading appears in the Stop 
File as Cases. Capacity 1 column heading in the Truck File will also 
appear as Cases.  
Note: Must be at least one (1) volume field in use, even if left blank. 

UnldRate (UnldVol1) 

Identifies the amount of time it takes to unload Volume1 value, in hrs.  
Ex: Volume1 = Cases. The field appears in the Stop File as 
UnldCases. It takes one hour to unload 1000 cases. A truck that 
carries 2000 cases would have an unload rate of 2 (2000 ÷ 1000/per 
hr.). The UnldRate time is added to the Fixed Time. The UnldRate 
heading will mirror the volume name defined in the Preferences > 
Configuration > Volumes (Weight = UnldWeight, Cases = 
UnldCases). 

Optional 

CloseTW 
TRUE or FALSE. When this option is set to TRUE, a vehicle must 
reach the stop, deliver, and complete unloading before the Time 
Window closes (including Fixed Time plus UnldRate).  

Optional 

Zone 

A percentage adjustment to the drive time. Default is 100 = normal 
rate of speed. An increase to the drive time will lower speed; a 
decrease to drive time will increase speed. Zone is hard coded to 
eight miles.  
Ex (Truck File): A value of 110 would increase the drive time by 10%, 
hence lowering the speed by 10%. A value of 90 would decrease 
drive time by 10%, increasing speed by 10%. The speed adjustment 
is only applied to the first 8 miles of each route segment (from 
Depot).  
Ex (Stop File): If all customers in downtown Chicago have a value of 
110 in this field, the software will increase drive time for the stops in 
downtown Chicago (within the 8 mile radius), while lowering the 
speed of travel. 

Optional 

AMStart Set AM start time to adjust speed to account for heavier/lighter traffic. Optional 

AMEnd Set AM end time to adjust speed to account for heavier/lighter traffic. Optional 

AMAdj 

Set drive time adjustment for AMStart and AMEnd. AM/PM Adjust 
works the same as Zone; increase the number (110) to increase the 
drive time by 10 percent. In turn the speed is decreased by 10 
percent. The radius is based on the rush hour distance setting 
(Preferences > Routing > General). Zone is hard coded to eight 
miles, while AM/PM Adjust is based on the rush hour distance.  

Optional 

PMStart Set PMStart to adjust speed to account for heavier or lighter traffic. Optional 

PMEnd Set PMEnd to adjust speed to account for heavier or lighter traffic. Optional 
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FIELD NAME DESCRIPTION REQUIRED 
OR OPTIONAL 

PMAdj Set drive time adjustment for PMStart and PMEnd. See AMAdj for 
additional info. Optional 

Open1 

Earliest time of day delivery can be made. Using Military Time format 
(0000-2400), delivery time windows are entered in the Open1 and 
Close1 fields. Multiple Time Windows can be established (up to ten), 
and are defined as Open1, Close1, Pattern1; Open2, Close2, 
Pattern2; Open3, Close3, Pattern3 and so forth.  
Ex: Customer can receive deliveries between 800 and 1130 on 
Sunday, Wednesday, and Saturday. This corresponds to 
Open1=0800, Close1=1130, and Pattern1=SWA. 

Required 

Close1 The latest time a delivery can be made. See Open1 for additional 
info. Required 

Pattern1 

Days of the week when the customer will accept deliveries. Time 
Windows are entered as patterns of opening and closing times and 
days of the week (SMTWRFA) that define when the customer will 
accept deliveries.  
Ex: Customer can receive deliveries between 800 and 1130 on 
Sunday, Wednesday, and Saturday. This corresponds to 
Open1=0800, Close1=1130, and Pattern1=SWA. S=Sunday, 
M=Monday, T=Tuesday, W=Wednesday, R=Thursday, F=Friday, 
A=Saturday 

Required 

EarliestDate 

(MM/DD/YY). May be used to ensure that a stop is not serviced 
before a specific date, or when used in combination with LatestDate, 
used to ensure the stop is delivered within a specific time window, 
and can allow multi-day/week deliveries based on date versus time 
window only. If this column is blank, it will be ignored. 

Optional 

LatestDate 

(MM/DD/YY) Used in conjunction with EarliestDate; determines the 
latest the date that the stop may be serviced. May be the same date 
as EarliestDate if there is only one day in which the stop may be 
serviced. If this column is blank it will be ignored. 

Optional 

EarlyBuffer 

Additional time before Open1 that a stop could be serviced - in Hours 
(Ex. .25, .5, 1, 2 or 3).​  Used to activate the Soft TimeWindows 
function within the software, allowing stops to be delivered outside of 
the hard time window. A penalty cost should also be used in 
conjunction as it guards against the use of the buffers when they are 
not needed. Note: EarlyBuffers and LateBuffers are used to expand 
time windows. 

Optional 

LateBuffer 

Additional time after Close1 that a stop could be serviced - in Hours 
(Ex. .25, .5, 1, 2 or 3). Used to activate the Soft TimeWindows 
function within the software, allowing stops to be delivered outside of 
the hard time window. A penalty cost should also be used in 
conjunction as it guards against the uses of the buffers when they 

Optional 
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FIELD NAME DESCRIPTION REQUIRED 
OR OPTIONAL 

are not needed. Note: EarlyBuffers and LateBuffers are used to 
expand time windows. 

PenaltyCost 

The penalty cost applies only when the delivery is within the early or 
late buffer period. The penalty is prorated, and a value of 60 is 
suggested, equal to $1 per minute of buffer time used. Without a 
PenaltyCost the algorithm interprets the Buffer Time as “free” and will 
use it to a larger degree. 

Optional 

MaxSplits Max number of splits allowed for a stop Optional 

Rt 

Route Number will be populated when the Stop File is routed. If there 
is already a value in this field, the software will automatically place 
the stop on this route. When Redispatching is used, the entry may 
have two numbers, separated by a comma.  
Ex: 3, 1. The first will denote the Route Number, and the second will 
be the Leg Number on that route.  

System Defined 

Rt2 (Transportation Modeler) The Destination Route#, populated by the 
system during the shipment building phase. (Rt1 will be OriginRt #) System defined 

Seq 

Sequence Number (the order of loading on the route) will be 
populated by the software during the routing process and refers to 
the order of the stop on the route. If there’s already a value in the 
field, the system will automatically place the stop in this sequence  
Ex: If the value is 3, indicates the customer is the third stop on the 
route. 

System Defined 

Seq2 
(Transportation Modeler) The Destination Sequence#, populated by 
the system during the shipment building phase. (Seq1 will be the 
OriginSeq#) 

System defined 

Priority Used with the Priority Routing Tool, to apply and adjust appropriate 
weight factors for prioritization during the routing process.  

Any number (1– 
9999) 

Longitude Coordinates that define where a customer is located. Geocoding is 
the process used to identify these coordinates. System Defined 

Latitude See Longitude. System Defined 

AddressErr Error description, if any, assigned by system when the record is 
geocoded. System Defined 

GeoResult 

Results received when the geocode process concludes. Indicates 
level of accuracy match to the address.  
Level 1–An exact match was made; for street addresses, trust is 95% 
or greater AND if address is outside the range listed in the database, 
the top match is within 100 address units of input address; OR for 
any other match level if there are multiple matches they are all within 
1 air mile of each other.  

System Defined 
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FIELD NAME DESCRIPTION REQUIRED 
OR OPTIONAL 

Ex: “100 Main Street” was input; the best match in the database is 
“150-250 Main Street”.  
Level 2–Inexact match but unique result (i.e. there is only one 
match).For street addresses, trust is 85% or greater AND if address 
is outside the range listed in the database, the top match is within 
500 address units of input address*; OR for any other match level if 
there are multiple matches they are all within .5 air miles of each 
other.  
Ex: “100 Main Street” was input and the best match in the database 
is “450-550 Main Street”.  
Level 0–Inexact match and there is more than one match in the 
database. For street addresses, trust is 50% or greater. Z1–Zip5 
match. Z3–ZIP9 match.  
No results found–Record not geocoded (results column blank). 

Symbol 

Specifies the symbol used to represent a stop when displayed on the 
map (Stop File is open). Symbols are chosen in the Stop File; double 
click on the Symbol column/field to open the dialog box; make the 
selection, then select the OK button. 

Optional 

Size Specifies size of the symbol to be displayed on the map. Default is 8. Optional 

Color Specifies the color of the chosen symbol. Select colors in the same 
fashion/at the same time as selecting symbols. Optional 

Selected 
TRUE or FALSE; displays the selected stop on the map. This field is 
not used when routing but is useful for performing various operations 
when editing and modifying routes. 

Optional 

MinDaysBetween 
Deliveries 

(SchedulePro) The minimum number of days required between 
deliveries to the customer.  
Ex: A customer requires deliveries to occur no more than once a 
week, then input 7 (number of days) in MinDaysBetweenDeliveries 
column. 

Optional 

MaxDaysBetween 
Deliveries 

(SchedulePro) The max number of days allowed between deliveries.  
Ex: If a customer requires deliveries at least every two weeks, then 
input 14 (14 days) in the column. 

Optional 

Frequency 

(SchedulePro/TerritoryPro) Number of times a stop is serviced during 
a scheduled period. Enter the number conversion for the frequency 
pattern. ​
1 = 1x a week​
2 = 2x a week​
3 = 3x a week​
5 = 5x a week (daily, weekdays)​
0.5 = 1x every 2 weeks (14 day cycle)​
0.33 = 1x every 3 weeks (21 day cycle)​
0.25 = 1x every 4 weeks (28 day cycle)​
0.125 = 1x every 8 weeks (56 day cycle) 

Optional 

©2026 Trimble Maps​ 65​ ​  Mar -26 



DirectRoute User Guide​ ​ 26.1 

 

FIELD NAME DESCRIPTION REQUIRED 
OR OPTIONAL 

StemTm 
(SchedulePro/TerritoryPro) Calculated value of Distance File fields 
(FromDrvTm/ToDist/NumStops), Frequency, and Cycle; populated 
automatically when Territories are built. 

System Defined 

Day 
(TerritoryPro) Day of the week that a Territory is to be serviced; if a 
Territory covers five days, then five days may be created to reflect 
each day’s routes. 

Required 

OrgDay 
(TerritoryPro) Original Day. The previous Day the territory was 
assigned for service, if included in the data file; leave blank if not 
used. 

Optional 

Territory 
(TerritoryPro) Name or Number designation of the Territory. When the 
Territories are built, TerritoryPro will assign the Territory designation 
based on the TrkID field in the Truck File. 

Required 

OrgTerritory (TerritoryPro) Original territory. Used to list previous Territory 
designations, if included in the data file; leave blank if not used. Optional 

Locked 

(TerritoryPro) TRUE or FALSE. Indicates if column Territory should 
be locked to editing; if existing Territories are in the file, it can be 
locked so as not to overwrite what was designated. If not populated, 
TerritoryPro will return a value of FALSE when Territories are built. 

Required 

EstTime (SchedulePro/TerritoryPro) The sum of StemTm, DrvBtwnStop, and 
ServTm; populated automatically when Territories are built. System Defined 

ServTm (SchedulePro/TerritoryPro) Calculated sum of FixedTime, UnldRate, 
Frequency, Cycle; populated automatically when Territories are built. System Defined 

ForcedMode (Transportation Modeler) Designates if a shipment should be routed 
using a pre-designated mode (TL, LTL, etc.). Optional 

DropCharge Cost added as a drop charge for each shipment; input in File > 
Preferences > Routing > General (DropCount) 

Optional 
 

TLMinCharge (Transportation Modeler) Minimum charge applied for shipment by 
Truckload; populated by the Rate Orders function System Defined 

TLTeamRate​  (Transportation Modeler) The rate used for Team Drivers, if used in 
the Rate File. Optional 

TLTeamMinCharge (Transportation Modeler) The minimum charge for Team Drivers on 
Truckload shipments when used in the Rate File. Optional 

TLRate (Transportation Modeler) The Truckload rate per mile (ex. $2.5/mile 
is input as 2.5); populated by the Rate Orders function. System Defined 

LTLCost (Transportation Modeler) Cost per pound to ship via LTL; populated 
by the Rate Orders function. System Defined 

Distance (Transportation Modeler) The distance in miles between the Origin 
and Destination points; populated by the Rate Orders function. System Defined 
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FIELD NAME DESCRIPTION REQUIRED 
OR OPTIONAL 

ItineraryID (Transportation Modeler) The ID assigned to the shipment 
(automatically) during the Shipment Solution building phase. System Defined 

OID (Transportation Modeler) The origin point ID.  Required 

DID (Transportation Modeler) The Destination point ID.  Required 

Figure 29–Stop File Fields and Descriptions Table 

 

 
Figure 30–Layout of Stop File 

 

3.2.3.​ Time Windows 
Soft Time Windows allow the stops to deliver/unload before or after the actual windows, in exchange for a penalty 
cost. These are standard Time Windows, used in conjunction with Early and Late Buffers as well as the Penalty 
Cost calculations. The Penalty Cost is judged against the use of the buffers.  

Example: Early/Late Buffers = one hour, and Penalty Cost is $20/hr. Time Windows are Open1/Close1 = 
0700-1000, and Open2/Close2 = 1300-1700. The truck arrives at the stop at 0645 (early, but within the one-hour 
buffer period). Though no Window Violation is generated, a penalty is assessed against the stop: 15 min (.25) x 
$20 = $5. 

 

Tip: Only use for customers that allow early/late delivery. 

 

Time Window Gap Buffer 
The Time Window Gap Buffer should not be confused with Time Window Buffers. Time Window Gap Buffer is 
used to determine if a buffer can be used. The Gap Buffer, default 1.75hrs, will determine if Buffers can be used. 
 

Example 1: Gap Buffer ignored; Buffers used; Early/Late Buffers set to .5 (Half-an-hour). Time Windows are set to 
0700-1100 and 1300-1700. There is a two-hour gap between the latest window of the first set, and the early 
window of the second set of windows. This is larger than the Gap Buffer (1.75). In this case, the Gap Buffer would 
be ignored, and the Soft Time Windows would be used.  
 
Example 2: Gap Buffer used; buffers ignored; Early/Late Buffers are set to .5 (30 min). First Time Window: Open1 
= 0700 and Close1 = 1230. Second Time Window: Open2 = 1330 and Close2 = 1700. 
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There is only a one-hour gap between the two Time Windows. Since the Gap Buffer was set at 1.75 (# is greater 
than the one-hour gap between the two Time Windows), the Gap Buffer would be used, instead of the Buffers 
(would close the window into a solid block). 

Example 3: Delivery time = 2100 until 0300. First Time Window: Open1 = 0 and Close1 = 0300. Second Time 
Window: Open2 = 2100 and Close2 = 2400. 

The earliest period (midnight to morning) must be placed first. Ensure the midnight Time Window is covered on 
the proper day. 
 

Caution: Reversing Time Windows may cause Window Violations or failure of any stops to load. 

 

3.3.​ Account Master File 
You may already have an Account Master File (spreadsheet or database file) that contains customer data 
information that is used regularly in a Stop File. If it is not already in a worksheet (.xls) or ASCII (.csv) format, it 
will need to be converted by importing the data into a spreadsheet, or by using the Extract process in DirectRoute.  
 
You can use the Master File exactly as the name implies; as a Master File in which information is copied from to 
input into a daily Stop File or you can use the Master File as your daily Stop File. It all depends on your business 
needs, whether your daily orders from each customer are always the same, or always different. In the following 
sections, we will run through three different methods for creating this file.  
 

Tip: The ASCII format can be fixed length delimited or comma delimited. 

 

 
Figure 31–Comma Delimited (.csv) File 
 
Regardless of the method used to create the Account Master File, it should generally contain the data columns 
listed here; each item listed is either required or recommended for use in the Stop File.  

•​ Name–Name of the customer; DirectRoute will add as new if not already in the file (Recommended). 

•​ Contact–Customer contact (name) at delivery location (Recommended). 

•​ Phone–Telephone number at the delivery location; can be used to geocode the record location 
(Recommended). 

•​ ID1–A unique primary identifier, ex: Account Number (Required).  
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•​ ID2–A secondary unique identifier, ex: Store#, Stop#, etc. (Recommended). 

•​ ID3–A tertiary unique identifier, ex: Line item, SKU, etc. (Recommended). 

•​ Qty1–Measured volume quantity of an order, as set/selected in Routing Preferences. (File > 
Preferences > Configuration > Volumes) (Required).  

•​ Address–Street address for the customer (Recommended).  

•​ Address2–Additional address information, ex: Suite #, building#, etc. (Recommended). 

•​ City–Name of the city (can be used by DirectRoute to determine distances/drive times) 
(Recommended). 

•​ State–Two letter abbreviation for the state, ex: CA, AZ, NM, etc. (Recommended). 

•​ Zip–The zip code (Recommended). 

•​ User Fields–Any additional fields (optional, up to 20); create/select the fields in Routing Preferences 
(File > Preferences > Configuration > Stop User Fields) (Recommended). 

•​ Latitude–The GPS coordinates for the latitude of the delivery location (Required). 

•​ Longitude–The GPS coordinates for the longitude of the delivery location (Required). 

Note: DirectRoute can use an Address, City, State, Zip, or Phone Number to geocode the stop locations for each 
record in the Stop File. If Geocoding is to be used, at least one or more of these fields are required to be used.  

 

3.3.1.​ Import/Extract an Account Master 
Import current account records (Account Master File) for use by DirectRoute.  

•​ Create an Account Master File with the required column headings (ref. Account Master File). 

•​ Save the edited file as an ASCII (.csv) or spreadsheet (.xls) file in the DirectRoute Data folder; 
rename it as something you will remember.  

•​ Open DirectRoute and (from the menu) select File > Open; select Stop Files from the drop-down 
menu in the bottom right corner of the info box, then select the new master file you just created and 
saved (from the step above). 

•​ Select the Open button to open this file. 

 
Figure 32–Open Stop File 

©2026 Trimble Maps​ 69​ ​  Mar -26 



DirectRoute User Guide​ ​ 26.1 

 
 
This new master file can be used to copy/paste into a daily Stop File. Remember to save the file again after any 
further editing is done.  

•​ Open DirectRoute and (from the menu) select File > New > Stop; a new Stop File will be created and 
open; it will be blank, except for the column headings. 

•​ Return to the other file you opened (the file created in the steps above, from the Account Master). 

•​ Copy/paste the data from that file into the new Stop File, in the matching columns. 

•​ When all data has been copied to the new Stop File, save the file (File > Save As) with a new name.  

Note: When completed, the new file(s) should always be saved to the DirectRoute Data folder, located in the 
directory where DirectRoute is installed. 

 

3.3.2.​ Extract a Daily Order File 
This method is used when the customer base is steady and new customers are added infrequently. The process 
uses an Account Master File (maintained and updated by DirectRoute during the extraction process) to create a 
Daily Order File. 
 
A Daily Order File extracted from your ERP/WMS system, is typically a tab delimited (.ext) or comma delimited 
(.csv) file, and contains only new orders (Account ID, Order Number, Quantity, etc.) associated with a customer 
that is listed within the Account Master File. Once extracted, the Daily Order File is converted into a Stop File for 
use in the route building process.  
 
DirectRoute will match the ID1 field in the Extract File (Daily Order File) to the ID1 field in the Account Master File, 
and will then edit the appropriate Stop File fields (Account ID, Order Number, Quantity, etc.) with the values from 
the Extract File. At the end of the process, you will have a Stop File containing only new orders for current 
customers, ready to route. 

•​ Using your ERP/WMS systems normal extract process, extract the Daily Order File, then edit the file 
to add the required Stop File column headings (ref. Import and Extract Records). 

•​ After editing the Extract File (Daily Order File), save it as an ASCII (.csv) or spreadsheet (.xls) file in 
the DirectRoute Data folder. 

•​ From the menu, select File > Open; select Stop files from the drop-down menu in the bottom right 
corner of the info box, then select the saved Extract File (Daily Order File). 

•​ Select the Open button to open the file.  

 
The file will now open as a Stop File that can be used in the route building process. Remember to save the file 
again if any further editing is done.  

Note: To simplify the daily process, create a custom extract (if possible) with the required Stop File column 
headings that can be used to extract the data from your ERP/WMS. 

 

3.3.3.​ Extract to Create a New Stop File 
This method is used when new customers are added frequently and is the most common method for creating a 
Stop File. The process uses an Account Master File maintained and updated by DirectRoute and ensures that 
static account data (Long/Lat, Time Windows, Unload Times, etc.) remains as accurate as possible. The column 
headings used in the Extract File must be identical to those used in the Account Master File.  
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•​ Using your ERP/WMS systems normal extract process, extract the Daily Order File, then edit the file 

to add the required Stop File column headings (ref. Import and Extract Records). 

•​ After editing the Extract File (Daily Order File), save it as an ASCII (.csv) or spreadsheet (.xls) file in 
the DirectRoute Data folder. 

•​ From the menu, select File > Extract. 
•​ In the Extract box, choose the appropriate files for the extract process 

o​ Master File–Select the Master File button, the Account Master File, and then the Open 
button. 

o​ Extract File–Select the Extract File button, the Daily Order File, and then the Open button.  

o​ Stop File–The file name will auto-fill (same name as Daily Order File) with an .xls extension. 

 
Figure 33–Extract Dialog Box 

 
In the Options section of the Extract box, select the specific functions that should be performed during the extract 
process (click on the box to select). 

•​ Create Stop File–Selected by default. 

o​ Get Address, City, State and Zip from Master–Will use the address, city, state and zip data 
listed in the Account Master File for each customer. 

o​ Zero coordinates if addresses don’t match–Will update the Lat/Long column (Stop File) to 
all zeros if the addresses in the Daily Order File and Account Master File don’t match. 

o​ Append new accounts to Stop File–Appends new customer stop info from the Daily Order 
(Extract) File to the Stop File only (does not update or append the Account Master File). 

o​ Append new accounts to Master–Appends new customer stop info from the Daily Order 
(Extract) File to the Account Master File only (does not update or append the Stop File). 

•​ Update Master File–Select to perform any of the following (not selected by default). 

o​ Overwrite Address, City, State, and Zip–Overwrite the address, city, state and zip data in 
the Account Master File with the address, city, state, and zip data from the Daily Order File. 

o​ Update Blank Fields–Will append blank fields in the Account Master File for existing 
customers only, with data from the Daily Order (Extract) File. 

o​ Select the OK button. 
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Note: Review and edit the Extract options in Routing Preferences (File > Preferences > Extract) before initiating 
the Extract process. 

 
When the extract process has completed, a dialog box will appear to display the results. 
 

 
Figure 34–Extract Complete 
 

3.4.​ Truck File 
The Truck File is a spreadsheet that contains all the information about the fleet that will be used to make 
deliveries. Each row in the file represents a Truck on which the Stops can be loaded. Key fields represented in the 
Truck File include Capacity, Availability, and Costs.  
 
If you already have a Truck File, or a spreadsheet with the required fleet information, it can be used in the project 
if it contains the required data columns. If you do not already have a Truck File, a new one can be created that 
will automatically populate the necessary header columns and allow manual input of all customer data.  
 

3.4.1.​ Create a New Truck File 
A new Truck File can be created that will automatically populate the necessary header columns and allow manual 
input of all necessary data. Or, if you already have a spreadsheet file with current fleet information, it can be used 
by copying the information into the Truck File.  

•​ From the menu, select File > Open > Truck or File > New > Truck. 

•​ Update, or enter (copy/paste) each vehicle’s data directly into each column of the spreadsheet; or 
double-click each row to open the Truck Dialog box and update/enter all the data for each vehicle in 
one window. 

•​ The Truck File Fields and Descriptions Table identifies and explains each field that is required or 
recommended to be used in each Truck File. 

 
The Truck Dialog box is divided into the following six sections:  

•​ General–Includes Truck ID, special equipment codes , and availability (if the One-way route box is 
marked, the Redispatch feature is not used; if Redispatch is required, set to TRUE, enter minimum 
time and turnaround time); change Zone if you wish to adjust the speed for this truck. 

•​ Location–Add location information, symbol, and color code options; Long/Lat for the depot or 
dispatch start point can be added later, during the Geocode process. 
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•​ Costs–Enter any known fixed costs for each vehicle. 

•​ Work Rules–Enter all restrictive work rules for each vehicle, including start times and dates (Day 1 is 
the first day of the routing scenario) (LatStart should be left blank to allow DirectRoute to best 
calculate time required to meet Time Windows). 

•​ Time of Day Speed Adjustments–Enter any, if needed. 

•​ Capacity–Enter capacities in the volume fields; should match those in the Stop File. 

•​ User Fields–Add any fields/entries needed; see Routing Preferences and Options Table for 
additional information. 

o​ In order to export to DRTrack, you must have a DayCode user field in the Truck File. 
DayCode informs DRTrack what day it should clone a Master Route, with values ranging from 
1-7 representing the day of the week beginning on Sunday and ending on Saturday, 
respectively: 

▪​ Sunday = 1 

▪​ Monday = 2 

▪​ Saturday = 7 

 
Figure 35–Truck File Record 
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When all entries have been completed, select Close > Accept, and then repeat as necessary for each additional 
vehicle. 
 
After all vehicle data has been entered into the Truck File: 

•​ Geocode the Truck File to find Lat/Long for each record in the file, see Geocoding Records). 

•​ Finally, save the updated Truck File in the DirectRoute Data Folder). 

•​ Select File > Save, or File > Save As, and assign a name to the file. 

 

3.4.2.​ Truck File Fields and Descriptions Table 

FIELD NAME DESCRIPTION 
REQUIRED 

OR 
OPTIONAL 

TrkID Truck ID entry may be a number, truck name, driver name, or what is 
of most importance to the router. Required 

Territory 

(TerritoryPro) The Territory ID will represent the name of each Territory. 
It can be any number in length, an alpha name, or alphanumeric. 
When Territories are built, this ID will be passed to the Stop File 
column named Territory, to identify the Territory that each Stop has 
been assigned. The number of unique Territory IDs used in the Truck 
File will determine how many Territories will actually be built.  
Ex: TrkID’s 101, 102, and 103 are all assigned to Territory 10000. 
TrkID’s 201, 202, 203 are all assigned to Territory 20000. 

Required 

Available This must be set to TRUE in order to make the vehicle available for 
use in the route build. Required 

One-way 
Set to TRUE for vehicles that will be routed out, but not returned to the 
depot. Set to FALSE if the vehicle will return to the depot upon 
completion of the route. 

Required 

SpEq 

Special Equipment Codes, used to identify special designations for the 
vehicle (Lift Gate, Refrig compartment, etc.); must have coordinating 
EqCode in the Stop File.  
Note: If using refuel points, insert ‘REFUELPOINT’ in this field (no 
corresponding EqCode necessary in Stop File) to designate the refuel 
location.  

Optional 

Volume1 
The maximum quantity of Volume1 (Stop File) that the vehicle can 
carry (vehicle capacity). Use the same Volume1 type used in the Stop 
File. 

Required 

UnldPerf% 

Unload Performance regulates changes to the UnldRate. When a 
value is entered into this field, the unload rate will either increase or 
decrease. 100% is the default value. An increase to 110 will increase 
the Unload Rate by 10% (shorter time to unload). A decrease to 90 will 
decrease in the Unload Rate by 10% (increase the time to unload). 

Required 

Redispatch Set to TRUE if the vehicle will be sent back out on another route, if 
time remains in the workday; FALSE if Redispatching is not used. Optional 
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FIELD NAME DESCRIPTION 
REQUIRED 

OR 
OPTIONAL 

MinTm 
Minimum Time; used with Redispatching. Reflects amount of time 
(hours) that must remain in a workday upon return to depot, in order to 
redispatch the vehicle. 

Optional 

TurnTm 
Turn Time is used with Redispatching; the amount of time (minutes) it 
takes to reload or any required time at the depot, between routes, 
before Redispatching. 

Optional 

MiCost Mileage Cost is cost per mile to operate this vehicle. Required 

HrCost Hourly Cost is the hourly cost of the driver for this vehicle. Required 

OTCost1 

Overtime Costs is the cost per hour added if the time to complete the 
route exceeds the time set for WorkDay.  
Ex: If the cost for the first two hours of overtime is $5, then OTCost1 = 
5. 

Optional 

OTHrs1 The level at which overtime hours are calculated; used with OTCost1.  
Ex: If OT costs are paid in 2 hr. increments, then OTHrs1 = 2.  Optional 

FixedCost Costs that don’t change (tractor rental, maintenance, etc.) Optional 

UnldHrCost Cost to unload per hour. Optional 

DropCost 
Drop Cost is the drop cost for each stop. User input, File > 
Preferences > Routing > General (Drop Count). A number in this 
section will add a drop cost to each stop on the route. 

Optional 

WaitHrCost The cost per hour if a vehicle must wait at the stop before making its 
delivery. Optional 

UnitCost The cost of each unit delivered (volume). Optional 

LayoverCost The cost applied when a vehicle must layover before completing its 
route and returning to the terminal. Optional 

EarStart The earliest time a vehicle may leave the terminal to begin a route; 
enter in military time format (2400). Optional 

EDate 

The earliest day, from the dispatch date, a vehicle may depart. The 
Date of Dispatch is DAY 1. A one (1) would be entered in this field if 
the trucks could leave on the first day of dispatch. One day vehicles 
may have an Edate of 1-7, depending on which day of the Dispatch 
cycle they are released to proceed. 

Required 

LatStart The latest time a vehicle can leave out of the terminal; enter in military 
time format (2400). Optional 

LatFinish The latest time a vehicle must return to the depot; enter in military time 
format (2400). Optional 
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FIELD NAME DESCRIPTION 
REQUIRED 

OR 
OPTIONAL 

LDate 

The latest date a vehicle must return to the terminal. This day is 
calculated from the dispatch date. A one-day route may have an Edate 
of 1, but also a Ldate of 1, while a weekly route may have an Edate of 
1 and an Ldate of 7. 

Required 

WorkDay 
The number of hours in a normal workday, OTCosts are incurred if the 
Workday hours are exceeded to complete the route (required if 
OTCost1 is used) 

Optional 

NormalStart 
The normal daily start time of the vehicle. The Load algorithm will obey 
this setting, but when Between Route Optimization is run, that 
algorithm may adjust the start time to a more cost effective time. 

Optional 

Brk1Start 
How far into the shift/route a mandatory break should start; if the driver 
should take a break four hours into the route, then Brk1Start = 4.  
Note: Up to five break fields can be used. 

Optional 

Brk1Duration 
The duration of the break; entered in decimal or whole number format 
(30 min = .5, 15 minutes = .25, etc.). Each numbered Break Start field 
must have a corresponding numbered Break Duration field. 

Optional 

MaxWorkTm The max time a vehicle can be out before returning to the depot (per 
day) Required 

TargetWrkTm 

The target work time (shift) for each vehicle. The Load algorithm will 
obey this setting, but when Between Route Optimization is run, that 
algorithm may adjust the Total Work Time on each route to a more cost 
effective amount. 

Optional 

MaxDriveTm The max drive time per shift on a route before a layover is 
implemented; entered in hours. Optional 

MinLayover The minimum number of hours a vehicle can layover.  Required if 
using ResourcePro in conjunction with DirectRoute. Optional 

MaxLayover The maximum number of hours a vehicle can layover. Required if 
using ResourcePro in conjunction with DirectRoute. Optional 

MaxDrvTmB4Layover 

Lowers the Max Drive Time for the first driving segment of the route 
(the stem distance) if there are no stops serviced prior to the 1st 
layover event. This field will never be used for routes which have stops 
before the layover event and would only be used on day 1 of any 
multi-day route. 

Optional 

MaxLayovers The maximum number of layovers allowed per route. Optional 

Max Miles 

Enter the number of miles by which to limit the vehicle. When used, 
DirectRoute will not attempt to build routes that exceed the number of 
miles set in the field. Field is considered during the optimization 
process; moves or swaps will not be made if the total route miles will 

Optional 
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FIELD NAME DESCRIPTION 
REQUIRED 

OR 
OPTIONAL 

exceed this setting. If a route is manually edited to go over the Max 
Miles set in this field, DR will return a MaxMiles route level violation. 

PreTrip In accordance with DOT rules, time added (in minutes) at the start of 
each route.  Optional 

PostTrip In accordance with DOT rules, time added (in minutes) at the end of 
each route. Optional 

Origin Name of the Depot Optional 

Address Address where the vehicle (Depot) is located. Required 

City City where address is located; used to geocode and used in the 
Distance File. Required 

State 2 letter state abbreviation for the address; used to geocode. Required 

Zip Zip Code of the address; used to geocode. Required 

Country 

This column will be used during the geocoding process for passing 
country code to the mileage system. If no value is present in this 
column, the country code set in the Preferences will be used. The 
value in this column should be ISO2 or ISO3 country code format (i.e. 
valid country code for the US is USA/US and for Canada CAN/CA). If 
no address information is given in the file, DR will try to geocode the 
stops using City, State, and Zip. 

USA/US 

Longitude The Depot's longitude coordinate, discovered during the geocode 
process. Required 

Latitude The Depot's latitude coordinate, discovered during the geocode 
process. Required 

Zone 

A percentage adjustment to the drive time. Default is 100 = normal rate 
of speed. An increase to the drive time will lower speed; a decrease to 
drive time will increase speed. Zone is hard coded to eight miles.  
Ex: (Truck File) A value of 110 would increase the drive time by 10%, 
hence lowering the speed by 10%. A value of 90 would decrease drive 
time by 10%, increasing speed by 10%. The speed adjustment is only 
applied to the first 8 miles of each route segment (from Depot).  
Ex: (Stop File) If all customers in downtown Chicago have a value of 
110 in this field, the software will increase drive time for the stops in 
downtown Chicago (within the 8 mile radius), while lowering the speed 
of travel. 

Optional 
 

AMStart Set AM start time to adjust speed to account for heavier/lighter traffic. Optional 

AMEnd Set AM end time to adjust speed to account for heavier/lighter traffic. Optional 
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FIELD NAME DESCRIPTION 
REQUIRED 

OR 
OPTIONAL 

AMAdj 

Set drive time adjustment for AMStart and AMEnd. AM/PM Adjust 
works the same as Zone; increase the number (110) to increase the 
drive time by 10 percent. In turn the speed is decreased by 10 percent. 
The radius is based on the rush hour distance setting (Preferences > 
Routing > General). Zone is hard coded to eight miles, while AM/PM 
Adjust is based on the rush hour distance.  
Ex: If rush hour distance is set to 30 miles, it will apply to the truck for a 
30mile radius from the depot. If it is set on the customer in the Stop 
File, it will be a 30mile radius from the customer. 

Optional 

PMStart Set PMStart to adjust speed to account for heavier or lighter traffic. Optional 

PMEnd Set PMEnd to adjust speed to account for heavier or lighter traffic. Optional 

PMAdj Set drive time adjustment for PMStart and PMEnd. See AMAdj for 
additional info. Optional 

Symbol 

The symbol (size and color) that is displayed on the map, to represent 
the Stop. Symbols are chosen from the Stop File; Double+Click on the 
customer record to open the dialog box; select the symbol, size and 
color, then select on OK. 

Optional 

Size Specifies the size of the symbol to be displayed on the map. Default 
size is 8. Optional 

Color Specifies the color of the chosen symbol. Select colors in the same 
fashion/at the same time as selecting symbols. Optional 

Georesult Georesult will display the results received when records are geocoded. Automatic 

Figure 36–Truck File Fields and Descriptions Table 

 

 
Figure 37–Layout of Truck File 
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3.5.​ Distance File 
The Distance File is a spreadsheet that contains a record of distances and drive times between the pick-up point 
(terminal, DC, etc.) and every city in the Stop File (stem distance), and/or pick-up point to every stop, and from 
stop to stop. When a Distance File is used in the routing process, DirectRoute will calculate the distances and 
drive times between each stop location based on the entries in this file.  
 
The software provides three options to calculating and/or collecting distances and drive times: 

•​ DirectRoute Drive Time–Uses DirectRoute’s internal algorithm settings and map files.  

•​ Optional Mileage System–Uses any optionally installed (by the user) Mileage System.  

•​ Highway Only when Get Directions is used–Default option in Preferences > Trimble Maps > 
Highway Only, Highway Only means local streets are not considered when running a route; vehicles 
are restricted to primary roads and highways only, regardless of vehicle profile.  

•​ Elevation Limit (Preferences > Trimble Maps > Elevation Limit)–DirectRoute will look for an 
alternate route to avoid roads that would exceed the set limit.  

o​ The unit of measure chosen (Feet, Meters) should be the same unit of measure chosen for 
Distance Option (Preferences > Other > Distance Options).  

o​ If the Distance Option is set to Miles, then set Elevation to Miles.  

o​ If set to Meters, then set Elevation to Meters. 

 
Figure 38–Layout of Truck File 

 
If a Distance File is not used, DirectRoute will calculate distances and drive times using an adjusted straight-line 
distance (as the crow flies) between locations. When there is a Distance entry for a pair of Stops, the software will 
use the Distance and Drive Time listed in the file, instead of calculating distances based on Lat/Long Coordinates, 
or other barriers that may be present.  
 
A Distance File can also be generated to record Stem mileage, the Distance between the terminal and each city 
listed in the Stop File. 
 
The software uses the Min/Max Distance settings to calculate the Distance entries in the Distance File. Min/Max 
Distance refers to the minimum and maximum distance between stops, using straight line distance. If the stops 
fall within the Min/Max Distance setting, the distance and drive Times will be calculated using the road network. 
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Using the road network will sometimes return a distance result above the Max Distance setting chosen; this does 
not indicate an error, as it is only the result of converting a straight-line distance to a road network distance.  
 

Example: If the Min Distance is set at 40 miles and the Max Distance is set at 500 miles, the system will generate 
an entry for every city that is between 40 and 500 air miles (straight line distance) from each city listed in the Stop 
File.  

 

Tip: A good rule of thumb for the max distance setting is one half to one times more the distance to the farthest 
stop in the delivery area. 

 
Before beginning any type of routing project, or generating a new Distance File, it is a good idea to review and 
edit, if necessary, the current Distance File settings in use by the software.  

•​ From the menu, select File > Preferences > PreProcess > Generate Distance File. 

•​ Use the Distance File Settings Table to assist in updating each item, as necessary. 

•​ Select OK when all selections are completed to exit the Preferences screen. 
 

3.5.1.​ Get Distance Entries from Database (Db) 
The following app settings are needed in DirectRoute.exe config for this to work.  

•​ UseDatabaseForDistanceEntries–Set to TRUE (default value). 

•​ ConnectionStringName –Connection string name configured in Connection Strings section. 

•​ CompanyID–1 (default value) (setting does not have any impact for now). 
 

In Preferences, choose either the Distance File, or the Database for distance entries (downloaded entries will be 
saved to a file). 
 

3.5.2.​ Distance File Settings Table 
Distance File settings are found in various sections of the DirectRoute Preferences table. When updating or 
changing any of these settings, it is a good idea to review all the sections to ensure that all the necessary settings 
match when necessary and are accurate. 

•​ Preferences > PreProcess > Generate Distance File. 

•​ Preferences > PC*Miler (or PC*Miler Direct) if the appropriate license has been purchased.  

•​ Preferences > Routing > General. 
•​ Preferences > Other (set distance options, mileage system, etc.). 

 

The following settings can be found at Preferences > PreProcess > Generate Distance File: 

 
FIELD SAMPLE ENTRY EXPLANATION 

Generate Distance 
File TRUE (FALSE) If TRUE, generates Distance File during 

Preprocess 
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Minimum Distance 
Between Stops 0 Minimum distance the software will 

compute distance between stops 

Maximum Distance 
Between Stops 800 Maximum distance the software will 

compute distance between stops 

Speed Adjustment 100 
Adjust drive time by this factor (100 is 
baseline, 120 increases drive time by 20%, 
etc.) 

Maximum Speed 60 Maximum allowable speed by vehicle on a 
route 

Generate 2-way 
entries for stops 
less than (x miles) 

5 Add a return distance, between two stops 
within X miles of each other  

Generate 2-way 
distance entries TRUE (FALSE) If TRUE, will calculate distances To and 

From stops 

Stem Distances 
Only TRUE (FALSE) 

If TRUE, will calculate distance between 
the Terminal and City where the stop is 
located (not the stop itself)  

In Cone 
TRUE (FALSE) 
(Angle and radius created from the terminal, 
defaulting to 57º) 

If TRUE, only stops within the Angle or 
Radius may be added to the selected route  

Overwriting Existing 
Entries TRUE (FALSE) If TRUE, will overwrite any Distance File in 

the DirectRoute Data Folder 

Within Territories TRUE (FALSE) 
Set to TRUE, will generate a Distance File 
with distances listed between EqCodes of 
the same type 

Route Across 
National Border TRUE (FALSE) 

If TRUE, will allow route to cross Canada 
and/or Mexico borders; if FALSE, will 
prevent routes from crossing borders (may 
result in more miles) 

Commercial 
Restrictions TRUE (FALSE) Option for Prophesy to use only roads 

permitted for commercial vehicles 

Avoid Toll Roads TRUE (FALSE) If TRUE, keeps trucks from using toll roads 

Use DirectRoute 
Drive Time TRUE (FALSE) 

If TRUE, will generate distances and drive 
times using DirectRoute’s calculations 
(instead of any optionally installed Mileage 
System or Historic Traffic Data. 

Threading Single Thread 
For use when generating Distance File, 
multi-core CPU = set threading to Multiple, 
otherwise set to Single 
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Distance File C:\Program Files (x86) 
\Appian\DirectRoute\Data\ xxxx\xxxx.dist  Enter the path to the existing Distance File 

Use Mileage 
System Drive Time 
if it is > DirectRoute 
Drive Time 

TRUE (FALSE) 
 
When an additional mileage system is 
installed and used, and the calculated drive 
time is greater than the drive time calculated 
by DirectRoute, adjust this setting to use the 
greater (longer) drive time (TRUE), or use 
the DirectRoute calculated drive time 
(FALSE). 

Only set to TRUE if an additional mileage 
system is installed and/or used (PC*Miler, 
etc.).  

Preferences > PC*Miler Direct 

FIELD SAMPLE ENTRY EXPLANATION 

Route Across 
National Border TRUE (FALSE) 

If TRUE, will allow route to cross Canada 
and/or Mexico borders; if FALSE, will 
prevent routes from crossing borders (may 
result in more miles) 

Route Type 

Practical 
 

Practical Routes - distances and driving 
routes that a driver would normally take to 
minimize time and cost.  
 
Shortest Routes - distances and driving 
routes that a vehicle would take to minimize 
total distance traveled while still following a 
reasonable route. 

Choose from Practical, Shortest, or 
Fastest. Practical considers distance, road 
quality, terrain, urban/rural classifications, 
truck-restricted roads, and designated 
principal and secondary through routes. 
Shortest will avoid truck-restricted roads 
and, in some cases, may favor a beltway 
rather than traveling directly through a city. 

Avoid Toll TRUE (FALSE)  

Hazardous Option 

None  
General, Radioactive 
Explosive, Inhalant 
Corrosive, Flammable 

 

Thread Count 0 
Number of thread counts to use in Matrix 
Mode (see Distance Generation Mode 
below) 

Distance 
Generation Mode 

Pair 
Matrix 

Changes how distance entries are 
generated 

Vehicle Profiles 

48' Semi Trailer 
 
Ex: Double Trailers, Straight Truck 
53' Semi Trailer, Full Sized Van 
Light Assets, Custom, etc. 

Edit/Add all vehicle types/options available 
from your vehicle fleet using the 
VehicleProfile Collection Editor. 

Default Vehicle 
Profile  Choose the default vehicle type for each 

new routing project. 
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Map Region NA Map Region option is not provided at this 
time. Default is set to NA. 

Use Historical 
Traffic Date TRUE (FALSE) 

Calculates drive times and distances 
based on historical traffic data (requires 
additional Appian licensing). 

Figure 39–Distance File Settings Table 
 

Note: When using Historic Traffic Data to generate distances/drive times, ensure the appropriate settings are 
edited in Preferences.  
PC*Miler Direct > Use Historical Traffic Data = TRUE. 
Routing > General > Use DirectRoute Drive Time = FALSE. 
And, if using Preprocess, set PreProcess > Generate Distance File > Use DirectRoute Drive Time = FALSE. 

 

 
Figure 40–Distance File Settings Table 
 

3.5.3.​ Generate a Distance File 
To generate a Distance File, first geocode both the Stop and Truck files, then save the files. 

•​ From the menu, select File > Generate Distance File. 
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•​ Edit the distance settings From and To (Min and Max distance between stops), Speed Adj and Max 

Speed. 

•​ Select Use DirectRoute Drive Time unless using an alternate mileage system. 

•​ Select any other options appropriate: Stem Distance (distance between Terminal and city only in the 
Stop File), in Cone (angle and radius created from the terminal), Overwrite existing entries (in current 
Distance File), Within Territory (generate a Distance File with distances listed between the same EQ 
codes), and Two Way Distance Lesser than (computes the distance between 2 points with a return 
distance added). 

•​ Select the Stop, Truck, and Distance File names/path (to create a new Distance File, do not select a 
Distance File name). 

•​ Select the second tab (mileage system, i.e. Trimble MAPS, PC*Miler, etc.) to review/edit vehicle 
profiles that will be used in the routing project. 

•​ When all options from both tabs have been updated, select the OK button to generate the Distance 
File. 

 

 
Figure 41–Generate a Distance File 

 

Tip: If an optional mileage system is installed and selected in Preferences→Other→Mileage System to generate a 
Distance File, only the General tab will appear/be available from which to choose distance and drive time options.  

 

3.5.4.​ Use Ultrafast Distance Matrix 
UltraFast Distance Matrix (UFDM) allows users to generate distances and drive times in near real-time between 
millions of combinations of locations. See What is the Ultrafast Distance Matrix for more details.   

Create a Distance file using the Ultrafast Distance Matrix. Internet connection required.  

●​ There can be up to a 5% discrepancy from actual distance when using the UFDM. 

●​ Does not support time-based restrictions, or Ferry links. 

●​ Can only be used when leveraging Preprocessing while in route-building mode using either DirectRoute 
or TransportationModeler.  
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●​ Preference changes must be defined and options enabled prior to creating routes.  

To enable UFDM, complete the steps below: 

1.​ Set Preferences. 

a.​ Click on File and select Preferences. 

b.​ Scroll down to Preprocess and click on Generate Distance File. 

c.​ Select Ultrafast from the Generate Distance File drop down menu. 

 

Figure 42 -  Generate Distance File Preference 

d.​ Set the Use DirectRoute Drive Time to True or False.  

e.​ Set the Maximum Speed and Speed Adjustment percentage fields. 

f.​ Select the correct vehicle size for the project by editing the Profile name from the Ultrafast Distance 
Matrix drop-down.  

●​ If you have a mixed fleet of different sizes, select the larger sized asset from the list of choices.  

●​ EU vehicle profile options only work with EU geocoded stops.  
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Figure 43 - Generate Distance File preferences 

g.​ Click on OK or ensure the Save Preferences on Close option is selected. 

2.​ Click on File from the Toolbar and select New.  

3.​ Click on Route then select the appropriate routing method: Regular, Priority, or Selective. 

 

Figure 44 - Routing method for new Routes  

4.​ Set the Dispatch Date in the drop down calendar. 

5.​ Click on the Enable Pre-Processing box. 

 

Figure 45 - Build Route Window  

6.​ Click OK to start the file generation and view the project in routing mode.  

●​ The UDFM-created Distance Files are saved to your current User Data Directory as 
stop-file-name_vehicle-profile-name_date-stamp. 
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●​ Distance Files created during Preprocessing are used by the algorithm during route construction. 

There is no need to run the solution again with the newly created distance file. 

●​ It's advised to disable Pre-Processing and not create multiple distance files for the same project 
on subsequent runs and project variations.  

 

3.5.5.​ Add New Entries to a Distance File 
New entries can be added to the Distance File when adding new stop records to a Stop without having to 
generate a whole new Distance File. DirectRoute can calculate and update the file by adding an entry for any new 
stops that do not already have an entry listed.  
 
To enable adding new entries as they occur, ensure the Preprocess setting is enabled in the Distance File 
settings, and always select the preprocess option when creating new routes. (Routing Preferences and Options 
Table, and Distance File Settings Table.) 

•​ Select File > Preferences > Preprocess > Generate Distance File = TRUE. 

 
Figure 46–Preferences Preprocess Options 
  
When creating new routes, always select the Load Option Enable Preprocess. 

•​ Select File > New > Route. 

•​ Under Load Options, select Enable Preprocess. 
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Figure 47 – Build Route Load Options  
 
In the event that multiple new accounts must be added, it is recommended that a new Distance File be generated.  
 

3.5.6.​ View, Edit, Save, or Export a Distance File 
The Distance File can be opened within DirectRoute, and individual entries edited when necessary. The opened 
file will resemble an Excel spreadsheet, with a file extension type of .dist. Once opened, the file can be saved as 
an Excel spreadsheet and viewed (exported) outside of DirectRoute.  

•​ Review the geocode results and validate, if necessary. 

•​ Create a custom geocode file. 
•​ Geocoding with Google Maps API. 

4.​ Geocoding 
Geocoding is the required process of finding associated geographic coordinates, expressed as Latitude and 
Longitude, from the address data provided in the Stop, Shipment, and Truck files. It enables the locations to be 
mapped and used to establish appropriate Routes.  

●​ All addresses in the Stop and Truck files must have a Lat/Long associated for the routing process to work 
correctly.  

○​ Any records not geocoded are unloaded or unassigned by the algorithm, if used 

●​ DirectRoute uses street addresses for the most accurate coordinates.   

○​ If the street address fails, it can fall back to City, State, and Zip to geocode the Stop and Truck 
records. 

○​ Ensure the addresses in each file are accurate before starting the geocoding process. 

●​ Once a record has been geocoded, it can be manually moved anywhere on the map using DirectRoute 
shortcuts; however, this changes the longitude and latitude in the Stop file.  

○​ Select CTRL+Left-click to select the Stop. Use SHFT + CTRL + Left-click to drop the Stop on the 
new map location. The lat / long update automatically.  

●​ If the file already has the coordinates (Lat/Long) for each Stop, shipment, or truck, they are placed on the 
map when the file is opened in DirectRoute.  

●​ The application offers either full web service access to the Trimble Maps database, or an offline-mode 
service with PC*Miler 38-cached information available locally without an Internet connection. 
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4.1 Geocoding Records 
1.​ Determine which mileage system should be used to geocode the records ー Trimble Maps or 

PC*MilerDirect, and ensure it is selected under Preferences > Other > Mileage System. 
●​ Trimble Maps is the default option and enables API connections that allow DirectRoute to obtain the 

most current information from PC*Miler. 

○​ This is the best option because the Geocoding process is completed using API calls  

○​ The geocoding engine runs on the PC*Miler Single Search API. For further information, click 
here.  

●​ PC*MilerDirect is the offline version of DirectRoute that does not connect to live information via 
APIs 

 
Figure - Mileage System Options  

2.​ Open the file you wish to geocode. 

3.​ Click on the Geocode by Address icon in the center of the Toolbar. 

4.​ Select the geocoding settings. See the figures below: 

●​ Address Information ー Contains the current address and row location for the record. Can be 
used to locate a singular record that requires editing 

○​ The default view is a continuous string of address information, Click on the Show Address 
Fields box to view the address in categories. 
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●​ Geocode Options ー More than one option can be selected at a time.  * indicates options are 

available for both Trimble Maps and PCMilerDirect 
○​ Show Address Fields* ー Check this box to see the address components like street and city 

in their own fields rather than the single text view used by the API 
○​ Overwrite/ Update Provided Address* ー Use this option to automatically update the 

address based on the results of the geocoding process. The Lat/ Long will always be updated  
○​ Skip Geocoded Stops or Trucks* ー Enable this function if you wish to skip any records in a 

file that have already been geocoded. Helpful when new records have been added to an 
existing file. When checked, it does not update the Lat/ Long 

○​ Color Code Symbols by Geocode Results* ー Apply colors and symbols to visualize how 
records have been geocoded (Edit menu > Geocode > Color Code options) 

○​ Geocode by Name ー (Trimble Maps only) Use this feature to geocode locations by business 
name when you may not have an address (does not require address when utilizing this 
feature) 

○​ Include Address2 in Query ー (Trimble Maps only) Allow the second line of the address to 
be included in the geocoding process. Helpful when suite or building numbers or cross streets 
are needed 

○​ Use Nearest Road Coordinates ー (Trimble Maps only) Check this box when records may 
include remote or new locations that may not have an address yet, or hard to find locations. 
Geocodes nearest intersection  

○​ Fallback to Zip ー (PCMilerDirect Only) Use this option when other parts of the address are 
unknown or uncertain 

●​ Processing:  
1.​ Ensure the proper file has been selected from the dropdown menu.   

2.​ Alter the records to be geocoded with the Row Range fields, if necessary. 

3.​ Click on Process Range to start the geocoding process. 

●​ Geocode Candidates ー View the geocoding results for each record/ row. If a record was 
previously geocoded: 

○​ Click on the Eye icon (top right corner of this section) to compare the previous geocoding 
results to the new geocoding results (highlighted yellow). 

○​ Click on the Accept Highlighted Result button to manually replace the geocoded information. 

○​ Results ー Displays the geocoding confidence level. Four levels available: 

■​ Level 1 ー Very High ー Exact and very close matches. Any potential match needs to 
be within 0.1 miles of each other. The top match is returned first, and can only have 
very small differences between it and the input query (e.g., Street vs Road or N vs 
North) 

■​ Level 2 ー Good ー Close matches with a trust factor of 85% or greater. If the address 
is outside the range, the top match is within 500 address units of the input address, and 
other matches are all within 0.5 air miles of each other. (e.g., 100 Main Street is input, 
and the best match is 450-550 Main Street). 

■​ Level 3 ー Uncertain ー The match is uncertain, and the trust factor is 50% or greater. 

■​ Level 4 ー Failed ー A match has failed, and the trust factor is below 50%. 
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○​ Address Error ー Returns the reason for the confidence level when any part of the address 

differs (e.g., An address of 123 N Main Street is returned 123 North Main St. may have a 
confidence level of 1 and an AddressError type 6). 

■​ There are 18 Result type categories: 

●​ 0 ー Country 
●​ 1 ー State 
●​ 2 ー County 
●​ 3 ー City 
●​ 4 ー Zip 
●​ 5 ー SPLC 
●​ 6 ー Street 
●​ 7 ー RouteNumber 
●​ 8 ー RouteAlpha 

●​ 9 ー POI 
●​ 10 ー POIStreet 
●​ 11 ー FullPostCode 
●​ 12 ー POIType 
●​ 13 ー CrossStreet 
●​ 14 ー LatLon 
●​ 15 ー CustomPlace 
●​ 16 ー None 
●​ 17 ー TrimblePlaces 

 
Figure - Trimble Maps Geocoding screen 
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Figure - PCMilerDirect Geocoding screen 

5.​ View Map ー View the geocoded record on the map. The black dot indicates the original address. The 
green dot represents the new geocoded location. 

 
Figure - Trimble Maps Geocoding screen  
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4.2 Custom Geocode File 
The Custom Geocode File is a separate file from the Stop file or Master file. It is a spreadsheet containing 
special locations that are hard to geocode or cannot be geocoded normally (e.g., new housing 
developments, remote dock yards). 

●​ Only one Custom Geocode file is necessary, if one is being used.  

●​ The Custom Geocode file contains a user-defined SiteID and the longitude and latitude of the Stop. 

●​ The SiteID is a unique name or string used to: 

1.​ Identify the longitude and latitude of the specific location.  

2.​ Allow DirectRoute to determine if a Stop in the Stop file is available for geocoding through 
the Custom Geocode file.  

●​ Separate SiteIDs allow many locations to be entered, even if not all the locations appear in each 
Stop file. 

●​ DirectRoute first attempts to geocode the records by Address, ZIP+4, and then by the Custom 
Geocode file.  

4.2.1    Using a Custom Geocode File 

Create a custom Geocode file to be used with DirectRoute. 

1.​ Create a new spreadsheet with three columns: SiteID, Longitude, and Latitude 

2.​ Enter the info for each location to be geocoded  

If the Stop file Then 

Contains the coordinates 
for the SiteIDs 

Copy/ paste the coordinates into the custom geocode file 

Does NOT contain the 
coordinates 

Manually locate the lat/ long:  

1.​ Zoom to the location on the map where the Stop is located and 
hover over it to display the Lat/Long Coordinates in the lower left 
corner of the map screen 

2.​ Copy the coordinates into the Lat/Long columns of the Custom 
Geocode file. 

●​ Longitude is the negative number (ex. -96.91080) and 
Latitude is the positive number (ex. 32.98247). 

3.​ Geocode the Custom Geocode file. 

4.​ Save the file in the DirectRoute Data Folder. 

5.​ Update the Stop file:  

a.​ Create a column called SiteID and enter the ids for each Stop that is also in the Custom 
Geocode file. 

b.​ Save the file changes. 
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6.​ Update Preferences: 

a.​ Navigate to File > Preferences.   
b.​ Select Other from the dropdown menu and locate the Custom Geocode File Path. 

c.​ Type in the file path, or click on the field to display the button with three dots (right side), 
click on the button and navigate to the location of the Custom Geocode file. 

d.​ Double click the file name to capture the path location. 

e.​ Locate Geocode File Col Identifier and enter SiteID 

●​ Both the Stop file and the Custom Geocode file should have SiteID column headers  

7.​ Select OK and close the Preference window. 

4.3 Geocoding with Google Maps API 
Geocoding with Google Maps API is available to validate DirectRoute geocode results, or to obtain 
Canadian or Australian geocode results.  

●​ The service is available as a limited alternative to DirectRoute’s built-in geocoding capabilities, 
provided by Google without cost.  

●​ Google Maps API uses an API Key, generated while using the Google APIs Console, to identify 
your application.  

○​ When the application calls an API enabled in this project, the application passes this key into 
all API requests as a key=API key parameter.  

○​ Use of this key doesn’t require any user action or consent, it doesn’t grant access to any 
account information, and it is not used for authorization. 

4.3.1 Using a Google Maps API Key 

1.​ Visit the Geocoding API for Work Web Services for instructions on creating a key and billing 
information.  

●​ If you already have a server key, you may use it. 

2.​ Update the DirectRoute Routing Preferences to enable the Google Geocode service.  

a.​ Select File > Preferences > Geocode Options. 

b.​ Secondary Geocoder - Select Google from the dropdown menu. None is default. 

c.​ Fallback to Secondary Geocoding after ー Set to anything other than Never. These 
options dictate when Google Geocoding kicks in as the secondary geocoder.  

●​ Exact ー Google is used when a record is geocoded and Trimble Maps response is a 
level 1 confidence or less 

●​ Good ー Google is used when a record is geocoded and Trimble Maps response is a 
level 2 confidence or less 

●​ Uncertain ー Google is used when a record is geocoded and Trimble Maps response is 
a level 3 confidence or less 
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●​ Zip ー Geocoding falls back to the zip code provided when the street address cannot 

be geocoded correctly 

●​ Failed ー Google is used when a record is geocoded and Trimble Maps response is a 
level 4 confidence or less 

●​ Always ー Google is used every time a record is geocoded despite Trimble Maps 
response 

 

Figure - Google Geocoding preferences 

d.​ Navigate to Google Settings dropdown and complete the following:   

Google API Key –  Paste the copied key 

●​ By default, a key can be used from any server. It is recommended that you restrict 
the use of your key by IP address to servers that you administer. 

Google Geocode Accuracy Level ー Select the desired accuracy level: 

●​ Rooftop – Default. (High Accuracy) precise down to the street address.  

●​ RangeInterpolated – (Same Street) An approximation, usually on a road, inserted 
between two precise points, such as intersections. 

●​ Geometric Center – (Same Region) The geometric center of a street (polyline) or 
region (polygon). 

●​ Approximate – (Approximate) The result is approximate. 
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3.​ Geocoding in Canada and Australia – Set the appropriate country code. Ensure the country code is 

changed each time to match the country. 

a.​ Scroll down to Other and locate Country 

b.​ Click on the field and select one of the following from the dropdown menu. Other country 
codes do not work at this time. 

●​ En-US-English (Australia) 

●​ En-US-English (Canada) 

●​ En-US-English (United States) 

 

Figure  – Country Code 

4.​ View the Google results displayed for each stop in the Stop file under the column heading Geo 
Result and Geocoding Results Info Box. Google may return several results when the address 
queries are ambiguous. 

●​ Rooftop – High accuracy. Indicates the result is precise down to the street address.  

●​ Range Interpolated – Same street. Indicates the result is an approximation, usually on a 
road, interpolated between two precise points, such as intersections. 

●​ Geometric Center – Same region. Indicates the result is the geometric center of a street 
(polyline) or region (polygon).  

●​ Approximate – Approximate. Indicates the result is approximate. 

 
Figure  – Google Geocode Results 
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5.​ Building Routes 
DirectRoute provides several tools to enable the quick and efficient building of routes. Which tool you use 
will depend on your routing environment and the type of results expected. 
 
There are two primary stages to building successful routes: 

●​ The initial route construction is called ‘Load’ 
●​ The fine-tuning of routes using cost is called ‘Optimization’ 

 
Initial route construction requires preparing the route files (Creating Route Files), a review, updating 
Routing Preferences, and loading/building routes. 
 
Optimizing routes enables DirectRoute to review how the routes were loaded and the factors used to 
determine the load sequence and evaluate the feasibility of making moves. Several factors can affect this 
process, but results can offer cost savings and/or decreased miles. 
 

5.1.​Create a New Route 
After preparing the Route Files and reviewing/updating the Routing Preferences, the loading and route 
build can be initiated.  

1.​ From the DirectRoute menu, click New > Route > Regular, and the Build Route dialog box will 
open. 

 
Figure 62 – Build Route dialog 

 

2.​ Select the files that will be used to build the routes: 

a.​ Click the Stop button, then select your Stop File. 

b.​ Click the Truck button, then select your Truck File. 

c.​ Click the Distance button, then select a Distance File (if one is being used). 

3.​ Select a Dispatch Date from the date picker. 

4.​ Select load options to direct how the routes will be built: 
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a.​ No Initialization: No route construction will occur automatically and instead allows the user 

to manually lasso all stops onto the route(s). 

b.​ Initialize Routes: Use this option if your Stop File has predetermined routes and you wish 
to display them in the Route Book. For example, the Rt & Seq columns are populated in the 
Stop File. 

c.​ Load Routes: Automatically creates routes using the DirectRoute path-finding algorithm.  

d.​ Init and Load: This function honors any Rt and Seq numbers contained in the stop file and 
secondarily Loads all stops without a Route identifier.  

e.​ Enable Preprocess: This check box enables one or more procedural steps to occur 
automatically without user input, such as generating a Distance File and/or Geocoding all 
stops to create Lat/Long coordinates. 

5.​ Click OK to begin routing. 

  
When the routing has been completed, the first route will be visible on the Map. 
 

5.2.​Inbound Routes 
Inbound Routes are routes that begin at the furthest stop and route back to the depot. The distance from 
the depot to the first stop (Farthest stop) is not calculated. This mode of routing may be completed without 
using One Way Routes, and then inverting the route. Inbound Routes are calculated when using the 
Inbound Algorithm setting (File > Preferences > Routing > Algorithm Settings > Algorithm). Options 
are: 
 

●​ Regular–Normal two-way routes 
●​ DOW–Day of Week, for fuel specific functions 
●​ Inbound–Route from stops back to depot, similar to a one-way inverted route 
●​ FarthestIn–Two-way routes from the farthest stop back to the depot 
●​ OutBound–Farthest stop is the last stop, with return to the depot 

 
When building Inbound Routes, all routes are calculated as Inbound Routes; standard two-way routes 
cannot be completed within the same Stop File. 
 

5.2.1.​ Set up Inbound Routes 
1.​ From Algorithm Settings (File > Preferences > Routing > Algorithm Settings) select Inbound 

Algorithm from the dropdown. 

2.​ Ensure the One Way column is set to FALSE for all vehicles in the Truck File. 

3.​ Build your routes using the process outlined under Create a New Route. 

  
When the build is complete, the routes will look the same as One Way routes, but each route will begin at 
the furthest stop and route back toward the depot. To resume building Two Way routes, change the 
Algorithm setting in Routing Preferences back to Regular. 
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5.3.​Manual Route Building Tool 
Routes can be built manually while viewing the stops on the map and selecting only the stops desired. 

This can be done using the Manual Route Tool , located on the DirectRoute toolbar. To get started, 
ensure the Stop and Truck Files are updated as needed and saved in the DirectRoute Data Folder. 

1.​ Build your routes using the process outlined under Create a New Route. 

2.​ Click the radio button next to No Initialization and select the Dispatch Date. 

3.​ Click OK to begin building. 

4.​ When the build process has been completed, select the Map tab to view the stops on the map. 

5.​ Click the Manual Route Tool on the toolbar. This opens the Route Building dialog.​

 

Figure 63 - Manual Route Building Tool 

5.1.​ Use the dropdowns to select the first Route number to apply to the new route, and the 
vehicle (TruckID) to use on the new route. 

5.2.​ To color code stops which will not exceed vehicle capacity, check the box next to Show 
Hints. 

5.3.​ Click OK when you are done. 

6.​ To select a stop to add to the route, position the cursor over the stop and use the Shift key and 
click to select; repeat for each additional stop to add it to the new route. Click the stops you wish 

to add to the route. When you are done, click the Normal Cursor Tool  from the toolbar. This 
will end the build process for the route. To build additional routes, repeat Steps 5 and 6. 

 

Complete routes can be viewed by selecting the Route Book tab from the top of the screen (additional 
editing can be performed in the Route Book as well, if needed). 
 

TIP: Manual Route Building can also be accomplished using the Lasso Tool. 

 

5.4.​Optimization Options 
During the route build phase, DirectRoute considers truck availability time, travel time, receiving time, 
unload time, and distance; all the parameters set within the Truck File, Stop File, and Routing 
Preferences. When optimizing, DirectRoute is performing additional passes over the routing data, while 
considering penalty factors, time windows, work time, etc., to look for options that would allow stops to be 
moved either within each route or between routes, to return a lower-cost routing solution. Additional 
options can be selected to attempt loading any unloaded stops at the same time. 
 

The following optimization options are available: 
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●​ Optimize Trucks After Loading: This Preference setting will automatically engage Truck 

Optimization, which looks to minimize costs by moving stops from an underutilized, more 
expensive asset to a cheaper asset using the costs found in the Truck file.   

●​ Optimize Stops After Loading: This preference setting automatically engages Between Route 
Optimization after route construction is complete. It aims to minimize costs by moving stops 
between and within routes. 

●​ Optimize Within Routes: Found under the Modify menu while the user is in Routing Mode, this 
function attempts to re-order the stops within a route to lower the overall cost. 

●​ Optimize Between Routes: Found under the Modify menu while the user is in Routing Mode, this 
function evaluates the effects of moving one or more stop(s) to other routes to lower the overall 
cost. 

 
Optimization settings can be chosen before the load/route process begins: 

●​ Review/update selections in Routing Preferences (Preferences > Routing > Algorithm), or 

●​ Choose and apply Optimization preferences to routes already built; with the Route Book open, 
select Modify > Optimize from the menu. 

 
Regardless of the option chosen, for optimization to work effectively, all necessary cost fields within the 
Truck File must be updated accurately. 

●​ Set the mileage cost, fixed cost, and hourly cost to a higher cost value for those vehicles that 
should be used only as a last resort (prevent them from being used until necessary). 

 

5.4.1.​ Optimize Trucks After Loading 
Optimize Trucks After Loading is designed to let DirectRoute choose the right vehicle for each route, 
when there is a mixed fleet of different types/sizes of equipment. DirectRoute will move loads from larger 
trucks (higher costs) to smaller trucks (lower costs) to minimize cost.  
 
Use Optimize Trucks After Loading when: 

●​ There is a mix of vehicle types in the Truck File. 
●​ Some vehicles should be used as a last resort (rentals). 
●​ Some stops did not load because there were no available vehicles of the type needed. 

 
The algorithm needs different costs assigned to these assets, reflecting a higher amount for the larger 
assets and a lower amount for the smaller assets. 
 

5.4.2.​ Optimize Stops After Loading 
Optimize Stops After Loading looks to minimize costs by moving stops between routes and within 
routes. DirectRoute will evaluate the effects of moving one or more stops to other routes, and/or changing 
the sequence of stops within the routes. Each route is viewed and modified individually. See Optimize 
Routes for additional information. 
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5.4.3.​ Optimize Within Routes 
Optimize Within Routes attempts to re-order the stops within a route to lower the overall cost. When 
selecting Optimize Within Routes, the info display box will display fields To and From, providing Users the 
option to select a range of routes.  

EXAMPLE: Input the number 2 in the To field and the number 10 in the From field, and Optimization 
Within Routes will be performed for all routes 2 through 10 (2, 3, 4, 5, 6, 7, 8, 9, and 10). 

 

 
Figure 64 – Optimize Within Routes 

●​ From RT: The first route to be optimized. While in the Route Book, the From/To Rt defaults to the 
route selected (if any). For example, if Route 6 is currently selected and being viewed in the 
Route Book when the user selects Modify > Optimize Routes, the From/To Rt will be 
prepopulated with the number 6. 

●​ To RT: Last route to be optimized (only stops within each of the selected routes will be looked at 
for optimization). 

●​ Level: the number of stops that will be reviewed at one time to determine if they can be moved to 
another position or another route (4 is the recommended Level). 

●​ Cutoff Amt: the minimum cost savings incurred to evaluate moving a stop or leaving it in its 
current order. 

●​ Time Limit: the max amount of time you want the optimization routines to run. 

EXAMPLE: If ‘5’ is entered as the Cutoff, DirectRoute will not change a route unless at least $5 
will be saved by moving the stop 

●​ Penalty Amount: This applies an arbitrary dollar amount to stops that are moved within a route 
(this dollar amount does not affect the cost of the route, but only counts as a penalty against the 
move). The Penalty factor allows more control over reasons for applied penalties. There are 
several options to choose from, but the application of a penalty on this tab has the same effect as 
the Penalty Amount slider on the previous tab. 

 
See Optimization Options for additional information. 
 

5.4.4.​ Optimize Between Routes 
Optimize Between Routes (Shift+Ctrl+O) evaluates the effects of moving a group of stops to other 
routes. The feature will move from depot to depot (if the multi-depot version is in use), adjusting the stops 
between the routes within each depot. Moves are made when a lower-cost alternative is identified. 
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Figure 65 - Optimize Between Routes Window 

 
The following options can be modified: 

●​ General Settings: 

○​ Level: The number of stops that will be reviewed at one time to determine if they can be 
moved to another position or another route. This should be set based on the number that is 
50% of the average stops per route in each specific project. 4 is the Default, meaning that 8 
stops per route is also the average between all customers and projects seen within 
DirectRoute to date. 

EXAMPLE: If DirectRoute is set to level four, it will evaluate moving a cluster of four stops to 
another route. If the level number is higher, then DirectRoute will review more than four stops 
at a time and will take longer to process. A lower level setting may result in fewer cost savings. 
In the diagram below, we see two routes. DirectRoute will evaluate moving stops #1, #2, and 
#3 from Route #1 to determine if there is a potential cost savings. If the level number were set 
to 1 or 2, then only the first two stops would be reviewed. Moving only one or two of the stops 
would save no incremental cost because all three stops are in the same area. 

 

Figure 66 – Optimization Level 

 

○​ Pass Limit: Limits the number of times the routes will "pass" through the optimization process. 
The default is 2. Two passes will only find up to 95% of the potential savings, three or more 
passes are required to find the theoretical 100% of savings in a given project. 

○​ Cutoff Amount: The minimum cost savings incurred to evaluate moving a stop or leaving it in 
its current order (enter 5 as the Cutoff Amount, DirectRoute will not change a route unless at 
least $5 will be saved by moving the stop). 
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EXAMPLE: DirectRoute determines if a stop is to be evaluated for movement to another 
position on the route or to a completely different route. For the move to occur, there must be 
savings of at least that dollar amount. If the amount of money saved for a stop or group of 
stops to be moved is equal to or greater than this value (the Cutoff Amount), DirectRoute will 
move the stop. 

○​ Max Time: Maximum time that you want the optimization routines to run. This does not mean 
the optimization will always run the maximum time. Generally, DirectRoute will complete 
optimization before the maximum time has elapsed. DirectRoute reviews the highest marginal 
cost stops first. This means that most cost savings will occur early in the optimization process. 

●​ 1st Pass and Subsequent Passes: Designates the time spent on each pass for making moves or 
swaps. These times are combined to make up the total time allowed for optimization. If these are 
less than the Max Time, optimization will halt when the pass settings are met. 

○​ Move Time: The time DirectRoute will attempt to make moves within the first pass (in 
minutes). Moves are defined as stops changing from one route to another, not sequence 
moves within the same route. 

○​ Swap Time: The time DirectRoute will attempt to make swaps between one route and another 
during the first pass (in minutes). Swaps are defined as an equal number of stops exchanged 
between two routes.  

TIP: To automatically perform both optimizations (within and between routes) after a new route has 
been loaded, select "Optimize after loading" within the Load Options, File > Preferences > 
Routing > Algorithm Settings > Optimize Stops After Loading.  

●​ Attempt loading unloaded: This check box will attempt to load any stops that have appeared on 
the unloaded stops page in the Route Book. 

●​ Optimize displayed routes: Much like Optimize Within Routes, this option also has the Penalty 
tab, and functions the same way. The check box will cause DirectRoute to only optimize routes that 
have been locked on the screen. Routes that have not been locked will be ignored. 

●​ Penalty Factor: A multiplier for the individual penalties seen on the Penalty tab. The Penalty tab 
allows for more granular control over the individual penalties applied where any occurrence of these 
violations has been counted. The Optimization algorithm would add to the route cost using the 
following formula: Total Penalty Cost = # of Violations * Penalty Factor * Cost Per Stop * Violation 
Penalty Weight 

○​ Individual penalties that can be applied are: 

●​ Start Costing: Modifies the starting time of a route 

○​ Total Penalty Cost = Arrival Time - Open Time * Penalty Factor * TruckHourCost * 
Start Costing Penalty Weight 

●​ Time Window (TW): Modifies routes with a Time Window violation 

○​ Total Penalty Cost = # of TW Violations * Penalty Factor * Cost Per Stop * TW 
Penalty Weight 

●​ Eq Code: Modifies routes with an EqCode violation 

○​ Total Penalty Cost = # of EqCode Violations * Penalty Factor * Cost Per Stop * 
EqCode Penalty Weight 

●​ Work Time (WT): Modifies routes with a Work Time violation 
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○​ Total Penalty Cost = # of WT Violations * Penalty Factor * Cost Per Stop * WT 

Penalty Weight 

●​ Capacity (Cap): Modifies routes with a Capacity violation 

○​ Total Penalty Cost = # of Cap Violations * Penalty Factor * Cost Per Stop * 
Capacity Penalty Weight 

 
5.4.5.​ Box Expand and Values 
Box Expand is a parameter that defines which routes are considered for Between Route Optimization. 
During optimization, DirectRoute constructs the smallest box that will contain all the stops on a route. 
When DirectRoute considers making moves, the logic does not consider moving stops between routes, 
unless their boxes intersect. This includes routes that are in the same vicinity. 
 

 
Figure 67 – Box Expand 

 
The Box Expand value is represented in miles and determines how far to expand the box. Larger 
numbers increase the time it takes for the system to complete optimization; adjusting the parameter 
allows the system to consider more routes during optimization. Depicted in this example are the results if 
Box Expand is increased to 25. 
 

 
Figure 68 – Box Expand Results 

 
The miles would be saved if Stop 4 (black route) was placed on the red route. By increasing the 
parameter to 25, the boxes now intersect, thus allowing more moves to be evaluated. The increased 
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value of Box Expand will also increase the amount of time the system takes to complete the optimization 
process. 
 
To edit Box Expand values, select from the DirectRoute menu: File > Preferences > Routing > 
Algorithm > Box Expand, then enter the number of miles to identify how far to expand the box. 
 

5.5.​Priority Routing Tool 
Priority Routing Tool is a manual route building tool that provides greater control and flexibility when 
building routes, and provides a simple format from which edits and adjustments can be made during the 
building process. 
 
Key components are:  

●​ Route building options not normally available for selection (selected internally by the Algorithm). 

●​ Stop Grid view of valuable information pertaining to each stop. 

●​ Preview the routing solution (statistics) prior to committing to changes. 

●​ Import orders (stops) directly from DRTrack™ to create manual routes.  
 

Priority Route Building can be accessed from the DirectRoute menu, or toolbar. 

●​ From the menu, select File > New > Priority Routing, or 

●​ Select the Priority Routing icon from the tool bar . 
 

 

Figure 69 – Priority Route Building From the Menu 

 
Figure 70 – Priority Routing Icon 

TIP: If the Priority Routing Info box opens too large to see or access the action buttons on the bottom of 
the box, resize the box by using the mouse to drag the right side wall inward, or the top wall downward, 
then reposition the box on the screen, as needed.​  

 

5.5.1.​ Priority Route File Selection 
Select the Route Files to be used to build routes. 

●​ Select the Stop, Truck, and Distance File by clicking on the dotted box next to each item. 
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●​ Edit the Dispatch Date or use the calendar icon to select a date. 

●​ Select the Enable Preprocess box, to apply parameters already preselected in Routing 
Preferences, if desired. 

●​ Select the Next button on the bottom of the box. 

 
Figure 71 – Priority Route File Selection 

 

In addition to using a Stop File from within the DirectRoute Data Directory, stops/orders can be imported 
directly from DRTrack, for use in building routes.  
 

5.5.2.​ Import Records From DRTrack 
To import orders from DRTrack to use in building routes:  

●​ Select the Import From DRTrack button. 

○​ Select the Branch, Shift, and Truck Profile using the drop-down arrow on each line. 

○​ Select the Distance File by clicking on the adjacent dotted box.  

○​ Edit the Start/End Dates or use the calendar icon to select a date. 

○​ Edit the Start/End Time.  

○​ Select Enable Preprocess to apply parameters preselected in Routing Preferences. 

○​ Select the Next button on the bottom of the box. 

 
Figure 72 – DRTrack Import 

5.5.3.​ Preview Selected Stop Records 
After the appropriate files have been selected, available stops can be viewed from the Stop Grid, in the 
lower half of the screen of the info box.  
 
Available trucks (routes) are viewed from the Route Grid, the upper half of the box. 
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Figure 73 – Stop Grid 

 
The Stop Grid provides a preview of valuable information on each stop, prior to selection for loading. 
Some Stop Fields included are not currently found in the Route Book (Nearest Neighbors, Dist. to 
Centroid, etc.). Use the scroll button on the bottom of the grid to reveal additional Stop Fields to the right 
or left. 

 
Figure 74 – Stop Fields 

Stops in the grid can be filtered by any Stop Field listed; click on the Filter icon  to activate and select 
the filter options. Additional Stop Fields can be viewed by sliding the scroll bar left/right, at the bottom of 
the grid. 
 
Some of the key fields and functions available in the Stop Grid prior to loading stops: 

●​ Seed Stop: A specific stop to build routes around, like a centroid. 

○​ Click the box to the left of the chosen stop. 

○​ Click on the Seed button in the bottom left corner; the stop will move to the Route Grid 
box. 

●​ Neighbor Stops Within ( ) Miles: Select the number of miles from the Seed Stop by which to 
consider neighboring stops for loading on the Route. 
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●​ Load Priority Configuration: Use the slide bars to apply appropriate weight factor for 

prioritization and/or distance, or edit the multiplication factor.  

●​ Apply Changes: Select this button to apply the changes/selections to Load Priority. 

●​ Show Compatible/All Stops: Use the drop-down arrow to show only compatible stops, or show 
all stops. 

5.6.​New Routes with Priority Routing 
To build a new route, select the first Truck or Route to build, using the drop-down arrow in Route Grid. 

●​ Select Seed Stop:  

○​ Locate the specific stop in the Stop Grid; select the box left of the stop and click on the 
Seed button on the bottom of the screen (the stop will appear on the grid). 

 

Figure 75 – Route Grid 

 

To load available stops on a route, locate each stop (Stop Grid) and select the box to the left of the stop. 

●​ Select one stop at a time and Load, select several stops then Load the group, or select ALL stops 
then Load. 

○​ Use the Load button on the bottom of the screen. 

Continue selecting and/or making changes to the route, as needed. As each stop is loaded, it will appear 
listed in the Route Grid.  

●​ To unload a stop from the route: 

○​ Select the red X, to the right of the stop. 

○​ Select the Unload button. 

●​ To insert a Refuel Point:  

○​ Select (highlight) the stop in the Route Grid. 

○​ Select Insert Refuel Point. 
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●​ Choose the Refuel Point Name from the Info box. 

○​ Select OK. 

Use the toolbar icons at the top of the screen to set/change the Route Start Time, edit a leg/route, or 
invert a route. 

●​  Invert Route  will reverse the order of stops on the route. 

●​ Set/Change Route Start Time  to edit or change the start time of a route (or group/range of 
routes). 

●​ Edit Leg/Route  to add/delete/edit any leg on the route. 

●​ Build Routes  performs Initialize/Load function (loads unloaded stops). 
 
When the build has been completed and no additional changes appear needed, left click on the Finish 
button on the bottom of the screen.  
 

5.7.​Priority Routing Results 
Finished routes will open in the DirectRoute Route Book. If additional edits or changes are needed, they 

can be completed in the Route Book, or select the Priority Routing icon from the toolbar .  
 

Unloaded Stops 
To load or build routes for any remaining unloaded stops, select the Build Routes icon  on the toolbar.  

●​ The Build Routes icon  performs the same function as Initialize/Load during the route building 
process in DirectRoute. 

●​ The DR Algorithm will attempt to load any unloaded stops on existing routes, if feasible, or build a 
new route(s). 

 

Statistics 
When using Priority Routing to manually build routes, statistical boxes are displayed for each route and 
truck, on the right side of the Route Grid. During the route building process, as changes are made to the 
route, the statistics will automatically update to reveal the effects of each change. In addition, any 
violations will also be displayed. 

●​ Select the Route Book Icon  to view Route Statistics. 

●​ Select the Truck Icon to view Truck Statistics. 
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Figure 76 – Priority Routing Statistics Boxes 

 

5.8.​Selective Routing Tool 
Similar to the Priority Routing Tool, the Selective Routing Tool provides an optional order selection filter 
that can be applied when selecting orders for routing, enabling greater control and flexibility of stop and 
vehicle selection when building routes manually. Key components:  

●​ Stop User Field filter, to select orders to route. 

●​ Apply load adjustments to vehicles; sliding meter enables adjustment of vehicle Capacities 
(Volumes), Work Time, Target Time, and Max Drive Time. 

●​ Import orders (stops) directly from DRTrack™ into Selective Routing to create manual routes.  

 

Before using the Selective Routing Tool, Stop User Fields and Order Criteria Fields should be updated. 

●​ Review and update Stop User Fields options (Preferences > Configuration > Stop User Fields) 

○​ Edit/add all Stop User Fields that are used in the Stop File.  

●​ Review and update Order Criteria options (File > Preferences > Other > Order Criteria > Query by 
User Field). 

○​ Use the dropdown arrow to select a Stop User Field from the list; fields populated based 
on the inputs in Configuration > Stop User Fields. 

●​ Review and update Query by Values option (File > Preferences > Other > Order Criteria > Query 
by Values). 

○​ Left click Collection to see the available values. 

○​ Use the  button to add/edit the Values for the Stop User Field (Values found in Stop 
File). 
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○​ Select the  button for each Value input. 

○​ Add as many Values as needed; use the  button to delete Values if necessary.  

 

 
Figure 77 – Order Criteria Preference Setting 

 

 
Figure 78 – Order Criteria Values 

 

●​ Review and update the Stop Selection Color options (selected stops will be color-coded on the 
map). 

●​ After all updates have been completed, close the Preferences dialogue box. 

 

Now the Selective Routing Tool can be initiated.  

●​ Select File > New > Route > Selective Routing. 
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Figure 79 – Start Selective Routing 

​  

5.8.1.​ Selective Route File Selection 
Use the Stop and Truck buttons to select the appropriate files to use (Distance File is optional). 

●​ Select Enable Preprocess settings to apply Preprocess settings (Preferences), if desired. 

●​ Ensure No Initialization is selected. 

●​ Edit the Dispatch Date. 

●​ DRTrack Users: To import and use DRTrack orders/files, select the Import from DRTrack tab. 

○​ Select the Branch and Truck File. 

○​ Edit dates to select ALL orders within the date range. 

○​ After all selections have been completed, select the OK button. 
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Figure 80 – Selective Routing DRTrack Options 

 

Note for DRTrack Users: When using Order Criteria selection fields, only orders with matching values will 
be included in the download file. To remove the filter and enable download of ALL orders, simply clear 
these entries from Preferences. 

 
DirectRoute will initialize the selected files automatically and when complete, the Selective Routing 
dialogue box will open.  
 

The Selective Routing dialogue box contains two grids; Trucks in the top half of the box (Truck grid) and 
stops from the Stop File in the bottom half of the box (Stop Grid). Both grids will list the available 
resources and the number of each on the tab button {i.e. Empty Trucks (15), Unloaded Stops (138)}. 
 

 
Figure 81 – Selective Routing Info Box 

 
The columns in both grids can be sorted, filtered, and moved (re-ordered).  

●​ To move a column, drag the column heading and drag/drop in the desired location. 

●​ To sort a column, click the column heading title. 

●​ To filter a column, click the filter icon adjacent to the column heading title, then select a field option 
from the Filter dialogue box. 

 

5.8.2.​ Selecting Stops 
There are several ways to select stops for use in the routing solution, but this section will focus on 
selecting stops during Selective Routing. 

●​ To select stops individually, place a check mark in the box (left of the stop#), or 
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●​ Select ALL; check the box located in the very top row (with column headings), or 

●​ Filter the list of stops by using the Select Stops by Filter in the top right corner of the stop grid 
(Order Criteria options must be set in Preferences). 

○​ When used, only stops that meet that the selection criteria will be returned and shown in the 
stop grid. 

○​ Click the dropdown arrow to select the field. 

○​ Click the box to the right of the field to display and select from the list of values associated 
with this field (values displayed are those used in this column in the Stop File). 

Example: Company A performs daily routing functions for shipment the next day. The availability status of 
each item ordered is annotated with a ‘X’ in the Stop File, in the column ‘Available’ (a Stop User Field). 
Using the Order Criteria settings, and the Selective Routing tool, orders can be filtered, and routes built to 
include only the orders with an ‘X’ in the ‘Available’ column. 

 

 
Figure 82 – Selective Routing Stop Filter 
 

●​ If any of the selected stops did not load, the grid will remain open and a message will display to 
indicate how many stops were not loaded. 

 
Figure 83 – Selective Routing Stops Not Loaded 

Additional stops can be selected from any remaining unloaded stops on the Unloaded Stops tab, 
repeating the steps to select and load, until all desired stops have been loaded.  
 
From the Unloaded Stops list, a counter at the bottom of the grid keeps count of the number of stops 
selected. Sort stops in the grid by Stop, Order, or Line Item number. 

●​ Use the View By box’s dropdown arrow to make the selection option. 

●​ View by Stop will return the fewest records in the Stop Grid, as orders are consolidated at the 
stop level.  

●​ View by Order will show all orders (unconsolidated) for every stop.  

●​ View by Line Item may return the most results, as one stop may include several orders, and each 
order may include multiple line items. 
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●​ Once selected, the records will sort automatically according to the option chosen. 

Select stops by choosing any of the configured Stop User Fields. 

●​ Use the Select Stops by box’s drop-down arrow to select an option. 

●​ Once a selection option has been made, use the dropdown arrow in the next box to choose from 
the list of data values found within the record’s selected Stop User Field.  

You can also edit any of the Stop User Fields in the grid. 

●​ Locate the desired record and Stop User Field then double click on the box to edit. 

 

 
Figure 84 – Selective Routing Stop View 
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Figure 85 – Selective Routing Stop Selection 

 
After stops are loaded/routed, they’ll be removed from the Unloaded Stops tab and moved to the Routed 
Stops tab. 

After the selection(s) have been made, click Load Stops  in the bottom right corner next to the red X, 
to route the selections. 

●​ The Routed Stops tab will appear in the stop grid and list all stops that were routed. 

●​ A message in the bottom left corner will indicate how many stops were routed.  

 
Figure 86 – Selective Routing Loaded Stops​  
​ ​ ​  
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5.8.3.​ Loading Trucks 
Trucks can be selected for routing using any of the methods listed below. After the stops are loaded, the 
loaded trucks will be removed from the Empty Trucks tab and reappear in the Loaded Trucks tab. 
 
Selecting Trucks 
Select the trucks to load from the list of Empty Trucks. A counter at the bottom of the Truck grid keeps 
count of the number as vehicles are selected. 

 
Figure 87 – Selective Routing Truck Grid 

●​ To select vehicles individually, check (left of the Truck ID), or select ALL; check the box located in 
the very top row (with column headings). 

●​ Truck Adjustments enables adjusting vehicle load capacity or adjusting the level at which work 
rules are filled (default levels = 100%). 

○​ Drag the orange slider button to adjust levels {left (-), right (+)}, or  

○​ Click the red dot and use the keyboard arrow keys (>) to move the slider left or right in 
small increments. 

 

5.8.4.​ Using the Lasso to Select Stops 
The Lasso Tool can also be used to select stops to load or unload. 

●​ Select the Lasso Tool from the menu then use the mouse pointer to draw an image around the 
desired stops. 

The Selective Routing dialogue box will open to display the selected stop(s) in the Stop Grid. 

●​ If a stop is loaded on a route, it will appear on the Routed Stops tab. 

●​ To unload the stop, select it from the list (Routed Stops tab) then select the  button. 

●​ If a stop is unloaded, it will appear on the Unloaded Stops tab.  

●​ To load the stop, select it from the list (Unloaded Stops tab) then select the  button. 

Close the Selective Routing dialogue box to view the adjusted routes. 

●​ The map screen will show the new routes, adjusted based on the changes made. 

●​ The Detail and Summary Reports will show the refreshed route info. 

●​ The Differential Info box will show the stats for the adjusted routes. 
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Additional route edits can also be completed using the traditional methods (Modify menu, or Route Book 
menu). 

Note: For more information on using the Lasso tool, see Using the Lasso Tool. 

 

5.8.5.​ Selective Routing Results 
Routes created with the Selective Routing Tool, as well as any unloaded stops, can be viewed and 
modified in the Route Book. 

●​ Both routed and unloaded stops are displayed on the map (red–unloaded, green–routed) 

●​ In the Unloaded Stops section of the Map Filter Info box, will be a drop-down list of the Stop User 
Fields, and the number of unloaded stops remaining for each value. 

●​ Check or uncheck the Stop User Field values to see or remove the stops from view on the map. 

●​ In the Routes section of the Map Filter Info box, use the check mark to toggle on/off the view of 
the routes on the map. 

●​ Selected stops and routes can be edited within the Route Book.  

●​ Unloaded Stops can be viewed and/or loaded from the Unloaded Stops tab. 

 

 
Figure 88 – Selective Routing Results 

 

5.9.​Apply Minimum Time Between Stops After 
Directions 

DirectRoute enables the automatic addition of minimum time between stops during the route-building 
process. When used, the Apply Min Time Between Stops After Directions option will tell DirectRoute to 
apply the designated time (Minimum Time Between Stops) during the route-building phase, eliminating 
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the need to add additional time to stops when needed. The result is more accurate planned stop arrival 
times. This new option can be used with any existing Route File or applied when creating new routes. 
 
To enable the Apply Min Time Between Stops After Directions option, edit DirectRoute Preferences 
(Routing > General). 

●​ Select TRUE and edit the designated time (minutes) in Minimum Time Between Stops, or  
●​ Select FALSE and no other action is required. 

NOTE: Minimum Time Between Stops (minutes) = The number of minutes DirectRoute should apply 
between stops. This is required when Apply Min Time Between Stops After Directions is set to TRUE. 

 

 
Figure 89 – Apply Min Time Between Stops 

From the DirectRoute toolbar, select the Get Directions icon  . 

●​ In the Route Directions dialog box, click Apply Min Time Between Stops. 

●​ To limit which routes this option is applied to, edit From Route and To Route with the appropriate 
route numbers. 

●​ Select OK when all options have been chosen. 

 
Figure 90 – Get Directions/Apply Min Time Between Stops 
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DirectRoute will recalculate the estimated arrival times for affected stops and update the Route Book 
accordingly. 
 
When Apply Min Time Between Stops is not needed on every route all the time, but when it is needed, the 
amount of time (minutes) added is standard for all stops, the Preferences can be set in a manner that will 
allow it to be turned 'on' within the Route Book, without needing to re-edit Preferences each time. 

●​ Set Apply Min Time Between Stops After Directions to FALSE. 

●​ Update the Minimum Time Between Stops (minutes) with the number of minutes commonly 
(standard) used. 

 
The next time the function is needed, all actions can be completed from within the Route Book. 

●​ From the DirectRoute toolbar, select the Get Directions icon  . 

●​ In the Route Directions dialog box, click Apply Min Time Between Stops. 

●​ To limit which routes this option is applied to, edit From Route and To Route with the appropriate 
route numbers. 

●​ Select OK when all options have been selected. 

 
DirectRoute will recalculate the estimated arrival times for affected stops and update the Route Book 
accordingly. 
 

6.  Speed Adjustments 
DirectRoute provides a wide-range of optional speed settings that can help you build routes that take into 
account many real-world factors drivers might encounter. 
 
 

6.1  Speed Adjustments at Project-level 
If one chooses not to use a Distance file, they can set a speed and speed adjustment in their Routing 
Preferences for the algorithm to use with every routing solution. See Preferences> Routing> General> 
Speed  

The Speed field indicates the average speed for all vehicles included in the routing solution (e.g, 60). 

●​ A Speed entry of 0 means the user is opting for the proprietary Route speed calculation rather 
than a user-defined value.  

The Speed Adjustment is the percentage increase or decrease on top of the average speed entered.  

●​ A speed adjustment entry of 100% means no adjustments are made.  

For example, a Speed adjustment of 120% decreases the speed of the Route because it 
increases the time by 20%. An 80% adjustment increases the speed because it decreases the 
time by 20%.  
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(.5 hrs x .80 = .4      30 mins x .80  =  24 mins  ー The Route went from 30 mins to 24 mins) 

 
Figure 91 - Speed and Speed Adjustments Preferences  

6.2  Speed Adjustments for Stop / Truck File 
In addition to project-level speed settings, adjustments can be defined to accommodate known 
occurrences such as traffic slow-downs in construction zones or a rush hour traffic influx. These are 
included in calculations using optional fields in the Stop and Truck files. The distance of the radius at 
which a slower speed is applied is described in the table below. 

●​ Project-level and Stop/ Truck file speed adjustments are compounded when used together. 

 

Zone Speed Adjustments 
File Field Distance (Radius) Center of Radius 

Stop Zone 8 miles, 24 hours a day Next stop in sequence 

Truck Zone 8 miles, 24 hours a day  Depot 

Rush Hour Speed Adjustments 
File Fields Distance (Radius) Center of Radius 

Stop AMAdj, PMAdj %Adj The Rush Hour Distance set in Preferences. Next stop in sequence 
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Truck AMAdj, PMAdj %Adj The Rush Hour Distance set in Preferences. Depot 

 
 

7.​ The Route Book 
A new Route Book is created each time a new routing solution is completed. It provides a detailed picture 
of each individual route, as well as summarized data (route report) for the entire routing solution. 

•​ Customized summary information about the routing solution. 

•​ Customized view of individual routes and stops. 

•​ Modify routes by adding or deleting stops.  

•​ Display capacity, drive time, and work time gauges for each route. 

•​ Generate turn by turn directions for each route. 

The Route Book contains a summary of all routes, as well as detailed information for each individual 
route. The Route Book also provides the opportunity to review and experiment with making your own 
"what if" changes to the routes.  

When the route building process completes, the Route Book becomes available for view. 

•​ Select View > Route Book from the menu, or use Ctrl+B.  

•​ To open a previously saved Route Book (Route File), select File > Open > Route, and select the file 
name to open. 

When the Route Book opens, the Route Book tab appears (just below the toolbar) adjacent to the Stop 
and Truck File tabs.  

•​ The first Route Book opened will appear as (P) Route Book 1 (on the tab); this identifies it as the 
primary Route Book. 

•​ If a second or subsequent Route Book(s) are opened at the same time, each additional Route Book 
will be numbered as Route Book 2, Route Book 3, etc. 

Included in the Route Book view are the solution Info boxes. The Route Info, Stop Info, Truck Info, 
Solution Info, and Differential Info boxes all display various information pertaining to the individual routes 
and/or stops that are present in the Route Book.  
 

7.1.​ Route Book Tools 
The Route Book tool bar is located on the right side of the Route Book. It provides shortcuts to common 
route modification actions and tools to alter the Route Book views.  
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Figure 92 – Route Book Tool Bar 

Use the Route Book filter to filter results in the Route Book. Let the filter tool help you select route info 
fields and field results to filter, or you can use free-form text, without navigating through the entire filter 
workflow.  
The Route Book properties include settings for column width, font, and color; or adjust view by hiding or 
showing grid lines, etc.  

•​ To adjust any of the settings, right click within the Route Book to open the Route Book menu. 
•​ Select RT Book Properties then select the item that requires modification from the extended menu. 

 

 
Figure 93 – Route Book Properties 
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Tip: The Route Book contains several tools to enable editing of the stops, routes, and final route results. 
Editing can be done within the Route Book, on the map, and even within the Solution Info panels. See 
Route Modifications for additional information and instructions on these options.  

 

7.1.1.​ Show Gauges 
Gauges are available to provide a quick view of total work time, drive time and capacity levels on each 
route. This can be useful when needing to add and/or delete stops, as you can quickly see when a vehicle 
and/or route are close to maximum capacity. If a route capacity is exceeded, the gauge color will 
immediately change from blue to red.  
 
The gauges, when used, will appear adjacent to the Route Book toolbar on the right side of the screen. 

•​ Right click anywhere in the Route Book and select Show Gauges from the menu, or  

•​ Select the Show Gauges icon  from the Route Book toolbar. 

 
Figure 94 – Route Gauges 

 

7.1.2.​ Show or Hide Details, Directions 
Additional tools available for selection from the Route Book menu. 
 
Skip Empty Routes –Dependent on the size of the fleet in your Truck File, the routing solution may 
include empty routes and vehicles that have not had any stops loaded on them. The empty 
routes/vehicles can be skipped so they are not visible. This is especially helpful when viewing and/or 
printing any of the route reports. 

•​ Right click from within the Route Book to display the menu and select Skip Empty Routes. 
 
Show Stop Detail–Review detailed stop data for any stop, on any route. 

•​ Select the specific stop in the Route Book to highlight the stop. 
•​ Right click and select Show Stop Detail from the Route Book menu.  

 
Show Directions–This command allows you to view the detailed turn by turn driving instructions for the 
route you have selected. See Generate Driving Directions for more information on generating 
directions. 
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When directions have been generated, select the Show Directions icon  (located on both the 
DirectRoute toolbar and the Route Book toolbar). To remove the directions from view, select the Show 
Directions icon again.  
 

7.2.​ Route Book Reports 
DirectRoute provides a great deal of flexibility for presenting and viewing route information. The Route 
Book reports are broken down into three areas, each having different formats that can easily be 
customized.  

•​ Summary Report–Pertains to the summary page of the Route Book.  

•​ Detail Report–This is the body of the report, and lists all the individual route details. 

•​ Header Report–Contains the Column headings information. 

•​ Solution Statistics–Contains statistical data for the current routing solution. 

o​ Select View > Solution Statistics from the main menu. 

o​ This report can be exported (saved) to a .csv, .tab, or .xls file. 

•​ Miles by State–Displays the total miles by state for all routes (requires Generate Route Directions 
be set to TRUE in Preferences). 

 
The Summary, Detail, and Header Reports are offered in three separate pre-defined formats or may be 

customized. To view the formats for each report, select the Report List icon  from the Route Book 
tool bar then select one of the reports listed. 

 
Figure 95 – Predefined Report Formats 

 

7.2.1.​ Summary Report 
To view the Summary Report, open the Route Book (File > Open > Route), or if still in the routing mode, 
select View > Route Book from the menu, or use Ctrl+B. 

•​ Displayed when Sum is selected in the column on the left; when the Route Book opens it will 
usually open to this view. 

•​ The Summary Report displays a list of all the routes created in the project, route numbers, truck 
IDs, route totals (miles, hours, stops, etc.), cumulative totals, and averages. 
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•​ Select the view format you want to use from the Report List on the Route Book toolbar. 

 
Figure 96 – Route Summary Report 

 

7.2.2.​ Detail Report 
To view the Detail Report for each route, select the Route # from the column on the left. 

•​ Displayed when the route# is selected in the column on the left. 

•​ The Detail Report displays the individual route information. 

•​ Consolidated stops can be exploded to view by selecting the + adjacent to the stop. 

 
Figure 97 – Detail Report 

 

7.2.3.​ Header Report 
The Header Report appears above the Detailed Report in the Route Book. 

•​ Displayed when the Detailed Report is displayed. 

•​ Contains the route totals for just that route, for each Stop Field column listed in the Detail Report. 

 
Figure 98 – Header Report 
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7.2.4.​ Miles by State Report 
The Miles by State report is generated when Generate Route Directions is set to TRUE in Preferences. 
DirectRoute totals the miles by state when generating directions and displays the totals in report format. 
 
The Route Summary tab lists the totals for each route separately, while the State Summary tab lists the 
totals by state. 

•​ Free Miles–Free miles traveled (non-toll roads) for each state. 

•​ Toll Miles–Toll road miles traveled for each state. 

•​ Toll Cost–Toll costs for each state. 

•​ Total Miles–Total miles for each state. 

 
Ensure Generate Directions is enabled in Preferences > Preprocess > Generate Distance File > Generate 
Route Directions = TRUE. 

•​ After creating a new routing solution with Generate Directions set to TRUE, select View > View 
Miles by State from the main menu.  

•​ This report can be exported (saved) to a .csv, .tab, or .xls File.  

 
Figure 99 – Miles by State Route Summary 
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Figure 100 – Miles by State Route Summary 

 This report can also be downloaded and saved to a .csv, .tab, or .xls File; click the Save button, then 
save the file to a location of your choice.  
 

7.2.5.​ Solution Statistics 
The Solution Statistics report contains statistical data for the routing solution that is currently displayed/ 
open. The totals listed are calculated for all routes in the current solution. 

This report can also be downloaded and saved to a .csv, .tab, or .xls File; click the Save button, then save 
the file to a location of your choice.  

 
Figure 101 – Solution Statistics 
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7.3.​ Customizing Reports 
Any of the formatted reports (Summary Report, Detail Report, and Header Report) can be customized by 
adding additional columns of information to display.  
 
To add columns to reports: 

•​ Select the Route Book Fields icon  from the toolbar. 

 
Figure 102 – Route Book Report Fields 

 
•​ Select the + key next to the Field Type to expand and show available columns  
•​ Drag the selected column and drag it into the header position on the Summary page 

 
Figure 103 – Detail Report Customization 

 
Once a column is inserted, the software will automatically populate the data into the columns.  

•​ To delete any column, right click on the column to display the Route Book menu, then select 
Delete RT Book Field. 

Tip: Column order within the reports can also be changed by selecting a column and drag it to the position 
desired 
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7.3.1.​ Header Report Customization 
Each column name can be customized to display any name.  

•​ Click on the column Header Title (to highlight); the Header Edit box should open at the 
bottom of the report. 

•​ Type the new Display Name in the Display Name box; adjust column width, if desired. 

•​ Select the Save button to save the changes. 

•​ Add a File Name to the Save Info box then select the Save button. 

•​ This will save the new format for use in other Route Books.  

•​ Select the Refresh button and the new Display Name will appear in the header. 

 
Figure 104 – Header Report Customization 

 

7.3.2.​ Multiple Report Formats 
When multiple report formats for the Route Book are necessary (for multiple DR Users), each differently 
formatted report can be saved to a User’s specific Data Directory. If only the detailed report (F8.DRP) is 
altered, the SRP and HRP files, even if unchanged, must be copied to the DirectRoute Data Directory.  

•​ Make changes to Route Book format, as required. 

•​ Save the new report to the appropriate user DirectRoute Data Directory. 

•​ Copy the other unchanged reports from the user’s Folder, to the DirectRoute Data Folder (not 
User-specific). 

•​ When a route is opened, the software will look in the DirectRoute Data Folder first. 

 
Figure 105 – Route Book Reports 
 

Tip: The DirectRoute Data Directory refers to the location of the DirectRoute Route Files and folders. 

Tip: Even if only one report format is changed, all three reports must be copied to the data directory. 
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7.4.​ Route Book Info Boxes 
The Stop, Truck, Route, Solution, Differential, and User Field Values info boxes contain valuable, 
at-a-glance information eliminating the need to view the actual Route Files. They are viewed on the right 
side of the screen, adjacent to the Route Book. 

 
Figure 106–Route Book Info Boxes 

●​ The Route Info box – Contains statistics pertaining to the Route that is currently appearing in the 
Route Book. 

○​ The percentage displayed represents the Route’s current capacity related to the primary 
capacity or volume 

○​ Click on the arrows to scroll through each Route on the map 

○​ The lock/unlock icons control what Routes are displayed on the map at the same time 

■​ Typically, only the active route is displayed on the map at any given time 

■​ Locks DO NOT prevent modifications made by the user or the algorithm 

○​ Click on the lightening icon to reveal an additional toolbar for favoriting Routes and syncing 
Route info between windows 

○​ Use the letter icon to customize the fonts within all Info boxes 
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○​ Sync information automatically to the active Route. 

●​ The Truck Info box – Contains info pertaining to the truck used for the selected Route and/or 
Stop. 

○​ Locate the Truck record with the row number, and use the arrows to scroll through the 
rows 

○​ Browse Truck User Fields by category or alphabetically 

○​ Favorite any attribute to bring it into the Favorites section 

○​ Sync information automatically to the active truck 

○​ Use the letter icon to customize the fonts within all Info boxes 

●​ The Stop Info box – Contains info pertaining to the specific Stop record that has been selected. 

○​ Locate the Stop record with the row number, and use the arrows to scroll through the 
rows 

○​ Sync information automatically to the active Stop 

○​ Use the letter icon to customize the fonts within this Stop Info box 

○​ Browse Stop User Fields by category or alphabetically 

○​ Favorite any attribute to bring it into the Favorites section 

○​ Open a detailed Stop Info box and show or hide the selection on the map 

●​ Solution Info tab – Contains statistical data for the Routes. Statistics and totals listed are for all 
Routes combined. 

●​ Differential Info tab – Displays the differences in values (e.g., Miles, Work Time, Cost) when one 
or more moves are made on a route. 

○​ DRStats – Values achieved immediately after DR completes initial route loading  

○​ Transactional – Difference in values immediately following a move (differences between 
the last move and current move). 

○​ Cumulative – Adds the value differences of all moves. 

●​ Map Filter tab – Allows the user to filter Unloaded Stops using any stop-level user field and its 
data 

Example: The results displayed in Figure 107 below were received following two separate moves on a Route. 

 
Figure 107 – Differential Info Box 
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Move 1 resulted in an increase of 26.4 miles to the Route, an increase of .58 hrs., and a cost increase of 
$39.90.  
 

Move 2 resulted in an increase of 19.4 miles (from the total miles presented as of the last move), an 
increase of .52 hrs. (from the total hrs. presented as of the last move), and a cost increase of $71.24 
(from the total cost presented as of the last move). 

Tip: Double-click on any stop or route in the Summary Report or on any stop on the map, to synchronize 
the Info boxes (Stop, Truck, Route), then select the desired Info tab located in the lower right corner 

Tip: Solution Statistics can also be viewed in spreadsheet format by selecting View > Solution Statistics 
from the menu at the top of the screen.  

Tip: The info boxes can be repositioned to view on the top or bottom, right or left side of the screen. Just 
click and hold the box tab (bottom of the screen) then drag it to the desired location; look for the grey 
position guide to help place the box in the correct location.  

Tip: Data can be edited from the Stop/Truck Info boxes; place the cursor in the box on the line to edit, 
make necessary changes, and select the F9 key to apply/save updates to the Route Book.  

 

7.5.​ Selecting Records for Display and Edit 
To select a specific record for display and/or editing, use one of these three options to locate and select 
the record. 

•​ Position the cursor over the top of any stop symbol on the map, Ctrl+Click, or 
•​ Edit the row# in the Info box (type the row # from the spreadsheet of the Truck or Stop File for 

the desired record, or the route #), or 

•​ Use the arrows  adjacent to the Row# to move to the next or previous record in the 
spreadsheet and/or route. 

To edit a record from one of the info boxes: 

•​ Locate the data in the info box to edit, and edit as necessary. 

•​ Press the F9 key to apply and save the updates to the Route File. 

 
The edits will carry/be applied to the spreadsheet column/cell immediately. 
 

7.6.​ View Route Violations 
The following violations are displayed in the Route Book Summary page, on the Route Page, and in the 
Route Info box. 

•​ Window – Time Window violation; delivery was made outside of the times allowed for the 
stop. 

•​ Drv Tm – Drive Time violation; the Drive Time as set in the Truck File has been exceeded. 

•​ Wrk Tm – Work Time violation; the Work Time as set in the Truck File has been exceeded. 

•​ Rtrn Tm – The Return Time for a driver to return to the terminal, as set in the Truck File, has 
been exceeded. 

•​ Wt Tm – Wait Time violation; the vehicle has exceeded the time allowed to wait at a stop. 
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•​ Cap – Capacity, as set in the Truck File, has been exceeded; check File > Preferences to 

ensure that another Capacity field has not been entered. 

•​ EqCode – EqCode violation; a stop has been loaded which does not meet the EqCodes for 
the truck. 

•​ Seq – Sequence Code previously entered in the Stop File was not followed; check the 
EqCode field for Sequence Codes. 

•​ MaxDist – Maximum distance between stops on a route violation. 

 
Figure 108 – Show Directions 

7.7.​ Generate Directions 
After a route has been created, turn by turn directions can be acquired in DirectRoute leveraging its 
integration to PC*Miler. Using Get Directions updates the Route’s given ETAs for all Stops, and, based on 
the transit time being used, may create Time Windows violations that did not exist prior. Also, the actual 
transit time may be longer than the algorithm anticipated using either Crow Flies mileage and transit times 
or an actual Distance file. 

●​ When directions are generated, the route lines on the map will follow the road network as 
opposed to using straight lines to connect the stops. 

●​ If you normally optimize routes, it is important to do so prior to generating directions. Any changes 
to a Route (manual or via optimization) resets the Route and directions to the previously 
calculated mileage,  transit time, and Route lines. 

●​ Get Directions uses either an API connection to retrieve mileage and transit time from PC*Miler, 
or information stored locally in the PC*Miler version installed in DirectRoute.  

○​ Trimble Maps (Preferences > Mileage System) is the default setting. It enables the use of 
several API calls that DirectRoute utilizes to get access to more, actively updated 
information. 

○​ If PCM*Direct is selected as the Mileage System, all API calls are turned off and PC*Miler 
is used for all mileage and transit calculations. 

●​ The PCM versions available in the Trimble Maps tab drop down are related to the user's API key 
and product licensing. 
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○​ The Current option references a database of information which is undated every 2 weeks 

○​ The remainder of the options reference specific static databases which coincide with the 
release of that years' PCM version 

○​ the PCM_GT database is not updated at regular intervals and relate to GeoTrack/Energy 
mapping 

To generate driving directions select Get Directions  from the main toolbar.  

●​ If your route has already been built and you plan to edit or modify the route, select the Generate 

Directions on Route Edit icon  from the toolbar before editing your route. This will ensure 
directions are regenerated automatically as soon as your edits are made on your route.  

 
Figure 109 – Trimble Maps Settings with the PCM version dropdown 

7.7.1.​ Driving Directions Options 

After selecting the Get Directions icon  from the main toolbar, select the desired options by placing a 
check mark in the box next to it the General tab (Route Directions dialogue box). 
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Figure 110 – Driving Directions Options 

 

•​ Identify the route numbers for which directions are wanted in the From Route and To Route 
boxes. For example, choosing From Route = 1, To Route = 5 will generate directions for 
routes 1 thru 5 only. 

•​ Use DirectRoute Drive Time–If selected, DirectRoute will generate drive times using 
proprietary calculations based on time and distance data obtained from PC*Miler (only 
replaces PC*Miler generated drive times). 

•​ Use Mileage System Drv Tm if greater than DirectRoute Drv Tm–If the ‘Use DirectRoute 
Drive Time’ option has been selected, this option can be enabled in addition. This option 
ensures the slowest segment drive time by using PC*Miler segment data if that drive time is 
greater than the time calculated by DirectRoute. 

•​ Update Distance File–Will add new distance entries for any stops in which no current 
distance entries already exist in the Distance File. 

•​ Overwrite Existing Distance Entries–Will overwrite the current Distance File entries, if 
different from those currently posted in the Distance File. 

•​ Optimize Sequence–Will optimize the sequence of stops on each route by the distance 
between stops and may rearrange stops so that each occurs in order of their location (map 
point sequence), regardless of any time windows; may cause sequence violations. 

 

If using PC*Miler Web Services and Trimble MAPS mileage system, select the Trimble MAPS tab. 

•​ Select a Vehicle profile from the drop-down menu (most data should auto-populate). 

•​ Enter an Elevation limit (if applicable). The unit (Feet, Meters) should be the same unit of 
measure chosen for Distance Option (Preferences > Other > Distance Options) (if set to 
Meters, then set Elevation to Meters, etc.).  

o​ DirectRoute will look for alternate routes to avoid roads that would exceed the set 
limit.  

•​ Select the Route Type and Hazardous Materials options that apply. 

•​ At the bottom of the box, select all options that may apply. 
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o​ Avoid Tolls – Will steer the route away from using toll roads. 

o​ Use Toll Discounts – Enables the use of multi-state toll discount programs. 

■​ Users can set the default Toll Preference under Preferences > Trimble Maps > Toll 
Discounts and select All or None. 

o​ Route Across National Borders – Enables DirectRoute to plan a route in which one 
or more trucks may cross the US national borders in pursuit of a customer delivery.  

o​ Highway Only – Means local streets are not considered when running a route; 
vehicles are restricted to primary roads and/or Highways only, regardless of vehicle 
profile. 

 

Figure 111 – Driving Directions Options 

 

7.7.2.​ PC*Miler Direct Driving Directions Options 
If using a PC*Miler license, select and change the PC*Miler Direct option, as necessary.  
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Figure 112 – PC*Miler Driving Directions 

When all options have been reviewed and selected, click OK to generate the directions.  
 
When the directions have been created, the Route File will include directions from the depot to each stop 
on the route.  

•​ Select the Show/Hide Directions icon  on the Route Book tool bar to remove the 
directions from view, or return them to view after hiding them, or 

•​ Click on the Route Book and select Show/Hide Directions. 
 
When printing the Route File, you can choose to print turn by turn directions, as well. Save the Route 
Book with the directions, before selecting print options. 

Tip: When a Route is saved, the driving directions are saved within the Route File. When the Route File is 
reopened, the driving directions will be restored. 

Tip: When generating directions, if the option Use DirectRoute Drive Time is not selected in the General 
Tab, DirectRoute may not adhere to the default values and rules that were initially selected to produce the 
routes. This may cause a change in drive times and distances between stops, minimum times between 
stops, and other results initially received with the original routes. 

8.​ Route Modifications 
At times, it may be necessary to modify routes. There are many reasons in which already built routes may 
need to be modified, but some of the more common reasons include:  

•​ Loading unloaded stops. 

•​ Optimizing routes. 

•​ Adding new, or deleting stops. 

•​ Changing route start times. 

•​ Moving stops from one route to another. 
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As varied as the reasons, the options by which to modify the routes and/or stops are just as varied. This 
section will cover many of the ways and means by which most of the modify options can be completed.  
 
Within the Route Book, there are two ways to access the Modify menu when a Route File is open.  

•​ From the menu, select Modify. 
•​ While in the Route Book, right-click to open the Route Book menu. 

 
Both menus’ offer the same modification options. The main difference is the Route Book menu offers 
additional tools to show details within the Route Book and tools to alter the fields displayed in the Route 
Reports. 
 

8.1.​ Route Book Modify Menu 
The Modify menu is available only while the Route Book is open. The options listed in this menu provide a 
means to perform additional actions on the route without having to repeat the entire routing process. 
 
To access any of the modification options, click Modify from the DirectRoute menu, then click the 
appropriate action. 
 

 
Figure 113 – Modify Menu 

 

8.1.1.​ Undo/Redo 
Undo or redo the last action performed on a route. For instance, if you manually move a stop onto a route 
and it causes a capacity violation, you can use Modify > Undo the move and return the route to its 
previous arrangement. If you have completed several actions within the Route Book and want to undo 
them all, you may have to select the Undo command several times. 
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Example: You completed three different delete actions, to remove three stops from a route, and then 
changed your mind. Select the Undo command three times to reload the stops onto the route. 

 
Redo–Reverses the previous Undo action. This command may be used in conjunction with the Undo 
command to toggle changes. 
 

8.1.2.​ Optimize Routes 
During the route build phase, DirectRoute considers truck availability time, travel time, receiving time, 
unload time, and distance; all the parameters set within the Truck File, Stop File and Routing 
Preferences. When optimizing, DirectRoute is performing additional passes over the routing data, while 
considering penalty factors, time windows, work time, etc., to look for options that would allow stops to be 
moved either within each route, or between routes, in an effort to return a lower-cost routing solution. 
Additional options can be selected to attempt loading any unloaded stops at the same time.  

•​ Optimize Trucks After Loading–Looks to minimize costs by moving stops between routes and 
within routes. 

•​ Optimize Stops After Loading–Looks to minimize costs by moving stops between routes and 
within routes. 

•​ Optimize Within Routes (SHIFT+Ctrl+W)–Attempts to re-order the stops within a route to lower 
the overall cost. 

•​ Optimize Between Routes (Shift+Ctrl+O)–Evaluates the effects of moving a group of stops to 
other routes.  

•​ Optimization settings can be chosen before the load/route process (Preferences > Routing > 
Algorithm) or choose and apply Optimization preferences to routes already built (Modify > 
Optimize). 

See Optimization Options for more information. 
 

8.1.3.​ Add, Delete, Move Stops 
Add Stops enables the addition of unloaded stops to a route.  

•​ Select View from the dialog box. 

•​ After viewing the unloaded stops, select the OK button to return to the dialog box. 

•​ Type in the stop number(s) that you wish to add. 

•​ Type in the route number and position number where the stops are to be added. 

•​ Select the OK button. 

 
Figure 114 – Add Stop 
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Delete Stops–The Delete command allows you to delete stops from routes. 

 
Figure 115 – Delete Stop Range 
 
 Delete Range–Allows deletion of a range of stops from one route. 

•​ Type in the route number and the range of stops to be removed. 

•​ Select the OK button and the stops will be removed from the route.  

 
Delete All–Allows deletion of all stops on one route or delete all stops on several routes. 

•​ Type in the range of routes you wish to delete (type the same number in the From Route and 
To Route boxes if you wish to delete an individual route). 

•​ Select the OK button and all the stops on the route(s) will be deleted. 

 
Figure 116 – Delete Route 
 
Move Stop (Ctrl+M)–The Move Stop command allows you to move a stop, or a range of stops. 

•​ Type in the route number and the range of stop(s) that are to be moved. 

•​ Type in the route number and stop number where the stops are to be moved. 

•​ After entering all applicable information, select the OK button to move the stop(s). 

 

 
Figure 117 – Modify Move Stop 
 
See Using the Lasso to Select Stops for additional information. 
 

8.1.4.​ Reload or Load Unloaded Stops 
Modify Load Unloaded Stops allows DirectRoute to determine the best location to place Unloaded Stops. 

•​ Enter the From Stop and To Stop record numbers in the dialog box. 
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Figure 118 – Modify Load Stop 

•​ Allow Rejection–Shows a warning before the move is actually made indicating how much 
the move will cost; accept or decline the move. 

•​ Allow load on empty route (Truck)–Allows the reloaded stop to be placed on an empty 
route; leave unchecked if you do not want the reloaded stop to load on an empty vehicle.  

•​ Allow load on displayed routes only–Allows a stop to be reloaded only to routes that have 
been displayed and/or locked on the screen; routes that are not visible will be ignored during 
the reload sequence. 

 
After selecting all applicable options and information, select the OK button to load the stops. 
 
Modify Reload Stops–The Reload Stops command allows DirectRoute to take stops from an existing 
route and determine the next best route for the stop. 
 

 
Figure 119 – Modify Reload 

•​ Input Route Options. 

o​ Rt #–The route number to reload. 

o​ Fr Stop–The first stop number of the route to reload. 

o​ To Stop–The last stop number of the route to reload. 

 
•​ Select Reload Options. 

o​ Allow rejection–Gives a warning before the move is made indicating how much the 
move will cost you; accept or decline the move. 

o​ Allow load on empty route (truck)–Allows the reloaded stop to be placed on an 
empty route; leave unchecked if you do not want the reloaded stop to load on an 
empty vehicle. 

o​ Allow reload on displayed routes only–Allows a stop to be reloaded to only look at 
routes that have been displayed and/or locked on the screen; routes that are not 
visible will be ignored during the reload sequence. 
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After selecting all applicable options, select OK to reload. 
 

8.1.5.​ Edit Leg/Invert Route 
Modify Edit Leg–Enables deletion or insertion of a leg into the routes. The insert option enables insertion 
before or after another route and leg. 
 
Modify Invert Route–Reverse the sequence of stops on a route; the first stop will become the last, and 
the last stop will become the first. 

•​ Type the route number you wish to invert. 
•​ Select the OK button. 

 

 
Figure 120 – Invert Route 
 

8.1.6.​ Lock Routes 
Select this option to lock the routes so stops cannot be moved by optimization actions. These options 
may also be selected in Preferences > Routing > General prior to loading (initializing) a route.  
 
You can limit locking action to groups of routes by selecting one of the following: 

•​ Select and enter the route numbers in From Route/To Route, to select a group of routes in 
sequential order. 

•​ Select Lock Displayed Routes to limit locking action to just those routes that are displayed on 
the map. 

•​ Filter the route book to meet certain criteria, then Select Lock Filtered in Route Book to limit 
locking action to just those routes that were filtered. 

Once the routes are selected, choose the type of locking action that should occur. 

•​ No lock–Routes are available for adding, deleting, or sequencing again. 

•​ Prevent Removal–When optimizing, no stop will be removed from a route; only the 
re-sequencing and adding stops may take place. 

•​ Prevent Addition–Stop may be removed and re-sequenced, but new stops cannot be added. 

•​ Prevent Removal and Addition–Stop may only be sequenced again. 

•​ Prevent Any Changes–No changes will be made on the locked route. 
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Figure 121 – Lock Routes 

 
Additionally, routes can be locked from within the Route Info box (Route Book) individually or by groups, 
using the Lock Routes icons.  
 

 
Figure 122 – Lock Routes (Route Info Box) 
 

•​ Lock Route–Locks the current Rt number displayed. 

•​ Unlock Route–Unlocks the current Rt number displayed. 

•​ Lock All Routes–Locks all routes in the open routing solution. 

•​ Unlock All Routes–Unlocks all routes in the open routing solution. 

•​ Open Route Lock Menu–Enables selection of specific, non-sequential routes, to lock/unlock; 
separate route numbers by a comma (no space), i.e. 1,3,5. 
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Figure 123 – Open Route Lock Menu 

8.1.7.​ Switch Routes/Trucks, Set Route Start Time 
Modify Set Route Start Time–Allows adjustment of the route start time for one or multiple routes.  

•​ Type in the route number (or range of routes to change), new start time, and date for that 
route. 

•​ Select the OK button and the start time and date will update. 

 
Figure 124 – Modify Start Time 
 
Modify Switch Routes–Switch trucks between routes. 

•​ Type in the route# to switch from, and the new route#, then select the OK button. 
 

 
Figure 125 – Modify Switch a Truck 
 
Modify Unviolate Routes–Removes violation flags from stops on a route.  
 
For example, if a stop violates a time window by a short amount of time and you decide to deliver to the 
stop anyway, you can use the command to remove the violation flag.  

•​ Type the From Route and To Route numbers to specify the range of routes you want to 
modify. 

•​ Select the type of violation(s) to remove. 

•​ Select the OK button to unviolate the routes. 
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Figure 126 – Modify Unviolate 

 

Tip: Modify Unviolate Routes can change previous settings, for example, Time Windows. 

 

8.2.​ Change Stop Sequence 
To change the sequence of a stop on a route (i.e. make Stop 2 be 4, instead) 

•​ Ctrl+click on the stop that needs to move (Stop 2) to place a circle around the stop. 
•​ Hover the mouse over the location on the route where you want to move the stop (between 

Stops 3 and 4), then press Ctrl+Shift+click. 
 

 
Figure 127 – Change Stop Sequence 

 

8.3.​ Add Stops from the Map 
You can add any unloaded stop to a route from the map screen. 

•​ Ctrl+ click on the stop. 
•​ Ctrl+Shift+click on the route line where the stop should be added. 
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Figure 128 – Add Stop from Map 

Note: While in the routing mode, unloaded stops can also be loaded using the Legacy Lasso tool (Modify 
> Lasso). For more info, see Move, Delete, or Add Stops and Add, Delete, and Move Stops.  

 

8.4.​ Working with Unloaded Stops 
There are several reasons why a stop may not load, including restrictions to Time Windows, Work Time, 
Drive Time, Capacity Constraints, or EqCodes.  
 
Before adding unloaded stops to a route, it is important to know why the stop did not load in the original 
load process. To help discover this, you will first need to view the list of unloaded stops then view each 
one individually.  
 

Unloaded Stops can be viewed by selecting the Unloaded Stops tab within the Route Book.  
•​ Select any stop listed to highlight it. 
•​ Select View Reason. 

 

Or, toggle the red pin on the route tool bar to show unloaded stops on the map. 

 
Figure 129 – Unloaded Stops Tab 
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        Figure 130 – Unloaded Stops 

 
The top half of the Unloaded Stop Reason dialog box lists all unloaded stops. The bottom half shows all 
available vehicles and current route assignments that could possibly accept the unloaded stop. Additional 
information is provided for each vehicle and route:  

•​ Leg and Sequence # the stop would be, if added to the current truck/route. 

•​ Any violations that would occur if the stop were added to the current truck/route. 

•​ Total stops for the listed route if the stop were added. 

•​ Estimated arrival date/time if the stop were added. 

•​ Added cost and miles to the route if the stop were added. 

 

These options enable choosing which candidate routes to consider for possible addition of the unloaded 
stops. 

•​ Select one of the options at the top of the screen to restrict which candidate routes to view, or 
do not select any options to view and evaluate all routes (default). 

 
Figure 131 – Unloaded Stop Reason 
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8.4.1.​ Sort Unloaded Stops 
You can sort unloaded stops before attempting to load/add them to existing routes. Examples of use: sort 
by cost to select the least costly vehicle/route option, or sort by estimated arrival date/time to find which 
possible route would deliver the earliest. 

•​ Select the Unloaded Stops tab. 

•​ Select which column to use as criteria for the sort. 

•​ Select the column header to sort (alphabetically, numerically); notice the sort arrow appears 
on the right side of the column selected. 

•​ To reverse the sort, select the arrow.  

 
From the Unloaded Stops tab, you could also perform a sort by selecting more than one column of 
criteria. This may be helpful if necessary, to sort by customer and account number, or sort by zone and 
EqCode, or some other factors listed in the Stop File. 

•​ Right click and select Sort. 

 

Figure 132 – Unloaded Stop Sort Option 

 

•​ Select the 1st Key box and use the dropdown arrow to select a field to sort. 

•​ Choose a 2nd and 3rd Key and sort field, if desired. 

•​ Select the OK button to initiate the sorting of the unloaded stops. 

 

8.4.2.​ Sort from the View Reason Dialog Box 
You could also perform a sort while viewing the Unloaded Stops Reason dialog box. 

•​ Select the Unloaded Stops tab. 

•​ Right click any stop and select View Reason. 

•​ Select a column to use as criteria for the sort. 

•​ Any column in top half of the dialog box (unloaded stops), or 

•​ Any column in the lower half of the dialog box (candidate vehicles/routes). 

•​ Select the column header to sort alphabetically or numerically; the sort arrow appears on the 
right side of the selected column. To reverse the sort, select the arrow button. 
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8.4.3.​ Load Unloaded Stops 
Load unloaded stops to a route using Unloaded Stop Reason. 

•​ View candidate vehicles and routes to find a suitable position to add the stop. 

•​ Locate and select the stop (ensure the stop shows as highlighted). 

•​ Select the Load button. 

Tip: It may be necessary to edit specific information about the vehicle or the stop to add the stop to the 
route or choose to accept the violation displayed and add the stop. 

Unloaded stops can also be added without viewing the reason. This should only be done if you are certain 
as to which route and position the stop should be added. 

•​ Select the unloaded stop you want to add. 

•​ Select Add; the stop number will prepopulate, corresponding to the Row number (record 
number) in the Stop File and the Unloaded Stops list. 

•​ Type the Route and Position number to which to add the stop. 

•​ Select the OK button. 

 
Figure 133 – Adding Unloaded Stops to a Route 
 

8.5.​ Scenario Manager 
The Scenario Manager tool allows the user to run various route scenarios for analysis, without affecting 
the integrity of the original route or Route Files.  
 
Scenario Manager allows temporary changes to Route Field values and Stop Field values within the 
Route Files, to determine what affects the changes would have to the overall route solution.  

•​ What is the impact if worktime is reduced from 9 to 8 hours? 

•​ Is there a cost benefit in expanding delivery windows by 30 minutes? 

•​ If service time is reduced by 5%, how much savings would be generated? 

Many different scenarios can be built and saved, edited, and used repeatedly with any existing route and 
corresponding Route Files. If, after running a scenario, it is determined that the scenario results are better 
than the results obtained with the original route, the scenario results can be applied and saved as a new 
route (and new Route Files), while still maintaining the integrity of the original route and Route Files used 
to perform the scenario.  
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8.5.1.​ Using Scenario Manager 
•​ Open any existing Route File. 
•​ Select Analysis > Scenario Manager from the menu at the top of the screen. 

 
Figure 134 – Scenario Manager Build 

•​ Select the +Add button. 

•​ Select a field (to adjust data) using the dropdown arrow.  

•​ To the left of the field, select how the Field should be adjusted (Increase/Decrease). 

•​ To the right of the field, type the numerical amount by which the Field should be adjusted 
(number representing an amount).  

•​ To the far right of the field, select the measurement type to apply to the numerical amount, 
Value or Percent (select Value when the number represents actual hours, miles, cost, etc.). 

•​ After selections have been made, edit the Name box to rename this scenario, if desired. 

•​ To add another field, select the +Add button (no limit to number of Fields that can be used in 
one scenario). 

•​ To delete a field, select the red X.  
•​ Click on the Save button to save the scenario.  

•​ To edit/change a scenario, select the blue pencil icon to the right of the scenario name. 

•​ To delete a scenario, select the red X to the right of the scenario name. 

Example: Our current Routes are set with a Max Miles of 250. We want to see the cost results that may 
be achieved by increasing the Max Miles to 300. Select Max Miles > Increase > 50 > Value (for actual 
miles). 

 

 
Figure 135 – Scenario Manager Field Selection 
 
After a scenario has been saved, it will appear by Name in the top block of Scenario Manager. 

•​ For a quick reminder of the fields used, select the circled arrow, left of the scenario name. 
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8.5.2.​ Scenario Manager Time Windows/Buffers 
When altering Time Windows and Buffers, additional parameter options are presented. 
 

 
Figure 136 – Scenario Manager, Time Windows 

 
Parameter options for Time Windows:  

•​ Only If/Always–Select when the Time Window should be increased or decreased. 
•​ Gap–Refers to the number of hours the Time Window is open. 

 
Parameter options for Buffers 

•​ Early/Late–Enter the # hours to apply to either or both the Open (Early) and Close (Late) of 
current Time Windows. 

•​ Penalty–Enter a dollar amount to apply as a penalty when/if the buffer is applied. 

Example: Routes feature a mix of Time Windows with open periods of 4 and 6 hours. To see the effect if 
all the open periods were 6 hours, select: Time Window > Increase > 2 > Value (actual hours) > Only If > 
Gap (Less Than) > 6. 

 

8.5.3.​ Scenario Manager Results 
After a scenario has been built and saved, it is ready to run. All scenarios are run from an open Route 
Book, so ensure the desired Route File is opened. If the Scenario Manager is not currently open, open it 
by selecting Analysis > Scenario Manager from the menu at the top of the screen. 

•​ To select a Scenario from a list of saved scenarios, click on the box to the left of the scenario 
name to select it (box will appear colored when selected). 

•​ Repeat to de-select any scenario. 
•​ Select the Run button in the top right corner of Scenario Manager. 

 

 
Figure 137 – Run Scenario Manager 

 
As the Scenario Manager is processing, a progress bar will appear. Once the process has completed, the 
results will be displayed in the bottom half of the Scenario Manager box. The results will include the 
original values for the route before it was adjusted (BaseResult), and the new values (ScenarioName), as 
well as the change value (+more or –less).  
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Example: The Max Drive Time on our current route is 6 hrs. and Max Work Time is 7 hrs. In the Scenario 
image above, we increased our Max Drive Time by 2 hrs. and our Max Work Time by 2.5 hrs. The results 
indicate our total cost decreased by ($1583.31), the Distance decreased by (277.87), and Elapsed Time 
decreased by (5.47).  

 

 
Figure 138 – Scenario Manager Results 

 

Tip: Scenario Manager will apply Optimization if set to TRUE in Preferences > Routing > Algorithm > 
Optimize Stops After Loading 

 
If the Scenario results are determined to be optimal, the results can be applied (Load) and saved as a 
new route/files, while still maintaining the integrity of the original route/files used. 

●​ Select the Load button adjacent to the scenario results. 
 
Scenario Manager will save and close the original Route Files (unchanged), and then create and save 
duplicate files with the change applied. The new files will bear the scenario name as an extension to the 
original file names.  

Example: Original file name = Phx1502, new file name = Phx1502-Mileage Cost.  

8.6  Cross Dock vs DC 
The Cross Dock vs DC (Distribution Center) tool allows users to evaluate customer service areas, where 
multiple methods for distribution exist, and determine the best network design solution based on cost. 
E.g., Is it cheaper to ship / service the customer directly from the distribution center or complete a line 
haul to a local cross-dock or warehouse for final delivery. The generated solution can then be fed to 
DirectRoute to determine the best Route and Stop sequence. 

●​ The algorithm does not evaluate the feasibility of the Route, driver work rules, or 
customer-specific time windows and service times.  

●​ The DC is the main hub or manufacturing location for all end-user products. There should only be 
one DC for the solution.  
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●​ The Cross Dock vs DC solution uses the Stop and Truck files (Distance file is optional). 

○​ Stop file:  

■​ No required Stop User fields. 

■​ Customer list ー Drives the demand for the evaluation 

■​ Volume displayed ー Can be a daily volume or an average weekly amount 

○​ Truck file:  

■​ Mileage Cost (MiCost) ー feeds the cost evaluation 

➢​ Cost from DC = (Stem Mileage of each stop from DC x 2) x Mileage Cost x (TTL 
Stop Volume / TTL DC Truck Capacity) 

➢​ Cost from Crossdock = (Stem Mileage from Cross-Dock x 2) x Mileage Cost x 
(TTL Stop volume / TTL Cross-Dock Truck Capacity) + (DC to Crossdock 
Mileage x 2) x Mileage Cost x (TTL Stop Volume / TTL Linehaul Truck Capacity) 

➢​ Multiplying the Stem Mileage x 2 accounts for round trip mileage. Two columns 
are inserted in the Stop file for DCCost and CDCost. 

■​ Must have the City name 

■​ Must have the TruckType Truck User field. 

➢​ There are three different Truck types/ scenarios tied to the TruckType: 

●​ Blank field = Trucks the main distribution center has for delivery to their 
local customers. 

●​ LH = Trucks available for Line Haul deliveries (e.g., DC to Cross Dock). 

●​ CD = Trucks available for Cross Dock deliveries (e.g., Cross Dock to end 
customer).  

➢​ The main DC utilizes all the Blank Truck and LH Truck Types.   

➢​ The Cross Dock facilities utilize CD TruckTypes only.   

➢​ The number of trucks entered in the Truck file represents the typical amount of 
trucks needed to satisfy the current work load. 

8.6.1 Use Cross Dock Tool  
To use the Cross Dock vs DC Tool complete the following: 

1.​ Ensure the proper Configurations are set ー TruckType is required as a Truck User field. To 
include TruckType, complete the following: 

a.​ Click on File and select Preferences.  

b.​ Navigate to the Configuration category and click on the drop down arrow. 

c.​ Select Truck User Fields and click on the three dots to the right. 

d.​ Click on Add and type in the STRING data type named TruckType.  

e.​ Click on Close and ensure the Save Preferences on Close option is checked.  

●​ The file must be closed to save any changes. 
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Figure 139 - TruckUserFieldType Collection Editor 

2.​ Include the City name 

3.​ Navigate to the Analysis menu and select Cross Dock vs DC.  

 
Figure 140 -  Analysis Menu 

4.​ Click on each button to add the Stop and Truck files (Distance file is optional). 

5.​ Pick the primary volume for the algorithm to use from the drop down. 

 

Figure 141 - Depot Selection Window  

6.​ Click on OK to launch the algorithm. 
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7.​ View the populated map on the Map tab to see the Stop assignments. 

●​ The DC and each warehouse are represented by a diamond shape on the map.  

●​ Customers are identified by a color-coded dot and zones are outlined with a polygon. 

○​ Note the DC/ warehouse and its coordinating color for future steps. 

○​ Colors are populated in the Color column of the Stop file for reference. 

●​ Boundaries shown on the Map can be saved or edited using the standard Drawing Tools.  

8.​ Determine if Routes and sequences are required.  

If you wish to Then 

Route individually as 
separate projects 

a.​ Split up the Stop and Truck files - one for each zone. 
b.​ Route and sequence each individual zone in DirectRoute.  

Route all together in 
one solution 

Convert the color that was assigned (Step 6) to an EqCode.  
a.​ Find the populated Colors column in the Stop file. 
b.​ Scroll to the EQCode column and enter the DC/ warehouse that identifies 

with that color. 
●​ E.g., Dallas is assigned the color red. Each red Stop must be 

EQCoded with @Dallas.  
c.​ Ensure the SpEq column in the Truck file matches the EQCode entries in 

the Stop file. 

9.​ Run the problem in DirectRoute. 

8.6.2 Cross Dock Statistics 

1.​ Navigate to the Analysis Menu and click on Show Cross Dock Statistics to view the estimated 
Linehauls required from the DC to each Cross-Dock. 

●​ The algorithm must complete its evaluation before statistics are available. 

 

Figure 142 - Cross Doc Statistics 
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9.​ Advanced Routing 
Once you have mastered the initial building of routes and understand how the software reads your data to 
create the optimal solutions, you’re ready to progress to more advanced methods of routing, as well as 
using other options to optimize the routing solution even further. Some of these methods may include: 

•​ Special Equipment Codes  

•​ Consolidating stops 

•​ Re-dispatching trucks 

•​ Splitting stops 

•​ Routing with Lasso Tool 
•​ Creating inbound routes 

•​ Creating relay routes 

•​ Tanker routing (Tanker Algorithm) 
•​ Using External Utilities 

 

9.1.​ Special Equipment Codes 
Special equipment codes provide a means to inform DirectRoute to load a stop on a vehicle. If you are 
routing using a fleet with various special equipment or your customers require special equipment for 
delivery, there may be a need to use special equipment codes.  
 
Below are seven special equipment codes that can be used to assist with specific routing scenarios, 
including:  

•​ Equipment Codes (EqCode)  
•​ Back Haul Codes (BH) 
•​ Priority Codes 

•​ Sequence Codes (Seq Code)  
•​ Sequence Preference Codes (SpEq Code) 
•​ Territory Codes (Terr Code) 
•​ Exclusion Codes (EX Code) 
•​ Origin-Destination Pairs (OD Pairs)  

 

Type Format Length Req’d Truck File 

Equipment Alphanumeric Any Yes 

Backhaul BH 2 characters No 

Priority !1- to !9 2 characters No 

Sequence 00 to 99 2 characters No 
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Sequence Preference 1.01 or 25.01 4-6 characters No 

Territory @Alphanumeric Any Yes 

Exclusion ^Alphanumeric Any No 

Inclusion &Alphanumeric Any No 

OD Pair #AA1/#AA2 to #ZZ1/#ZZ2 4 characters No 

 
The following section provides descriptions and uses for each of these special codes. 
 

9.1.1.​ Equipment Codes (Eq) 
EqCodes are alphanumeric, one to three characters, and user defined; the user determines what 
characters/numbers will be used to define any requirements that exist. These codes are entered in the 
EqCode column in the Stop File to identify the specific requirement for that stop. Any number of codes 
can be used together per stop and are separated by a dash between each. 
 

Example: Sample EqCodes: LG = Lift gate, FB = Flatbed, X3 = 53ft Truck; two or more used = X3-LG-FB 

 
When using an EqCode, one or more trucks in the Truck File must be designated with the same code in 
the SpEq field to identify it as compatible to load/deliver any stop with this code designation. As many 
codes as necessary can be added to any stop or truck; use a dash between each code to separate them 
(ex. X3-LG-FB).  

•​ A stop that is coded in this manner can only be loaded on a truck designated with all three of 
these codes in the SpEq field in the Truck File.   

 
It’s important to remember that the use of SpEq codes on a truck does not preclude the truck from loading 
or servicing a stop without these codes, but simply identifies the truck as being able to meet the special 
requirements of some stops.  

Example: Figure 125 indicates which trucks can service which stops. 

 

 
Figure 143 – SpEq Codes 

 

Note: A truck without a SpEq Code can service any stop without an EqCode, but a stop with an EqCode 
can only be serviced by a truck with the matching SpEq code. Likewise, a stop without an EqCode can be 
serviced by any truck, with or without any SpEq Code designation. 
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Tip: Place vehicles with Special Equipment Codes at the bottom of the Truck File. During the routing 
process, DirectRoute starts with the first available truck in the Truck File to start loading stops. Stops with 
no Equipment Codes may go on any vehicle. However, stops with Equipment Codes may only go on 
those vehicles coded to accept them. By placing vehicles with Equipment Codes on bottom of the Truck 
File, this ensures that the stops with codes will have vehicles available for loading. 

 

9.1.2.​ Back Hauls (BH) 
A Back Haul is a stop to be picked up (versus delivered) after the truck has been unloaded, and taken 
back to the terminal; it requires that the truck be empty before it arrives at the stop to be picked up. Back 
Hauls can be identified in the Stop File using an EqCode of BH. During the routing process, DirectRoute 
will place these stops at the end of the Route after all other stops have been delivered.  
  

Note: There does not have to be a corresponding BH code in the Truck File. Stops coded as Back Hauls 
can be loaded on any truck unless the stop has additional constraints, such as size restrictions or other 
EqCodes. 

 

Tip: When shown in the Route Book, Back Hauls are shown with a negative capacity. A column heading 
for BH Totals may be added to the Header Report in the Route Book. 

 
Back Hauls should not be confused with a regular pickup for delivery to the Depot. This type of pick up 
could be at any location between two delivery stops, anywhere on the route. The BH code should not be 
used for this type of stop. For less than truckloads, set the stop quantity to 30,000 and DirectRoute will 
include it in the routing process. 
 

9.1.3.​ Priority Codes 

Priority Codes allow the user to change the order in which stops are loaded in the construction phase of 
route building. Priority Codes are identified using the exclamation symbol (!), followed by a sequence 
number between 1 and 9, entered in the EqCode field in the Stop File.  
 
Typically, DirectRoute will load the farthest un-routed stop on an empty vehicle and proceed to load 
additional stops within the same vicinity on the vehicle. Using Priority Codes will change this behavior, 
giving priority loading, or preference, to stops with a Priority Code, over non-prioritized stops.  
 
A Priority Code does not ensure that a stop will be the first stop on a route, only that the stop gets loaded 
before all others without a Priority Code (to indicate priority delivery, see Sequence Codes. When 
assigning the sequence number, 1 is used to indicate the highest priority and 9 the lowest.  

Example: Priority Code!1 indicates a higher priority than !3. 

Note: There doesn’t have to be a corresponding Priority Code in the Truck File. Priority stops can be 
loaded on any truck unless the stop has additional constraints, such as size restrictions or additional 
EqCodes. 
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9.1.4.​ Sequence Codes 
When stops require priority delivery over other stops, the use of a Sequence Codes (Seq Code) will force 
DirectRoute to build the route using the delivery sequence input for each stop.  
 
A Seq Code is a 2-digit number (01 thru 99) used in the EqCode field in the Stop File, to indicate delivery 
order. Stops with the lowest sequence number (00, 01, 02, etc.) will be loaded before stops with a higher 
number (10, 23, 99, etc.). Any numerical code (without alpha characters) entered in the EqCode field is 
assumed to be a Seq Code. 
 
When using Seq Codes, all of the stops must have a Seq Code; blank cells in the EqCode field will be 
given a null value (00), which will force a first delivery, while a value of 99 will force a last stop, or delivery. 
When combining Seq Codes with another EqCode, separate the two with a dash.  
 

Example: A 2nd delivery stop (Seq Code 02) requires a lift gate (EqCode LG). EqCode field = LG-02.  

 
The following table represents coded stops in the Stop File. Based on the EqCode field input, can you 
determine when/how these stops should be loaded/delivered? 

 
Figure 144 – EQ Codes 
 

•​ Stops A and G must be delivered before B and E (Seq 01 takes precedence over 02 and 03).  

•​ Stops C, D, and F have no Seq Code assigned, so the software will assign a null value (00). 
Since 00 indicates the highest precedence, Stops C, D, and F will be forced to deliver first, 
ahead of stops A, G, B and E, even though they were designated for 1st, 2nd, and 3rd delivery 
by the Seq Codes 01, 02, and 03. 

•​ To avoid this error, Stops C, D, and F should be assigned a numerical value that will ensure 
delivery sequence in the proper order.  

•​ Remember, the use of any Seq Code in the Stop File will require that ALL stops be assigned 
a sequence code.  

 

9.1.5.​ Sequence Preference Code 
A Sequence Preference Code (SpEq Code) is a dollar amount assigned to be multiplied/added to any 
stop in which delivery preference is requested. The dollar amount is placed/used in the EqCode field, 
adjacent to any other special code, in the same way that any other special code is used. 

Example: $3.25 is assigned for a stop in which preference is required. A stop already assigned an 
EqCode of RF and requires Seq preference would show the following in the EqCode field: RF-3.25. 
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When DirectRoute builds and optimizes routes, it will calculate a cost for the route (ref. cost fields in the 
Truck File). If SpEq Codes are used in the Stop File, the system will add an additional cost to the routes, 
equal to the assigned value for the preference code multiplied by the stop Seq Code number, minus 1. 

Example: If the SpEq Code is 3.25, and a stop’s Seq Code is 5, then the added cost to the route would be 
3.25 x (5-1), or $13.00. 

 
The earlier in the route the stop is sequenced, the lower the calculated cost; the later in the route, the 
higher the calculated cost will be. As a result, DirectRoute will attempt to reposition the stop to the first or 
earliest position on the route. Additionally, it is possible DirectRoute will be able to re-sequence the route 
without increasing mileage. 

Note: It is important to always test values to ensure they do not have an adverse effect on operations.  

 

9.1.6.​ Territory Codes 
Territory Codes, used in both the Stop and Truck File in the EqCode and SpEq fields, will force routes to 
remain within a certain area. Territory Codes are identified by using the symbol @ with two alphanumeric 
characters (ex. @A2).  
 
Territories can be as small as one truck, or have multiple routes assigned. If drivers are assigned to a 
specified territory and their routes should not cross territory lines, then Territory Codes could be used in 
the Truck File to restrict which stops (Territories) can be loaded on the truck.  
 
The main difference between a Territory Code and a normal EqCode is that the codes on a truck must be 
a subset of the codes on a stop, whereas with normal EqCodes, the stop codes must be a subset of the 
codes on the truck. 
  
In the table below, Customer X can only be serviced by drivers assigned to Territories 1, 2, and 3 (@1, 
@2, @3), but not by the driver assigned to Territory 4 (@4). 
 

 
Figure 145 – Territory Codes 

Note: Any truck can service a stop without a Territory Code. In most cases, if Territory Codes are used, 
they are placed on all stops and all trucks. 

 

9.1.7.​ Exclusion Codes 
Exclusion Codes (Ex Code) are used to specify that two or more stops cannot be loaded on the same 
vehicle. These codes are identified by using the symbol ^ with two alphanumeric characters (ex. ^A2) in 
the EqCode field of the Stop File. Stops with the same Ex Code will not be loaded on the same vehicle. 
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NOTE: Exclusion Codes are “hard” rules, meaning the Load algorithm must always exclude stops. The 
system would leave a stop unloaded versus inserting it onto a route where another stop exists with the 
same Exclusion Code. 

EXAMPLE: A beverage distributor delivers to customers who may receive as many as three deliveries per 
week. The Stop File used represents deliveries for a typical week. Each stop in the file represents one 
delivery, so for each customer receiving two, or three deliveries in the week, there are two, or three 
records in the Stop File. To ensure these deliveries are not all loaded on the same vehicle to deliver all on 
the same day/time, enter an EX Code on each record, to prevent it from loading with the others on the 
same vehicle. 

 
Stops coded with an Exclusion Code can be loaded on any truck unless the stop has additional 
constraints such as size restrictions or additional Equipment Codes. There does not have to be a 
corresponding Exclusion Code in the Truck File. 
 

9.1.8.​ Inclusion Codes 
Inclusion Codes are used if multiple orders are being delivered to the same area to ensure they are 
placed on the truck which regularly runs the route in question. These codes are identified using the 
ampersand symbol (&) in the Equipment Code field of the Stop File. 

NOTE: Inclusion Codes are "soft" rules, meaning if the Load algorithm runs into another hard rule such as 
MaxWorkTm, Capacity, or another EQCode, it has the ability to break up stops with the same Inclusion 
Code and will place them on another route. 

EXAMPLE: A clothing distributor delivers orders to the same outlet mall and wants to ensure all the 
deliveries to that geographic area are on the same truck. An Equipment Code of &OutletMall ensures all 
these deliveries will be placed onto the same route. 

Stops coded with an Inclusion Code can be loaded on any truck unless the stop has additional constraints 
such as size restrictions or additional EqCodes. There does not have to be a corresponding Inclusion 
Code in the Truck File. 
 

9.1.9.​ Origin-Destination Pairs 
Origin-Destination Pairs (OD Pairs) can be used to force DirectRoute to load a pair of stops on the same 
route, in proper order, as an exception to standard Depot-to-Stop routing.  

TIP: For best performance of the software, OD Pairs should account for less than 20% of the total Stops 
in one routing solution.  

 
OD Pairs include both a pickup and a drop off. The paired stops are identified by using the # symbol with 
a two-digit alphanumeric code and a sequence number, ex. #AA1 and #AA2.  

•​ The lower sequence number in the pair (#AA1) represents the Origin stop, while the higher 
sequenced number (#AA2) represents the Destination stop.  

•​ OD Pairs must be used as a pair; if one stop lists an OD Pairs code, there must be another 
stop at some point in the route with a matching code.  

©2026 Trimble Maps​ 162​ ​  Mar -26 



DirectRoute User Guide​ ​ 26.1 

 
How it works: 

•​ DirectRoute determines the first stop on a route during the construction phase of load building 
and looks for any stops with OD Pair codes.  

•​ If found, the stop coded with the lowest number is loaded first. 
 

Example 1: #AA1 would load before #AA2, as the number 1 is lower than number 2. 
DirectRoute then checks the capacity of the vehicle against the volume to be picked up, ensuring there is 
enough space on the vehicle when it leaves the terminal to pick up the Origin Stop.  

Example 2: #AA1 and #AA2 are assigned for pickup and delivery. 
Vehicle capacity is set at 17,000 pounds; 14,000 pounds are loaded at the terminal for various stops on 
the Route, and an additional 2,200 pounds must be picked up at another location before all deliveries can 
be made 

 
This would be a valid use of OD Pairs. The stop with the matching OD Pairs code need only be loaded 
after the pick. The remainder of the route is built in the usual manner, with appropriate consideration given 
to other equipment or sequence codes.  

Note: The first Stop of any OD pair in a route will always display itself in the Route Book as a negative 
number, representing the Stop as a pickup. 

 

9.2.​ Consolidating Stops 
Options exist in Preferences > Routing > Consolidate Settings to enable consolidation of stops. These 
settings are validated when they are updated.  
 
Several options exist to consolidate orders, but only one option may be chosen:  

•​ Consolidate by ID1  

•​ Consolidate by ID2 

•​ Consolidate by Address 

•​ Consolidate by Fixed Times 

•​ Consolidate on Initialize 

Example: Two orders, a Deli order, and a Hardware order, both with unique and separate order numbers, 
are to be delivered to the same Super Store location. If a consolidation option is not chosen, DirectRoute 
will consider these two orders as separate stops, and would appear in the Route Book as Rt 3/Stop 1 and 
Rt 3/Stop 2. However, if you tell DirectRoute to consolidate orders by address, the Route Book result 
would show both orders as Rt 3/Stop 1. 

 
For the consolidate function to work properly, additional conditions must also exist. To consolidate by 
address or customer, each record must contain the following: 

•​ Identical Time Windows. 

•​ Identical EqCodes. 

•​ Identical Size Restrictions. 
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•​ Lat/Long must be within three decimal places. 

When one or more stops have been consolidated, they will appear as one stop on a route, designated 
with a + symbol, left of the sequence number.  

 
Figure 146 – Consolidated Stop 

 
•​ Select the + symbol to explode (expand) the stop detail. 

 
Figure 147 – Unconsolidated Stop 

 
•​ To return the view to Consolidated, select the dash (–) symbol. 

 

9.2.1.​ Consolidate by ID1/ID2 
ID1 is reserved for a unique identifier for the stop record (account number). If this option is set to TRUE, 
DirectRoute will consolidate all records with the same account number (ID1) into one stop record. This 
option is useful if you have several orders for the same customer.  

•​ ID1 will be displayed as the alias if set in File > Preferences > Configuration.  

•​ If the ID1 field Account#, this option will read Consolidate by Account#. 

•​ To consolidate by ID2, the same rules apply. 

Note: An error message will be generated if Consolidate by ID2 is set to TRUE and both Consolidate by 
ID1 & Consolidate by Address is set to FALSE. This setting must be corrected to save/close the dialog 
box; or select Cancel to exit without saving the erroneous setting changes. 

 

9.2.2.​ Consolidate by Address 
If this option is set to TRUE, DirectRoute will combine records that have identical addresses (Address1 
fields match). This option is useful if you have several orders to be delivered to the same address, though 
the account numbers may be different.  
 
Consolidate (Sum) Fixed times–If this option is set to TRUE, the fixed time for the consolidated stop will 
be equal to the sum of the fixed times for all the orders that are consolidated into one record. If it is 
unchecked, the fixed time will be equal to the fixed time of the first order in the consolidated group. 
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Consolidate on Initialize–If this option is set to TRUE, DirectRoute will consolidate fixed routes based on 
ID1, ID2, or Address, whichever option is set to TRUE, during the route building process if Initialize 
Routes is selected. 
 

9.3.​ Redispatch 
Redispatch is used in local delivery situations when the time to deliver a route is short in comparison with 
the maximum work time set for the truck. The short delivery time allows the truck to be sent out on 
multiple route legs during a day.  
 
Redispatch is controlled in the Truck File, by the Redispatch column. 

•​ If set to TRUE, the truck is available for Re-dispatch. 

Note: This field will be ignored if the Oneway column is also set to TRUE. 

 

Example: A distributor may deliver to customers in full truckload quantities. This may only require a 
couple of hours which would allow the driver to return to the depot, reload, and deliver another stop. This 
process would be repeated until the truck was out of work time. 

 
Redispatch Minimum Time 
This indicates the minimum amount of work time remaining (in hours) before considering Redispatching. 
 

Example: If the max work time is set to 10 hours and the minimum time is set to 2 hours, Redispatching 
will cease if the route has already run more than 8 hours (10-2). If minimum time is set to zero, it is 
assumed that another driver will be taking the next leg of a route and work time statistics are reset to 
zero. 

 
Redispatch Turnaround Time 
Turnaround time is the amount of time it takes to reload the truck after it has returned to the depot (in 
minutes). With the Redispatch feature, all dialogs that require a route number (Modify > Move, Modify > 
Delete) also require a leg number. This information is entered into the route field, separated by a comma.  
 

Example: 1, 2 would indicate Route 1, Leg 2. If the leg number is omitted, the system assumes it is Leg 1. 

 

9.4.​ Splitting Stops 
Split Stops allows a user to define where, and by how much, a stop is split after routes have been built, 
based upon capacities that have been used in the Stop and Truck Files. 

•​ Open the Route Book. 

•​ Select the route containing the stop to split. 

•​ Select the stop to highlight it. 

•​ Right click on the stop and select Split Stop. 
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o​ Select Split by Percentage to split by a percentage amount and enter the amount in 

the box to the right.  

o​ Select Split by Number to split by a number (set in the Stop File Field Split Size).  

•​ Select OK. 

Tip: Stops must be Unconsolidated to split. 

 

 
Figure 148 – Split Stops within Route Book 

 
The split will create two stops, each with the selected split quantities. Each stop may be treated 
independent of each other; they can be moved to another route, unloaded, or any other action that might 
be necessary. 
 

9.4.1.​ Dynamic Splitting 
Dynamic splitting is intended to be used in routes that have low stop counts (typically 2 to 4 stops per 
route) and where the vehicle capacity is the primary constraint on the routing problem. For example, 
assume a truck has a capacity of 100 units and you have 5 stops that have a quantity of 40 units each. If 
dynamic splitting is not allowed this would produce three routes (two routes with two stops of 40 and one 
route with one stop of 40). If dynamic splitting is turned on, the system could load the stops on two routes 
by splitting one of the stops into two 20 unit stops and placing each of those stops on a route with two 40 
unit stops. 
 
Dynamic splitting parameters are selected and set in Preferences > Routing > Dynamic Splitting, before 
route building is initiated.  
 
There are several factors used to determine how dynamic splitting is executed. For example, reference 
the field in the Stop File called MaxSplits. If this field is set to ‘1’ or higher, the stop can be considered for 
dynamic splitting, otherwise it will not be considered. Each stop will contain at least one order, and each 
order will contain at least one line item. If Split Orders is set to TRUE, the system will evaluate pulling 
some of the line items off an order to make a split; otherwise, it will look at splitting full orders off the stop. 
Listed below are the parameters that dictate how dynamic order splitting is executed (Preferences > 
Routing > Dynamic Splitting). 

•​ Split stops while loading–Dynamic splitting option is available if set to TRUE. If this 
parameter is set to FALSE, the remaining parameters under the dynamic splitting section are 
inconsequential.  
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•​ Split Orders–If TRUE the system will consider splitting an order by placing some of the line 

items on one stop and placing the remaining line items for the order on the other stop. If this 
parameter is set to FALSE, the system will only split stops by placing full orders on the stops 
created by the split.  

•​ Split Line Items–If TRUE the system will consider splitting the stop at the line item level. This 
option is only valid for stops that contain only one order and one line item on the order.  

•​ Splits-Max splits per stop–Indicates the maximum number of times a stop can be split. This 
is typically 1 or 2 times. This value is only used if there is no entry in the Stop File for 
MaxSplits.  

•​ Splits-Min split size–The minimum size for a split order (based on quantity 1 field). When an 
order is split into two stops, each stop must have at least the min split size. For example, if 
the min split size is 2,000 and a stop has 10,000 units, possible splits could be: 2,000 and 
8,000; 4,000 and 6,000; 5,000 and 5,000.  

Example: You could not have a split of 1,000 and 9,000 since one of the orders would be less than 2,000. 
This also places a limit on the size of an order that can be split. For example, if you had an order of 3,500, 
it could not be split since there is no way to split the order where both stops contain at least 2,000 units.  

 

•​ Splits-Truck Full–This parameter determines if the system will try to split a stop based on 
the user’s definition of what a full truck is. Let us take an example where Truck Full is set to 
80%. The system will load stops on a route until it runs out of capacity. At that point, we will 
check the capacity used by the route, if it is less than 80% it will try to find a stop to place on 
the route by splitting it. It should be noted that Min split size and the Truck Full parameter 
have an influence on each other. For example, let assume you have vehicles that have a 
capacity for 20 pallets, and you set the Truck Full to 90% and min split size to 4. If a route 
contains 17 pallets, it will be at 85% capacity and will look at splitting a stop to fill the route. 
But because min split size is set to four, it can’t fill the route any further because a 4-pallet 
stop would exceed the capacity of the vehicle.  

•​ Splits-Evaluate Split Options–Setting this parameter to TRUE only comes into play if Split 
Orders is set to TRUE. When the system evaluates splitting a stop it will first attempt to split 
the stop by full order. If this is successful, it will not evaluate the possibility of filling the vehicle 
further by looking at splitting the order if this parameter is set to FALSE. If it is set to TRUE, it 
will look at splitting orders then select the option which utilized the most capacity of the 
vehicle.  

 

9.4.2.​ Stops That Should Not Be Split 
For stops that should NOT be split dynamically by DirectRoute during the loading phase of Route 
building, use the Stop User Field in the Stop File to identify them. 

•​ When used with Dynamic Splitting, orders/line items that DO have a value of TRUE, will not 
be split.  

•​ When used with Static Splitting, orders/line items that DO NOT have a value of TRUE, will be 
split first if the order/line item quantity is over the set Static Split size (Preferences > Routing 
> Static Splitting > Split Size). 
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Figure 149 – DoNotSplit 

•​ Use the Add button to add EqCodes, and the Remove button to remove codes from the list. 

•​ Click the Add button and then click the Stop User Field code box and type in the EqCode. 

•​ Repeat to add each subsequent EqCode. 

•​ To remove an EqCode, click the EqCode to select it, and then click the Remove button. 

•​ When all edits have been completed, click the Close button. 

 

9.5.​ Using the Lasso Tool 
The Lasso Tool enables the selection of a group of stops (records) from the map. The stops can be 
loaded or unloaded stops, and can be used to manually build new routes, moved to other routes, or 
loaded/unloaded to and from routes, all without leaving the map view.  
 
To access the Lasso Tool option while in the routing mode, select the Lasso icon from the tool bar, or use 
the menu (Modify > Lasso) to select one of the actions mentioned above that you want to complete once 
the stops have been selected on the map.  
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        Figure 150 – Lasso Tool Options 
 

•​ Show Legacy Window–When the Lasso tool is used to select stops on the map, the 
Lassoed Stops info box will open, enabling selection of an action to perform (load stops, 
delete stops, etc.) 

 

 
Figure 151 – Lassoed Stops Info Box 

 
•​ Show Selective Routing–When the Lasso tool is used to select stops on the map, the 

Selective Routing info box will be opened and can be used to assign the selected stops 
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Figure 152 – Selective Routing Info Box 

  
•​ Filter in Stops Grid–When the Lasso tool is used to select stops on the map, the Stops Grid 

(Stop File.xls) will update to show only the stops selected, instead of all stops in the Stop File. 
 
See Using the Lasso to Select Stops for additional information. 
 

9.6.​ Build Manual Routes on the Map 
This action is completed in the same way as using the Manual Route Build Tool, except that the Lasso 
Tool is chosen instead. 
 
To start, ensure the Stop and Truck Files are updated as needed and saved in the DirectRoute Data 
Folder.  

•​ From the DirectRoute menu, select File > New Route. 

•​ Select the Stop File, Truck File, and Distance File (if used) to use in the routing scenario. 

•​ Select No Initialization and select the Dispatch Date (first day vehicles should depart). 

•​ Select the OK button to launch the build process. 

 

When the build process has completed, select the Map tab from the top of the screen to view the stops on 
the map.  

•​ From the toolbar, select the Lasso Tool; the mouse cursor will change to resemble a pen. 

•​ Left click and hold the mouse, and drag the pen to draw a perimeter around the group of 
stops to select them, and then release the mouse. 

 

An info box will open to display the number of stops selected and the volume totals of the selected stops. 
These stops can now be loaded to a route. 
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Figure 153 – Lasso Build Routes 

 

•​ Type the Route# in the Load Stops to Route box. 

•​ Select the OK button to complete. 

•​ If the selected action will violate any constraints, a warning notice will be received. 

 

9.7.​ Move, Delete, or Add Stops 
The Lasso Tool enables the selection of a group of stops (records) at one time, while viewing the stops on 
the map. Various actions can be applied to the selected records as a group. Some of these actions 
include adding stops to routes, deleting stops from routes, redistributing territories (ref. TerritoryPro: 
Redistribute Territories), or reassign resources (ref. ResourcePro: Reassign Resources).  
 

While in the routing mode (Route File open), select the Lasso Tool  from the toolbar. 
•​ The mouse cursor will change to resemble a pen; left click and hold the mouse, and drag the 

pen to draw a perimeter around the group of stops to select them, then release the mouse. 
 

 
      Figure 154 – Lasso Function 

 
An info box will open to display the number of stops selected and the volume totals of the selected stops. 
These stops can now be loaded to a route, reloaded to another route, or deleted from a route. 

•​ Select the action desired. 
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•​ Select OK to complete the action. 

•​ If the selected action will violate any constraints, a warning notice will be received. 

 
See Using the Lasso to Select Stops for additional information. 
 

9.8.​ Inbound Routes 
Inbound routes are routes that begin at the furthest stop and route back to the depot. The distance from 
the depot to the first stop (farthest stop) is not calculated. This mode of routing is an alternative to 
inverting a completed routing project.  
 
The DirectRoute Algorithm will calculate and build Inbound Routes when the INBOUND option is selected 
in Routing Preferences. 

•​ From the main menu, select Preferences > Routing > Algorithm Settings, and select 
INBOUND from the drop-down menu. 

•​ Ensure the Truck File column One Way remains set to False.  
 
When INBOUND is selected, all routes will be calculated as Inbound routes; standard routes cannot be 
completed within the same stop file. To return to building regular two-way routes, edit the Routing 
Preferences to return the Algorithm Setting to Regular. 
 

9.9.​ Routing Dense Stops 
When routing dense stops, DirectRoute may be slower as it searches for the next stop to load on a route.  
 
During the routing process, as each stop is assigned a stop sequence, DirectRoute then looks through 
each remaining stop in the Stop File to find and assign the next stop/stop sequence. This works well 
when stops are generally a few miles from each other. However, in metropolitan areas or areas with a 
high concentration of stops close to each other (dense stops), this can slow the routing process 
considerably.  
  
To alleviate this problem, an entry can be made in Routing Preferences to limit the number of stops that 
DirectRoute attempts to sequence to the previous stop, to speed up the routing sequence. When used, 
DirectRoute will only look to the next (# entered) closest stops from the previous stop. This will prevent 
the routing sequence from reviewing all available stops for loading while routing very dense stops. 

•​ From the main menu, select Preferences > Routing > Algorithm Settings. 
•​ Scroll down to the last item, Max Closest Stops, and enter a number to limit the number of 

stops, closest to the current stop, that DirectRoute should look at before assigning the next 
sequence number. 

 

9.10.​ Relay Routes 
The Cross-Dock function was used to assign routes to an alternate dock, yard, or domicile. This 
functionality has been deprecated and replaced with Relay Routes. The Relay Route function (in the 
Route Book) allows the shipper to simulate warehouses where there may only be drop/hook trailer yards. 
The process creates a line-haul route from the warehouse to the selected drop/hook yard (remote 
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domicile). Routes are run as a multi-depot project, with the remote domicile being the actual warehouse. 
The routes will be routed from the remote domicile to the delivery point.  
 
Relay Settings 
It is recommended that new entries in the Truck File be created to be used specifically for relay routes. 
For each location you will be creating the relay for, there should be an entry in the Truck File. Each truck 
should also have the City column populated. It is also recommended that the names of the trucks be such 
that they are noticeably relay trucks only.  
 
Ensure the values for Edate/Ldate/EarlyStart/LateFinish allow for enough time for the relay to be 
completed. When the new trucks have been created, the Truck File should be geocoded. 
 

9.10.1.​ Creating a Relay Route 
Create routes using the Stop File and Relay Truck File. When the routing solution has been completed, 
open the Route Book to view. 

•​ Select the route with the stop that will be relayed to another terminal. 
•​ Select the stop to select it. 
•​ Right click once and select Relay Route from the drop-down menu. 
•​ Select Relay by Destination, or Relay by Truck. 

 

 
Figure 155 – Relay Routes 

9.10.2.​ Relay by Destination 
Relay by destination creates a line haul from the remote domicile to the main depot. The main depot is 
listed as the destination. 

•​ Right click anywhere in the Route Book to open the Modify menu. 

•​ Select Relay by Destination. 

•​ Pick the relay point from Relay Point 1; default is the City location of the first truck in the 
Truck File that is different from the current truck location. 

•​ Edit From Route No/To Route No, if necessary; default is the current Route No. 

•​ Edit the Transfer Time at Pickup/Drop-off  if necessary; default is 15 minutes. 

•​ Edit the Maximum Speed if necessary; default is 65 MPH. 
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•​ Select OK. 

 
 Figure 156 – Relay by Destination 

 
DirectRoute will create a new relay route. The route number created will correspond to the truck’s position 
in the Truck File (ex. if the eighth truck listed in the Truck File is used, Route 8 will be created). 
 

9.10.3.​ Relay by Truck 
Relay by Truck creates a line haul originating from a location other than the remote domicile, or depot. 
The line haul originates from the truck dispatch location. 

•​ Pick your Relay Truck from the dropdown menu (Relay Truck); default is the first available 
truck in the Truck File. 

•​ Edit the From Route/To Route No if necessary; default is the current Route#. 

•​ Edit the Transfer Time at Pickup/Drop-off if necessary; default is 15 minutes. 

•​ Edit the Maximum Speed if necessary; default is 65 MPH. 

•​ Select OK. 
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   Figure 151 – Relay by Truck 

 
DirectRoute will create a new relay route. The route number created will correspond to the truck’s position 
in the Truck File (ex. if the eighth truck listed in the Truck File is used, Route 8 will be created). 
 

9.11.​ Tanker Assignments 
The Tanker Algorithm and assignment logic is intended to assist with optimized trailer compartment 
utilization when multiple products in various order quantities have to be planned on compartmentalized 
trucks together in a pickup or delivery route. The tanker logic considers, in part, volume and weight of 
loaded totes, tanks, and spaces, and is only applicable if the tanker algorithm is enabled.  
 
The steps to building routes with the Tanker Algorithm are the same steps normally used to build routes in 
DirectRoute, regardless of the algorithm used. The differences lie in the Tanker Algorithm settings, and 
the use of two additional files: Tote File, and Product Ratio File. Both files are saved in an .xls 
spreadsheet format, in the DirectRoute/Data Folder, with the Stop and Truck Files. 
 

9.11.1.​  Tanker Algorithm Settings 
The Tanker Algorithm settings identify the options that should be updated to enable the use of the Tanker 
Algorithm.  
 
To complete the updates, select File > Preferences > Tanker from the main menu. 
 

TANKER LOAD BUILDING FOR COMPARTMENTS EXPLANATION 
Weight  Choose from Configuration/Volume 

Fields 
Volume  Choose from Configuration/Volume 

Fields 
Count  Choose from Configuration/Volume 

Fields 
Tote File Name C:\Program 

Files\Appian\DirectRoute\Data\Tote.xls. File 
Name and path of the Tote File, 
typically found in the DirectRoute 
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TANKER LOAD BUILDING FOR COMPARTMENTS EXPLANATION 

should contain columns: Totaled, Gallons, 
Weight, Cube, Pallets, and Available 

Data Folder with the Stop and 
Truck Files. 

Product Ratio File 
Name 

C:\Program 
Files\Appian\DirectRoute\Data\Ratio.xls. File 
should contain columns: ID, Product Code, 
Gallons, and quantity fields 

Name and path of the Ratio File, 
typically found in the DirectRoute 
Data Folder 

Use Tanker 
Algorithm For 
Product Assignment 

TRUE/FALSE Default is FALSE; if set to TRUE, 
will use the Tanker Algorithm for 
product assignment 

Max Number of 
Totes Per Order 

 Max number of totes allowed on 
each order 

Split Orders to Totes TRUE/FALSE Set to TRUE, will split orders down 
to tote level 

Figure 152 – Tanker Algorithm Settings Table 
 
In addition, the Configuration and Default options need to be updated. 

•​ Select File > Preferences > Configuration > Volumes. 

•​ Add quantity field Gallons as the first quantity type. 

•​ Add quantity field Tank; as many (number/name of Tanks) as necessary. 

•​ Add quantity field Space; as many (number/name of Spaces) as necessary. 

•​ Add quantity fields Weight and Volume. 

 
Figure 153 – Tanker Algorithm Volumes 

 

•​ Select File > Preferences > Defaults > Unload Rates. 

•​ Add the Unld Rates for each of the quantity fields used in Volumes. 

•​ Ensure the same Volume Fields for each item/product listed in the Product Ratio File are 
also used in the Stop File. 
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Figure 154 – Tanker Algorithm Unload Rates 
 

 
Figure 155 – Tanker Stop File 
 

9.11.2.​ Product Ratio File 
The Product Ratio File is an .xls spreadsheet that contains the product data (name or number) for items 
loaded in Totes, and the corresponding ratio for each (Gallons to Weight, Cube and Pallet, etc.) should be 
listed. The column headings/fields required in the file are listed below, and once complete, should be 
saved in the same DirectRoute/Data Folder with the Stop and Truck Files. 

•​ Product Code–Code/name assigned to a specific product unit. 

•​ Gallons–The number of gallons in one product unit.  

•​ Weight–The weight of one product unit. 

•​ Cube–The number of cubes in one product unit. 

•​ Pallet–The number of pallets assigned to one product unit. 
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Figure 156 – Product Ratio File 
 

9.11.3.​ Tote File 
The Tote File is an .xls spreadsheet that identifies each Tote in use, and its maximum capacity levels. The 
volume fields listed must be the same as the volume fields used in the Product Ratio File. Once complete, 
the file should be saved in the same DirectRoute/Data Folder with the Stop and Truck Files. 

•​ ToteID–A number ID assigned to a specific tote. 

•​ Gallons–The maximum gallon capacity of the tote. 

•​ Weight–The maximum weight capacity of the tote. 

•​ Cube–The maximum cube capacity of the tote. 

•​ Pallet–The maximum pallet capacity of the tote. 

•​ Available–Availability status of the tote, entered as TRUE or FALSE. 

 
   Figure 157 – Tote File 
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9.11.4.​ Tanker Route Results 
Tanker route results will be returned in the Route Book. Route totals and statistics can be viewed in the 
Summary page and individual route pages, as well as in the Info boxes (Route, Stop, Truck, or Solution. 
In addition, a Tanker Chart is available, presenting a color-coded view of items loaded, including number 
of tanks and totes filled on each route, and remaining capacity levels. The Tanker Chart is opened in a 
separate window by selecting the chart icon in the top right corner of the Route Info box. 
 

 
Figure 158–Tanker Chart Icon 
 

 
Figure 159 – Tanker Chart View 
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9.12.​ External Utilities (Merge Utility) 
External Utilities contains an additional tool, the Merge Utility, that enables the merger of two or more 
Stop Files into one cohesive Stop File, even if all the columns are not the same or do not match. This tool 
can be extremely helpful, especially for those who use any of the additional add-on programs with 
DirectRoute (SchedulePro, TerritoryPro, ResourcePro, etc.).  
 
To use the Merge Utility, the Util.config file (DirectRoute Directory) must be available and configured 
properly. If you do not have this file, or are not able to access it and would like to use this function, contact 
Trimble MAPS Support, support@trimblemaps.com, Phone: (800) 663-0626. 

The External/Merge Utility is accessed by using the  icon on the DirectRoute toolbar. When the 
Utilities box opens, select the Merge Utility. 

 
Figure 160 – External Utilities Menu 

 

Note: The Windows Explorer Utility simply provides a shortcut to the computer systems Explorer Window, 
enabling search/find of files or folders. 

 

9.12.1.​ Using the Merge Utility 
•​ Select Merge Utility from the listing in the Utilities box. 

 

 
Figure 161 – Merge Utility 

 

•​ Select the Select Files button to select both of files (one at a time) to be merged 

•​ The file names will be listed in the white space of the box as they are selected 

•​ If you select the wrong file, select the Clear button to remove it 

•​ Next, select the Select Output File button and assign a name to the new merged file 
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•​ Select the Merge button, and the new file is created 

Note: The Merge Utility will create a new file by copying all the stops from the selected files. The original 
files used to create the merged file will remain intact and unchanged. 

10.​ Drawings and Boundaries 
DirectRoute allows users to add drawings two different ways - draw directly on the map using application 
tools and upload a drawing file. 
 

10.1.​ Draw Directly on a Map 
DirectRoute contains a set of Drawing Tools that enables you to draw your own boundaries directly on the 
map, add borders around a group of stops or routes, and add text boxes or labels to shapes or areas on 
the map.  
 
Drawings and boundaries can be used to define routes or territories, assign vehicles and/or drivers, or 
view statistical analysis for records within or outside the boundary. The map with drawings can be saved, 
printed, reused, and edited. 
 
Drawings can be edited at any time on a new or saved drawing file.  
 
Drawing Tools can be enabled in DirectRoute without any files open, or directly within a Stop or Truck 
File, or a Route File. If you are going to be working with a previously saved Drawing File, open it before 
attempting to activate the tool bar. 
 
The Drawing Tools tool bar contains several line tools, as well as shape tools, shading tools, and color 
options for each. These tools can be used for various effects on the map, as well as within any Route File, 
and all are detailed further in this section. 
 
To activate the toolbar, select Map > Tools > Draw from the menu, or select the Drawing Tools icon from 
the menu .  
 
The gold padlock icon on the screen enables locking Territories on the map, preventing them from moving 
during the planning phase, but still enabling them to be edited. When the mouse hovers over the gold 
padlock, an info box will open and advise whether the current item (s) have been stocked.  
 

 
Figure 162 – Drawing Tools Menu 

 
While the tool bar is activated, items from the DirectRoute menu may not be available. To deactivate the 
tool bar and access the DirectRoute menu or any additional files, select the Drawing Tools icon  from 
the menu.  
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10.2.​ Open a Drawing File 
This option allows users to open a drawing file to enable boundary visualization during the Route building and 
editing process (new for v25.2).  

View a Drawing file: 

1.​ Click on File from the top tool bar and click on Open Drawings. 

2.​ Select your drawing file to superimpose the drawings over the map. 

Clear a Drawing file:  

1.​ Click on Map from the top tool bar then click on Tools.  

2.​ Select Clear Drawings to remove the drawing file from the map.   

 

10.3.​ Text Tool 
The Text Tool  enables placement of a text box on the map, similar to a text box on a presentation. It 
can be used to label territories, areas, or regions. Select and change font, style, size, color, and patterns, 
and choose borders around the text box. 

•​ Select the Text Tool from the tool bar 

•​ In the text dialog box that appears, type the text you want to appear on the map 

•​ Select Draw Borders, to outline the box if desired 

•​ Choose the font type, style, and size 

•​ If you want the size of the text to change with the change in map size (zoom in/out), left click 
on Scalable 

•​ Select the Fixed Size if you want the size to remain the same regardless of the map 
position/size  

 

Figure 163 – Text Tool Dialog Box 

 

•​ When all options have been chosen, select OK 

•​ Position the mouse cursor over location on the map to place the text and left click once, then 
type the text 

•​ To reposition the text, left click and hold the text box and move to desired location; release 
the mouse button to set in place 
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To clear the text box from the map, select Map > Tools > Clear Drawings from the tool bar and left click 
once on the text box. 
 

10.4.​ Line Tools 
Line tools can be used to draw your own boundaries directly on the map, add borders around a group of 
stops or routes, or define routes or territories. 

 
Figure 164 – Line Tools 

After drawing a line, the total distance can be displayed on the map. This can be useful to determine the 
distance between two or more points.  

•​ Select the normal cursor icon (arrowhead) from the tool bar 

•​ Position the mouse pointer over the line and left click (frame handles surround the line that is 
selected) 

•​ The status bar, located in the lower left part of window, will display the total distance of the 
line 

 

10.4.1.​ Polyline Tool 

 The Polyline Tool enables drawing multiple connecting line segments on the map. As each line 
segment is drawn, the status bar shows the length of the current line segment and the total length of the 
polyline. After drawing the line, the total distance of the polyline can be displayed. This tool is also 
especially useful for displaying cumulative distances between areas on the map. 

•​ Select the Polyline Tool from the tool bar. 

•​ Select the map to indicate your start point. 

•​ Move the mouse to the next point and left click; a drawn line will appear. 

•​ Move the mouse to the next point and left click again. 

•​ Continue repeating until your drawing is complete. 

•​ Lines can reconnect at another point in the drawing and/or cross another. 

•​ To end the polyline, press Ctrl+ left click. 

•​ To stop the Polyline Tool and return to the normal cursor, select the arrowhead icon on the 
tool bar. 

 
To clear the drawing and start new, select Map > Tools > Clear Drawings from the menu and select the 
drawn object.  
 

10.4.2.​ Line Tool 

The Line Tool  enables drawing a single line segment on the map. This tool can also be used to 
display the distance between two areas on the map. 
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•​ Select the Line Tool from the tool bar. 
•​ Left click on the map to indicate your start point. 
•​ Left click and hold to move the mouse towards your endpoint; notice the distance is displayed 

in the status bar as you move the line. 
•​ When you reach the point at which you want to end the line, click again. 
•​ To stop the Line Tool, select the normal cursor icon (arrowhead) from the tool bar.  

 
To clear the drawing and start new, select Map > Tools > Clear Drawings from the menu and select the 
drawn object. 
 

10.4.3.​ Arrow Tool 

The Arrow Tool  enables drawing a line with an arrowhead at the end, or drops a triangle on the map 
to mark a spot. The arrow line is useful in pointing to objects or areas on the map. The distance of the 
arrow (line) is also displayed in the status bar. 

•​ Select the Arrow Tool from the tool bar. 

•​ left click on the map to indicate your start point, or drop point. 

•​ If dropping a triangle to mark the spot, left click one more time to set. 

•​ If drawing an arrow line, left click, hold and drag to the end of your line. 

•​ To end the arrow line, click again. 

•​ To stop the Arrow Tool, select the normal cursor icon (arrowhead) from the tool bar. 

 
To clear the drawing and start new, select Map > Tools > Clear Drawings from the menu and left click 
once on the drawn object.  
 

10.5.​ Boundary Tools 
A boundary is a completely enclosed shape. The boundary tools available include a circle, rectangle, and 
a polygon, and displayed with various patterns and colors. Boundaries can be used to: 

•​ Denote a special attribute about an area using colors and patterns. 

•​ Calculate the statistics of records within an area. 

•​ Select records within a boundary for analysis. 

 

 
Figure 165 – Activate Boundary Tools 

 

10.6.​ Polygon 
The Polygon Tool  enables drawing a boundary of any shape on the map. In addition, the polygon can 
be edited and sized by dragging the frame handles on the polygon.  

•​ Select the Polygon Tool from the tool bar 
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•​ left click on the map to indicate your start point 

•​ Move the mouse to the next point and left click; the drawn line will appear 

•​ Move the mouse to the next point and left click again 

•​ Continue repeating until your drawing is complete 

•​ Press Ctrl+ left click to end drawing the lines and your drawn shape will appear on the map 

•​ To add a pattern inside the shape, left click inside the shape once, then left click on the 
chosen pattern 

•​ To add or change background and/or foreground color, left click inside the shape once 

•​ Select a Foreground/Background color using the drop-down arrow to choose 

•​ Select the Color drop down arrow to choose color 

•​ To end the Polygon Tool, select the normal cursor icon (arrowhead) from the tool bar. 

 
To clear the drawing and start new, select Map > Tools > Clear Drawings from the menu and select the 
drawn object. 
 

10.6.1.​ Circle Tool 

The Circle Tool  enables drawing a circle on the map. The circle can be drawn to a specific radius, 
which is displayed, on the status bar at the bottom of the screen. 

•​ Select the Circle Tool from the tool bar. 

•​ left click on the map to indicate your start point. 

•​ left click and hold while moving the mouse outward to expand the size of the circle; release 
when the desired size is achieved. 

•​ To add a pattern inside the shape, left click inside the shape once, then left click on the 
chosen pattern. 

•​ To add or change background and/or foreground color, left click inside the shape once. 

•​ Select a Foreground/Background color using the drop-down arrow to choose. 

•​ Select the color drop down arrow to choose color. 

•​ To adjust the position of the circle, left click, hold and drag to correct position location; release 
the mouse button to set it in place. 

•​ To end the Circle Tool, select the normal cursor icon (arrowhead) from the tool bar.  

 

To clear the drawing and start new, select Map > Tools > Clear Drawings from the menu and select the 
drawn object.  
 
To display the radius of a circle:  

•​ Once a circle is drawn, you can display the radius in the status bar on the bottom left side of 
the map. Select the normal cursor icon (arrowhead) from the tool bar and click once within 
the shape. 
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10.6.2.​ Rectangle Tool 
The Rectangle Tool  enables drawing a rectangle on the map. As the rectangle is drawn, the width and 
length of the boundary is shown on the status bar at the bottom of the screen. These dimensions can also 
be displayed later.  

•​ Select the Rectangle Tool from the tool bar 
•​ Left click on the map to indicate your start point 
•​ Left click and hold while moving the mouse outward to expand the size of the rectangle; 

release when the desired size is achieved 
•​ To add pattern inside a shape, left click inside the shape, then left click on the chosen pattern 
•​ To add/change background and/or foreground color, left click inside the shape once 
•​ Select a Foreground/Background color using the dropdown arrow to choose 
•​ To adjust the position of the rectangle, left click, hold and drag to correct position location, 

then release to set in place 
 
To end the Rectangle Tool, select the normal cursor icon (arrowhead) from the tool bar.  
To clear the drawing and start new, select Map > Tools > Clear Drawings from the menu and select the 
drawn object. 
 
To display the dimensions of a rectangle:  

•​ Once a rectangle has been drawn on the map, you can display the dimensions in the status 
bar on the bottom left side of the map. Select the normal cursor icon (arrowhead) from the 
tool bar and click once within the shape. 

 

10.6.3.​ Lock Tool 
The Lock Tool provides the ability to lock and unlock shapes on the map to prevent them from being 
moved while working with stops on the map. When the mouse hovers over the lock icon on the tool bar, a 
dialog box will open and indicate whether the drawings can be locked or unlocked. The three locking tools 
available are Lock Selected Shape, Lock All Shapes, and Unlock All Shapes. 
 

 
Figure 166 – Territory Lock Tool 

 

10.6.4.​ Hide Labels 
While working in the Drawing File, toggle the Hide Labels icon to show or hide the labels or text boxes 
attached to drawn objects on the map. 
 

10.7.​ Using Boundaries 
Boundaries can be used to analyze the information in a data table and view the results on the map. The 
three main functions used with boundaries include:  

•​ Template Overlay–Denote a special attribute about an area using colors and patterns 
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•​ Statistics Calculation–Calculate the statistics of records within an area 

•​ Build to Value–Select records within a boundary for analysis 

 
To use boundaries for any analytical function, the boundary must first be drawn (Boundary Tools).  
Ensure the file to be analyzed is open as well. 
 

10.7.1.​ Overlay Template 
The Template function enables pasting data into records that exist either inside, or outside of the 
boundary. 
  

Example: The boundary may represent a sales territory. By using the template overlay, you can change 
the symbol of all the customers within that sales territory, and not affect any records outside of that 
territory.  

To select all the records within a boundary:  

•​ Select the Drawing Tools icon from the menu  

•​ Select the Normal Cursor icon (arrowhead) from the tool bar 

•​ Left click within the drawn boundary 

•​ Select Edit > Template from the menu 

 

 
Figure 167 – Template Dialog Box 
 
Select the Template Options to apply. 

•​ Overlay–Selection status refers to records marked as TRUE in the Stop File; to select 
records within the boundary regardless of their selection status, check Ignore Selection 
Status 

•​ While Overlaying–To change the selection status of the chosen records in the Stop File, 
choose Select Records 

•​ Select OK 
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Select the Stop File tab to review the selection status of the records (should now reflect TRUE in the 
column labeled Selected). 

•​ Select the F8 key to display statistical data for the selected records 

 

To unselect and begin a new template overlay, select Edit > Template from the menu. 

•​ Select Selected Records Only 

•​ Select Unselect Records 

•​ Select OK 

 
Repeat the process to select new records for any further analytical review. 
 

10.7.2.​ Statistics Inside a Boundary 
View summary statistics for records inside a selected boundary. 

•​ Open the spreadsheet  

•​ Position the cursor over the drawn boundary and left click once to select it  

•​ Select Edit > Statistics from the menu, or press the F8 key 

 
The Statistics Info box will include two additional columns, In Boundary and Out Boundary, with the 
applicable statistical results displayed in each. 
 
Use the Drawing Tools to define or alter the boundaries, as needed.  
 

10.8.​ Build to Value 
The Build to Value function color-codes locations based upon the geographical area and a volume 
criterion. DirectRoute will search in concentric circles from the starting point and apply a color and symbol 
to locations that fall within the criteria you establish.  
 

The Build to Value function can be used for a variety of applications, including:  

•​ Building a skeletal route based upon area and delivery quantities 

•​ Build a sales territory based upon area and sales quantities 

•​ Site location analysis (which customers can be serviced based upon warehouse capacity) 

 

To use the Build to Value function: 

•​ Review the Stop File and ensure that all stops are of the same symbol, color, and size 

•​ Select the map tab to active the window if not already  

•​ Zoom to the desired geographical area 

•​ Select Map > Tools > Build to Value from the menu 

•​ left click on the map where the geographical center of the territory will be located 
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•​ Select Build by Symbols 

 
Figure 168 – Build to Value Dialog Box 
 

•​ Select the Search button; ensure Symbol, Color, and Size are the same as the current 
selections. 

•​ Select the Replace button; select Symbol, Color, and Size to apply to locations in the new 
territory.  

•​ Select the applicable boundary option: Within, Outside, Ignore. 

•​ Use the Criteria drop-down button to select the column from the Stop File from which to 
choose. 

•​ Select the Max Volume the territory will contain (volume of the criteria chosen). 

•​ Select the Max radius that the search will include. 

•​ Select OK to begin the Build to Value function. 

Note: If the radius field contains a value, DirectRoute will search records in concentric circles until it 
reaches the first of the two value limitations; if the radius field is blank, DirectRoute will continue to search 
records until the maximum volume value is reached, or until boundary limitations are reached. 

 

 
Figure 169 – Build to Value Results 

 
DirectRoute marks all selected records with the color and symbol chosen with the Replace Option.  
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11.​ Exporting Route Info To 
ERP/WMS/OMS 

When a routing solution has been completed, the results can be exported to your ERP/WMS/OMS for 
processing. The primary options used to retrieve this data are: 
 
The primary options used to retrieve this data are: 

•​ Web Services–Automatically pull order and account information from our software 
applications (DRTrack) in real time or in a daily/batch process. 

•​ XML File–A simple, standard text file that contains a specific set of data fields, enables 
sharing pertinent information that multiple interchanges can. 

•​ Upload File (UPL)–An Upload File (UPL) in standard text format, customizable to allow 
selection of desired data fields, while omitting data not needed. (Requires an Upload Format 
File (URP) be created). 

 

11.1.​ Export with Web Services 
Exporting a routing solution from DirectRoute using web services requires the use of DRTrack, our 
web-based GPS tracking program. The info is exported and then uploaded to DRTrack from DirectRoute, 
where DRTrack can automatically send the info via web services to your ERP/WMS/OMS when a request 
is received for the info. The request/response via systems can be scheduled to occur automatically on a 
recurring basis. 
 
Before attempting to export the routing solution, ensure Preferences have been updated to include all 
necessary information. 
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Figure 170 – DRTrack Preference Settings 

 

DRTrack URL–Your DRTrack URL address, to which routes and/or Master Accounts will be uploaded. 

Company Name–Your Company name. 
DRTrack Username–Your DRTrack username. 
DRTrack Password–Your DRTrack password. 
DRTrack Proxy Server–If applicable.  

DRTrack Proxy Port–If applicable. 

DRTrack Proxy Username–If applicable. 

DRTrack Proxy Password–If applicable. 

DRTrack Timeout–Set timeout value in minutes. 
Branch–Use the drop down menu to select Branch name or add names (requires at least one). 
Default Branch–Select the Default Branch name from the drop down menu (entered in Branch). 
Profiles–Leave blank for all, or use the drop down menu to select (add Profile names, if used). 
Route Upload Version–Enter the number 5, or other number for older versions of DRTrack.  
Master Profiles–Leave blank or select from the drop down menu (add Profile names, if used). 
Shift–Leave blank or select from the drop down menu (add Shift info, if used). 
Account Master Upload Version–Select 1.0 or 2.0. 

Use LoadID from Stop File–Select TRUE or FALSE. 

Compression Method–Select none or Gzip. 
Manage Master Profile Routes–Leave blank or select from the drop down menu (add Profile names, if 
used). 
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Skip Empty Routes–Select TRUE or FALSE to skip empty routes on upload. 
 
To export a routing solution to DRTrack you will need to be in the routing mode. 

•​ With the routing solution open, click on DRTrack on the menu and then click Export to 
DRTrack. 

 

 
Figure 171 – Export to DRTrack 

 

•​ Click to add a check mark to select Skip Empty Routes and/or Overwrite Existing Entries and 
then click the Export button. 

•​ When the Export info box opens indicating a successful export, click on OK.  

•​ Click Yes or No to close the Route Files when the next info box opens. 

 

 
Figure 172 – Successful Export to DRTrack 
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11.2.​ Export an XML or Upload (UPL) File 
DirectRoute can export an XML File or Upload (UPL) File to relay order and route information directly to 
your ERP/WMS/OMS. Both files are created in simple text format and can easily be consumed by most 
applications.  
 
The primary difference between an XML File export and a UPL File export is that the XML File is a 
fixed-data field file, and it will contain all data fields available with no ability to limit the amount of data 
passed, whereas a UPL File can be customized to limit the fields passed by selecting only the information 
needed. The UPL File also requires the creation and use of a Format File (UPF), to determine which data 
fields will be relayed during the export. 

•​ XML File 

−​ Fixed-data fields; includes all available order, account, and route fields. 

−​ Cannot be customized to limit the type of data passed in the export. 

 

•​ UPL Upload File 

−​ Can customize to include only fields of data needed, and exclude unwanted data. 

−​ Can be created/saved in various file formats, i.e. UPL, xls, CSV, TXT, and XML. 

−​ Requires the use of a Format (UPF) File to determine which fields of info to include. 

 
When creating an XML or UPL File, you will first need to ensure that Preferences have been updated and 
set to specify upload and export options. 

•​ Select File > Preferences > Upload from the main menu. 
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Figure 173 – Upload Options 
 
The following options should be reviewed and selected as needed. 
 

Upload Consolidated–By default, the UPL File will list each order separately regardless of whether or 
not consolidate stops (Load tab) is chosen.  

•​ If Upload Consolidated = TRUE, the orders/stops will be passed in a consolidated format in 
the UPL File; this is most useful when you do not require each order to be listed separately. 

Upload Displayed Only–Set this option to TRUE to include only those routes that are displayed on the 
map (locked). If FALSE, the file will include all routes for that routing session. 

Upload Header Record–Places a header row at top of the UPL File, with the number of routed orders. 

Upload Starting Terminal–If TRUE, the starting terminal/distribution center will pass in the UPL File. 

Upload Ending Terminal–If TRUE, the ending terminal/distribution center will pass in the UPL File. 

Upload Date Format–Select the date format to be used, i.e. MM/DD/YYYY. 

Upload Day Format–Select how the day of the week should be displayed; (ex. Monday, Mo or Mon). 

Upload Format File (URP)–Enter the file name and path of the Format (URP) File that will be used; when 
updated here, the software will not ask for this during the upload process, it will only ask for the Upload 
File name. (Leave blank if using the XML Upload File option) 

Upload File Name–The default file name is RTUPLOAD, or use the drop-down arrow to select another 
name for the file (the file name can be changed after it is created). 

Upload File Path–Enter the location (Path) to save the UPL File, if different from the current DirectRoute 
Data folder location. 

Upload File Type–Choose the file type you would like produced (UPL, XML, TXT, CVS, or xls) 

Upload XML Version–Enter the XML version number (2 or 5). 

Upload Sequence–If TRUE, the UPL will display orders by route and stop sequence numerically, same 
as it is displayed in the Route Book. 

OBC Upload–Enables Onboard Computer System Upload File (OBC Upload File) format for PeopleNet, 
XATA, etc.  

OBC Folder Path–The path to the OBC File. 

OBC Upload File Name–OBC Upload File name. 

Upload Time Format–Select the time format to be used (ex. H:mm). 

V8 Compatible–TRUE or FALSE; enables backwards compatibility with DirectRoute Version 8. 

Display Arrival and Departure Time on Consolidated Order–When TRUE, will display the same 
arrival/departure date for each order on the same stop (consolidated order). 

Display Miles on Consolidated Order–When TRUE, will display the same miles for each individual 
order on the same stop (consolidated order). 

Display Unload Time on Consolidated Order–When TRUE, will display the same unload time for each 
individual order on the same stop (consolidated order). 

Ignore Terminal in XML Upload–When TRUE, will ignore the terminal, and only display orders.  

Display Drive and Work Time on Consolidation–When TRUE, will display Drive Time and Work Time 
on consolidated orders. 
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Abbreviate Rt Violation–When TRUE, will abbreviate all route violations. 

Display Total Distance on Consolidated Orders–When TRUE, will display the total distance on 
consolidated orders. 

 

After all options have been reviewed and/or selected, ensure the file names/paths have also been 
updated in File > Preferences > File Names/Paths. This information will normally pass automatically when 
entered under the Upload options, but it’s a good idea to check anyway. 
 

 
Figure 174 – Upload File Name/Path 

 

11.2.1.​ Create an XML Upload File 
An XML Upload File is created while in the routing mode, after the routing project has been completed 
and saved. The data fields passed in the file are fixed, and cannot be customized. 

•​ With the Route Book open, select File > Run Post Process from the menu.  
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Figure 175 – Run Post Process 
If you did not previously enter a file name/path in the Upload section of Preferences, you will be prompted 
to select a file name and path, and then click the Save button.  
 

 
Figure 176 – File/Upload 

 
When the file has been created successfully, an info box will appear with the file name and location of the 
saved file. If a previously produced upload file already exists, the info box that appears will ask if you want 
to overwrite the one that exists already. 
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Figure 177 – Overwrite Existing Upload File 
 

 
Figure 178 – XML File Created Successfully 
 
You can open and view the saved Export File at the path specified. The file is now ready to copy over to 
the ERP/WMS/OMS.  
 

 
Figure 179 – Sample XML File Sample 

 

11.2.2.​ Create a URP Format File 
The URP File is a text formatted file that lists the data fields that should be exported in the Upload File. 
Using a URP File enables customization of the output data that will be in your Export File; you get only 
the information you want, while excluding all other unnecessary data. 
 
The URP File requires a specific header line, with the data fields listed below it. Each data field parameter 
is separated by a comma with no spaces. List each field in the order in which you want it produced, the 
same order in which it will be passed to the ERP/WMS/OMS.  
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To create a customized URP File, it’s probably easiest to ask for a sample file and then edit that file to 
include/exclude the fields you want. However, you can create one from using Notepad or similar text 
program 

•​ Open a new file and type the header line (including brackets): [Detail Section]. 

•​ Open the URP Field Names Table and copy/paste each field you want, directly below the 
header line. 

•​ Add an equal sign (=) after each one, no space between. 

 
Figure 180 – Sample URP File 

 
After you’ve copied all of the fields you want, add the five parameters for each field. Each parameter 
should be separated by a comma with no spacing between. 

 

 

For example:  

[Detail Section] 

SFSEQ=1,2644,4,L,0 

SFNAME=1,2356,30,L,0 

SFADDRESS=1,1775,30,L,0 

SFCITY=1,1839,30,L,0 

RFARV_TIME=1,16,5,L,0 

RFDEPT_TIME=1,172,5,L,0 

 
Here is the same example, with a breakdown of the five parameters: 

URP Field Column# Position# # of characters Left/Right justified # of decimals 

SFSEQ= 1 2644 4 L 0 

SFNAME= 1 2356 2356 L 0 

SFADDRESS= 1 1775 30 L 0 

SFCITY= 1 1839 30 L 0 

RFARV_TIME= 1 16 5 L 0 
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RFDEPT_TIME= 1 172 5 L 0 

Figure 181 – URP Field Entry Format 
 

•​ Field names must be capitalized (all letters). 

•​ The first and second entries reflect the starting Column and Position of the data. 

•​ The third entry is the Number of Characters used for data in the field. 

•​ The fourth position is for Text Justification within the cell (L = Left, R = Right). 

•​ The last entry number is the Number of Decimals allowed to follow any given number in the 
field. 

 
Once all entries have been added, save the file as *.URP in the DirectRoute Data Folder and then update 
Preferences with the URP file name/path, Preference > File Names/Paths, and Preference > Upload.  
 
 

11.2.3.​ Create a UPL Upload File 
When creating a UPL file, you will first need to ensure that Preferences have been updated and set to 
specify upload options, and that you have created and saved an URP Upload Format File. Follow the 
directions for option entries in Section 11.2 and Section 11.2.2 to create a format file.  
 
To create the UPL Upload File,  

•​ With the Route Book open, select File > Run Post Process from the menu.  
 

 
Figure 182 – Run Post Process 
 
You may be asked if you want to upload displayed routes only (versus all routes in the Route Book) 
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Figure 183 – Upload Displayed Routes Only 
 
You should receive a notification box when the UPL has been created successfully. 
 

 
Figure 184 – UPL Created Successfully 
 
To view the newly created UPL File, navigate to the location where the file was saved.  
 
Below is a sample UPL File output. A few things to note: 

•​ Header information will not be passed in the upload information.  

•​ If there are ### in any field, there was an error in the processing. 

o​ Ensure a period has not been placed in the parameters, in the place of a comma. 

•​ If there are *** in the UPL, the fields are too small to hold the requested data. 

 

 
Figure 185 – Sample *.UPL Upload File  
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11.2.4.​ URP Field Names Table 
ROUTE FIELDS DESCRIPTION 

RFARV_DATE Arrival date at delivery location 
RFARV_DAY Arrival day at delivery location 
RFARV_TIME Arrival time at delivery location 
RFARVTM_WITH_TZ Arrival time at delivery locale w/Time Zone 
RFBREAKTM Break time for driver 

RFCUM_DRV_TM Cumulative drive time 

RFCUM_WRK_TM Cumulative work time on route 

RFCUMQTY001 Cumulative Quantity1 of Order 

RFCUMQTY002 Cumulative Quantity2 of Order 

RFCUMQTY003 Cumulative Quantity3 of Order 

RFCUMQTY004 Cumulative Quantity4 of Order 

RFCUMQTY005 Cumulative Quantity5 of Order 

RFCUMQTY006 Cumulative Quantity6 of Order 

RFCUMQTY007 Cumulative Quantity7 of Order 

RFCUMQTY008 Cumulative Quantity8 of Order 

RFCUMQTY009 Cumulative Quantity9 of Order 

RFCUMQTY010 Cumulative Quantity10 of Order 

RFDEPDAY Day of departure/dispatch day 

RFDEPT_DATE Route departure date 

RFDEPT_TIME Time of route departure 

RFDEPTTM_WITH_TZ Time of route departure with Time Zone 

RFDIST_TO_PREV_STOP Distance from previous stop 

RFINCR_COST Incremental cost of a stop. Calculates difference in miles, drvtm; 
if stop was added, applies mileage and hr cost  

RFLAYOVER_TM Overnight layover time within a route 

RFREMAINCAP001 Remaining Capacity1 

RFREMAINCAP002 Remaining Capacity2 

RFREMAINCAP003 Remaining Capacity3 

RFREMAINCAP004 Remaining Capacity4 
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ROUTE FIELDS DESCRIPTION 

RFREMAINCAP005 Remaining Capacity5 

RFREMAINCAP006 Remaining Capacity6 

RFREMAINCAP007 Remaining Capacity7 

RFREMAINCAP008 Remaining Capacity8 

RFREMAINCAP009 Remaining Capacity9 

RFREMAINCAP010 Remaining Capacity10 

RFSEQ_NO Sequence number of stop within a route 

RFTIME_TO_PREV_STOP Time to Previous Stop 

RFUNLOAD_TIME Unload Time 

RFWAIT_TM_AT_STOP Wait time at stop 

RFWINDOW_VIOLATION Window Violation 

RT_NUM Route Number 

RT%_ABSCAP001_USED Absolute value of Qty1 for each stop on route divided by Trk 
capacity * 2 (pickup, delivery) 

RT%_ABSCAP002_USED Absolute value of Qty2 for each stop on route divided by Trk 
capacity * 2  

RT%_ABSCAP003_USED Absolute value of Qty3 for each stop on route divided by Trk 
capacity * 2  

RT%_ABSCAP004_USED Absolute value of Qty4 for each stop on route divided by Trk 
capacity * 2 

RT%_ABSCAP005_USED Absolute value of Qty5 for each stop on route divided by Trk 
capacity * 2 

RT%_ABSCAP006_USED Absolute value of Qty6 for each stop on route divided by Trk 
capacity * 2  

RT%_ABSCAP007_USED Absolute value of Qty7 for each stop on route divided by Trk 
capacity * 2  

RT%_ABSCAP008_USED Absolute value of Qty8 for each stop on route divided by Trk 
capacity * 2  

RT%_ABSCAP009_USED Absolute value of Qty9 for each stop on route divided by Trk 
capacity * 2  

RT%_ABSCAP010_USED Absolute value of Qty10 for each stop on route divided by Trk 
capacity * 2  
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ROUTE FIELDS DESCRIPTION 

RT%_CAP001_USED Percent of cap1 used on route (10 cap fields avail) 

RT%_CAP002_USED Percent of cap2 used on route  

RT%_CAP003_USED Percent of cap3 used on route  

RT%_CAP004_USED Percent of cap4 used on route  

RT%_CAP005_USED Percent of cap5 used on route  

RT%_CAP006_USED Percent of cap6 used on route  

RT%_CAP007_USED Percent of cap7 used on route  

RT%_CAP008_USED Percent of cap8 used on route  

RT%_CAP009_USED Percent of cap9 used on route ( 

RT%_CAP010_USED Percent of cap10 used on route  

RTCAP001_USED Route capacity1 used (10 cap fields avail) 

RTCAP002_USED Route capacity2 used  

RTCAP003_USED Route capacity3 used  

RTCAP004_USED Route capacity4 used  

RTCAP005_USED Route capacity5 used  

RTCAP006_USED Route capacity6 used  

RTCAP007_USED Route capacity7 used  

RTCAP008_USED Route capacity8 used  

RTCAP009_USED Route capacity9 used  

RTCAP010_USED Route capacity10 used  

RTBACKHAUL001 Backhaul1 

RTBACKHAUL002 Backhaul2 

RTBACKHAUL003 Backhaul3 

RTBACKHAUL004 Backhaul4 

RTBACKHAUL005 Backhaul5 

RTBACKHAUL006 Backhaul6 

RTBACKHAUL007 Backhaul7 

RTBACKHAUL008 Backhaul8 
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ROUTE FIELDS DESCRIPTION 

RTBACKHAUL009 Backhaul9 

RTBACKHAUL010 Backhaul10 

RTCOSTPERSTOP Cost per Stop 

RTDEL001 Total value of Qty1 delivered (Non negative quanties and 
excludes backhauls) 

RTDEL002 Total value of Qty2 delivered 

RTDEL003 Total value of Qty3 delivered  

RTDEL004 Total value of Qty4 delivered  

RTDEL005 Total value of Qty5 delivered  

RTDEL006 Total value of Qty6 delivered  

RTDEL007 Total value of Qty7 delivered  

RTDEL008 Total value of Qty8 delivered  

RTDEL009 Total value of Qty9 delivered  

RTDEL010 Total value of Qty10 delivered.  

RTCOSTPERQTY001 Cost per Quantity1 

RTCOSTPERQTY002 Cost per Quantity2 

RTCOSTPERQTY003 Cost per Quantity3 

RTCOSTPERQTY004 Cost per Quantity4 

RTCOSTPERQTY005 Cost per Quantity5 

RTCOSTPERQTY006 Cost per Quantity6 

RTCOSTPERQTY007 Cost per Quantity7 

RTCOSTPERQTY008 Cost per Quantity8 

RTCOSTPERQTY009 Cost per Quantity9 

RTCOSTPERQTY010 Cost per Quantity10 

RTEARLIESTLATEDATE Shows the critical latest delivery date when Earliest/Latest Date 
is used. 

RTENDDATE End date of route 

RTENDDAY End day of route 

RTENDTIME Time route ends 
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ROUTE FIELDS DESCRIPTION 

RTSTARTDATE Date route starts 

RTSTART_DAY Day route starts 

RTSTARTTIME Time route starts 

RTFARTHESTSTOP Distance to the farthest stop on the route 

RTJULIANPLUSRT Generate rt # for PeopleNet day of year +Rt# i.e. 050012 is rt 12 
on the 50th day of the year 

RTNONSTEMDIST Non-Stem distance 

RTPENALTYCOST Penalty Cost 

RTPICKUP001 Total value of Qty1 delivered (shown as negative quantities) 

RTPICKUP002 Total value of Qty2 delivered  

RTPICKUP003 Total value of Qty3 delivered  

RTPICKUP004 Total value of Qty4 delivered  

RTPICKUP005 Total value of Qty5 delivered  

RTPICKUP006 Total value of Qty6 delivered  

RTPICKUP007 Total value of Qty7 delivered  

RTPICKUP008 Total value of Qty8 delivered  

RTPICKUP009 Total value of Qty9 delivered  

RTPICKUP010 Total value of Qty10 delivered  

RTQTYPERHR001 Quantity1 per hour 

RTQTYPERHR002 Quantity2 per hour 

RTQTYPERHR003 Quantity3 per hour 

RTQTYPERHR004 Quantity4 per hour 

RTQTYPERHR005 Quantity5 per hour 

RTQTYPERHR006 Quantity6 per hour 

RTQTYPERHR007 Quantity7 per hour 

RTQTYPERHR008 Quantity8 per hour 

RTQTYPERHR009 Quantity9 per hour 

RTQTYPERHR010 Quantity10 per hour 

RTQTYPERMI001 Quantity1 per mile 
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ROUTE FIELDS DESCRIPTION 

RTQTYPERMI002 Quantity2 per mile 

RTQTYPERMI003 Quantity3 per mile 

RTQTYPERMI004 Quantity4 per mile 

RTQTYPERMI005 Quantity5 per mile 

RTQTYPERMI006 Quantity6 per mile 

RTQTYPERMI007 Quantity7 per mile 

RTQTYPERMI008 Quantity8 per mile 

RTQTYPERMI009 Quantity9 per mile 

RTQTYPERMI010 Quantity10 per mile 

RTSTEMDIST Route stem distance 

RTSTOPSPERHR Stops per hour on route 

RTSTOPSPERMI Stops per mile on route 

RTTOAT_UNLD_TM Route total unload time 

RTTOT_DAYS Total number of days on a route 

RTTOT_DIST Total distance of a route 

RTTOT_DROPCOST Total drop cost of a route 

RTTOT_ELAPSED_TIME Total elapsed time of a route 

RTTOT_FIXEDCOST Total fixed cost of a route 

RTTOT_HRCOST Total hourly pay cost of route 

RTTOT_LAYOVERCOST Total cost of layovers on a route 

RTTOT_MICOST Total mileage cost of a route 

RTTOT_OTCOST Total overtime cost of a route 

RTTOT_PREPOST Total pre and post time for a route 

RTTOT_UNITCOST Total unit cost on a route 

RTTOT_UNLDHRCOST Total unload hour cost on a route 

RTTOT_WAITHRCOST Total wait hour cost of a route 

RTTOTAL_COST Total cost of a route 

RTTOTAL_DRV_TM Total drive time 
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ROUTE FIELDS DESCRIPTION 

RTTOTAL_STOPS Total stops serviced 

RTTOTAL_WAIT_TM Total wait time on a route 

RTTOTAL_WRK_TM Total work time on a route 

RTVIOLATIONSYN Violations yes or no 

RTVIOLATIONSFULL Violations (equip/capacity) on a route-Full 

RTVIOLATIONSBRIEF Violations (equip/capacity) on a route-Brief 

RFEMPTYMILES Empty Miles 

RTTOTAL_HOURS_PERROUTEDAY Total hours per route day 

RTTOT_LAYOVERTIME Total layover time of a route 

RTTOTAL_MILES_PERROUTEDAY Total miles per route day 

RTTOT_LAYOVERS Total no of layovers on a route 

RTTOLLCOST Toll cost per route 

RTQTY001 Total Qty1 per route 

RTQTY002 Total Qty2 per route 

RTMILESPERQTY001 Route miles per QTY1 

RTMILESPERQTY002 Route miles per QTY2 

Stop Fields Description of Field Info 

SFADDRESS Address of stop 

SFADDRESS2 Extra address information 

SFAMADJ AM Rush Hour Speed Adjustment 

RFBUFFERUSED Total untilized buffer time 

SFCITY City the stop is located in 

SFCOLOR Color of stop displayed on the map 

SFCONTACT Contact name for stop 

SFOPEN1 Earliest time for 1st delivery Time Window 

SFCLOSE1 Latest time for 1st delivery Time Window 

SFPATTERN1 Avail Del Days for first set of Time Windows 

SFOPEN2 Earliest time for 2nd delivery Time Window 
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ROUTE FIELDS DESCRIPTION 

SFCLOSE2 Latest time for 2nd delivery Time Window 

SFPATTERN2 Avail Del Days for 2nd set of Time Windows 

SFDELQTY001 Quantity1 delivered to stop 

SFDELQTY002 Quantity2 delivered to stop 

SFDELQTY003 Quantity3 delivered to stop 

SFDELQTY004 Quantity4 delivered to stop 

SFDELQTY005 Quantity5 delivered to stop 

SFDELQTY006 Quantity6 delivered to stop 

SFDELQTY007 Quantity7 delivered to stop 

SFDELQTY008 Quantity8 delivered to stop 

SFDELQTY009 Quantity9 delivered to stop 

SFDELQTY010 Quantity10 delivered to stop 

SFEQCODE Equipment code 

SFFIXEDTIME Fixed time for stop 

SFEARLIESTDATE EarliestDate for stop 

SFID1 First Identifier for Customer/Acct (Account#) 

SFID2 Second Identifier for Customer/Acct (Order#) 

SFID3 Third Identifier for Customer/Acct (LineItem) 

SFLATITUDE Latitude coordinates of stop 

SFLONGITUDE Longitude coordinates of stop 

SFLATESTDATE LatestDate 

SFNAME Customer name 

SFOUTPFROUTECOST Out of Route cost for Stop 

SFPHONE Customer phone number 

RFPENALTYCOST Cost incurred for utilizing Early/Late Buffer  

SFPICKUPQTY001 Pickup quantity1 (negative number) 

SFPICKUPQTY002 Pickup quantity2 (negative number) 

SFPICKUPQTY003 Pickup quantity3 (negative number) 
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ROUTE FIELDS DESCRIPTION 

SFPICKUPQTY004 Pickup quantity4 (negative number) 

SFPICKUPQTY005 Pickup quantity5 (negative number) 

SFPICKUPQTY006 Pickup quantity6 (negative number) 

SFPICKUPQTY007 Pickup quantity7 (negative number) 

SFPICKUPQTY008 Pickup quantity8 (negative number) 

SFPICKUPQTY009 Pickup quantity9 (negative number) 

SFPICKUPQTY010 Pickup quantity10 (negative number) 

SFQTY001 Quantity1 of order 

SFQTY002 Quantity2 of order 

SFQTY003 Quantity3 of order 

SFQTY004 Quantity4 of order 

SFQTY005 Quantity5 of order 

SFQTY006 Quantity6 of order 

SFQTY007 Quantity7 of order 

SFQTY008 Quantity8 of order 

SFQTY009 Quantity9 of order 

SFQTY010 Quantity10 of order 

SFROW Row # in the spreadsheet for the stop 

SFRT Route number 

SFRTONLY Displays only the Rt#, not Rt and Leg 

SFSELECTED Stop selected 

SFSEQ Sequence number of stop 

SFSIZE Size restriction 

SFSTATE State where stop is located 

SFSYMBOL Symbol assigned to the Stop 

SFUNLDRATE001 Unload rate1 

SFUNLDRATE002 Unload rate2 

SFUNLDRATE003 Unload rate3 
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ROUTE FIELDS DESCRIPTION 

SFUNLDRATE004 Unload rate4 

SFUNLDRATE005 Unload rate5 

SFUNLDRATE006 Unload rate6 

SFUNLDRATE007 Unload rate7 

SFUNLDRATE008 Unload rate8 

SFUNLDRATE009 Unload rate9 

SFUNLDRATE010 Unload rate10 

SFUSERFLD001 Stop File user field1 (20 fields available) 

SFUSERFLD002 Stop File user field2  

SFUSERFLD003 Stop File user field3  

SFUSERFLD004 Stop File user field4  

SFUSERFLD005 Stop File user field5  

SFUSERFLD006 Stop File user field6  

SFUSERFLD007 Stop File user field7  

SFUSERFLD008 Stop File user field8  

SFUSERFLD009 Stop File user field9  

SFUSERFLD010 Stop File user field10 

SFUSERFLD011 Stop File user field11  

SFUSERFLD012 Stop File user field12  

SFUSERFLD013 Stop File user field13  

SFUSERFLD014 Stop File user field14 

SFUSERFLD015 Stop File user field15  

SFUSERFLD016 Stop File user field16  

SFUSERFLD017 Stop File user field17  

SFUSERFLD018 Stop File user field18  

SFUSERFLD019 Stop File user field19  

SFUSERFLD020 Stop File user field20  

SFZIP Zip code where stop is located 
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ROUTE FIELDS DESCRIPTION 

SFZONE user defined zone of stop 

SPDISTTODEPOT dist from stop to depot 

SPDISTTODEPOTSUM sum of distance from stops to depot 

SFDAYSBETWEENROUTES Days between routes 

SFFREQUENCY Frequency for stop 

SFGEORESULT Geocode results 

SFLEG Leg number for stop 

SFLTLCOST LTL cost for the stop 

SFMAXSPLITS Max number of splits allowed per stop 

SFAMSTART Specifies start time of AM rush hour  

SFAMEND Specifies end time of AM rush hour  

SFPMSTART Specifies start time of PM rush hour  

SFPMEND Specifies end time of PM rush hour  

SFPMADJ Amount to adjust PM drive time 

SFAMADJ Amount to adjust AM drive time 

RFTOLLCOST Cost of toll for a stop 

TW_GRAPH Time window graph 

RFCAPUSED001 Capacity1 used per stop (10 cap fields avail) 

RFCAPUSED002 Capacity2 used per stop  

RFCAPUSED003 Capacity3 used per stop  

RFCAPUSED004 Capacity4 used per stop  

RFCAPUSED005 Capacity5 used per stop  

RFCAPUSED006 Capacity6 used per stop  

RFCAPUSED007 Capacity7 used per stop  

RFCAPUSED008 Capacity8 used per stop  

RFCAPUSED009 Capacity9 used per stop  

RFCAPUSED010 Capacity10 used per stop  

Truck Fields Description of Field Info 

©2026 Trimble Maps​ 211​ ​  Mar -26 



DirectRoute User Guide​ ​ 26.1 

 

ROUTE FIELDS DESCRIPTION 

TFCAP001 Vehicle capacity1 

TFCAP002 Vehicle capacity2 

TFCAP003 Vehicle capacity3 

TFCAP004 Vehicle capacity4 

TFCAP005 Vehicle capacity5 

TFCAP006 Vehicle capacity6 

TFCAP007 Vehicle capacity7 

TFCAP008 Vehicle capacity8 

TFCAP009 Vehicle capacity9 

TFCAP010 Vehicle capacity10 

TFDROPCOST Drop Cost 

TFEARSTART Earliest time vehicle can be dispatched 

TFEDATE Earliest date vehicle may be dispatched 

TFFIXEDCOST Fixed cost for operating vehicle 

TFHRCOST Cost per hour to operate the vehicle 

TFLATFINISH Latest time vehicle can finish the route 

TFLAYOVERCOST Cost per layover of vehicle 

TFLDATE Latest date vehicle may be dispatched 

TFLOCK Lock route 

TFMAXDRIVETM Maximum drive time for the vehicle/driver 

TFMAXLAYOVER Maximum layover allowed 

TFMAXWORKTM Maximum work time for vehicle/driver 

TFMICOST Cost per mile to operate the vehicle 

TFMINLAYOVER Minimum layover required 

TFOTCOST Over time cost 

TFSPEQ Special equipment identifier (corresponds to equipment code in 
Stop File) 

TFSTATUS Vehicle utilized (Y or N) 

TFTRKID Unique identifier for vehicle 
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ROUTE FIELDS DESCRIPTION 

TFUNITCOST Cost per unit on vehicle 

TFUSERFLD001 user defined field1 

TFUSERFLD002 user defined field2 

TFUSERFLD003 user defined field3 

TFUSERFLD004 user defined field4 

TFUSERFLD005 user defined field5 

TFUSERFLD006 user defined field6 

TFUSERFLD007 user defined field7 

TFUSERFLD008 user defined field8 

TFUSERFLD009 user defined field9 

TFUSERFLD010 user defined field10 

TFUNLDHRCOST Unload hour cost 

TFWAITHRCOST Wait time cost per hour 

TFBREAKTM Break time for driver 

TRDIST Total distance driven (all routes) 

TRDROPCOST Total drop cost 

TRDRV_TM Total drive time 

TRELAPSED_TIME Total elapsed time 

TRFIXEDCOST Total fixed cost 

TRHRCOST Total hourly pay cost 

TRLAYOVERCOST Total layover cost 

TRMICOST Total mileage cost 

TROTCOST Total over time cost 

TRSTOPS Total stops serviced 

TRTOTCOST Total overall cost 

TRTOTTM Total time used 

TRUNITCOST Total unit costs 

TRUNLD_TM Total unload time 
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ROUTE FIELDS DESCRIPTION 

TRUNLDHRCOST Total unload hour cost 

TRWAIT_TM Total wait time 

TRWAITHRCOST Total wait time cost 

TRWRK_TM Total work time 

TFCITY City the truck is located in 

TFLATITUDE Truck latitude 

TFLONGITUDE Truck longitude 

TFPRETRIP Pre Trip 

TFPOSTTRIP Post trip 

TFUNLDPERF Unload performance 

ResourcePro Fields Description of Field Info 

RPDRIVER Driver assigend to route in ResourcePro 

RPTRUCK Truck assigned in ResourcePro 

RPTRAILER Trailer assigned in ResourcePro 

RPSTARTINGDRIVETIME Drive Time Start in ResourcePro 

RPSTARTINGWORKTIME Work Time Start in ResourcePro 

RPWORKHOURSBEFORE Work Hours Before Next Route (Hours Between Routes) 

      Figure 186 – URP Field Names Table 
 

12. Custom Road Edits 
PC*Miler provides a number of ways to customize routing, including avoid and favor preference 
designations, that can be saved and used while generating routes and/or Distance Files in DirectRoute. 
To use these road edits in DirectRoute, the saved file (flattened_af.dat) can be copied from PC*Miler to 
the user’s DirectRoute Data folder (ex. Program Files (x86)\TMW Systems Inc.\Appian\ALK\Data\File 
Name), where DirectRoute can access it. 
 

Additionally, if PC*Miler Tolls was purchased with PC*Miler, you can generate accurate, up-to-date toll 
costs for U.S. and Canadian lanes with these costs integrated directly into the routing database and 
reported turn-by-turn per trip. Columns for toll costs appear in the PC*Miler Detailed Route Report, the 
State/Country Summary Report, and the Comparison Report, and tolls can be reported in either U.S. or 
Canadian dollars–using the current conversion rate. ​
 
For more information on using PC*Miler customized road edits, visit the PC*Miler Solutions web page, 
PC*Miler User Guide. PC*Miler is a registered trademark of Trimble MAPS. 
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13. DirectRoute Use Cases 
This section includes examples of ways you can use DirectRoute to enhance your fleet’s operations. 
 

Should your fleet deliver an order or hire someone else to deliver 
it? 
 
When you have a single item or a small order you need to deliver to a customer, DirectRoute can help 
you decide whether it is more cost effective to deliver it with your private fleet or ship it via LTL/third party.  
 
To calculate and start to understand the cheapest mode of transport for a given delivery: 
 
Step 1: Create an LTLCost field for your stop files 
In order for DirectRoute to decide on the cost effectiveness of using an LTL/third party carrier, you need to 
provide the algorithm with the cost for a particular order to be shipped in this manner. To do this, a new 
field titled LTLCost needs to be added to Preferences and to your Stop files. 

1.​ Close any open files in DirectRoute.  
2.​ Go to File > Preferences > Configuration > Stop User Fields. 
3.​ Click the three dots at the end of the row. The StopUserFieldType Collection Editor dialog 

opens.  

Figure 187 - Stop User Field Configuration 

4.​ Select Add to add a new custom field. 
5.​ In the Name field, enter LTLCost, with no spaces. This feature will not work if spaces are 

added. 
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Figure 188 - Stop User Field Type Collection Editor 

6.​ Set the Data Type field to Numeric. 
7.​ Select Close to finish, and select OK to exit the Preferences dialog. 
8.​ LTLCost is added among the user fields when you create a new Stop file.

 

Figure 189 - LTL Cost in a new Stop file 
 
Other Preferences 
In Preferences, you must also tell DirectRoute to not Optimize Stops After Loading. (After DirectRoute 
builds the routes and makes modal decisions, you can manually optimize the private fleet assets, if 
necessary.) 

1.​ Go to File > Preferences > Routing > Algorithm Settings. 
2.​ Be sure Optimize Stops After Loading is set to False, which is the default value. 
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Figure 190 - Optimized Stops after Loading 

 
Step 2: Populate LTLCost 
Once you have added the LTLCost field to your Stop file, it must be manually populated with values. 
LTLCost is the flat rate in dollars for delivering an item via an LTL/third-party service.  
 
When DirectRoute builds a route, it compares the LTLCost value to your fleet's cost to deliver that item. 
Your cost is calculated and based on a number of factors, including the MiCost and HrCost fields in your 
Stop file. 
 
Step 3: Build a route 
Build a route as you normally would but with a Stop file that includes the LTLCost field. After the routes 
are built, DirectRoute returns an info box that shows the total number of orders loaded out of the total 
number of orders. 

 

Figure 200 - Number of Orders loaded 

Step 4: View and compare costs in the Route Book 
You can view the list of unloaded orders in the Route Book > Unloaded Stops tab. Right click on one of 
the unloaded orders and select View Reason to see why the order was not loaded on a truck. 
 

 

Figure 201 - Route Book 1 View Reason 

 
If you see LTLCost under the Violations row, it means DirectRoute has determined it is cheaper to ship 
that order via LTL. Scroll to the right in the Unload Stop Reason dialog if you want to view the LTLCost 
for that stop. 
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Figure 202 - Route Book 1 LTL Cost Violations 

 
Notes on LTLCost 
LTLCost is currently only viewable in the Unloaded Stops tab of the Route Book. You cannot drag to 
add it to the Routes tab in the Route Book as you can drag and add other Stop User Fields.  
 

Appendix A: DOT Hours of Service 
The following is a summary of the U.S. Department of Transportation Hours of Service (HOS) 
Regulations. Most drivers must follow the HOS Regulations if they drive a commercial motor vehicle, or 
CMV.  
 
In general, a CMV is a vehicle used as part of a business, is involved in interstate commerce, and fits any 
of these descriptions: 

•​ Weighs 10,001 lbs. or more. 
•​ Has a gross vehicle weight rating or gross combination weight rating of 10,001 lbs. or more. 
•​ Is designed or used to transport 16+ passengers (including driver) not for compensation. 
•​ Is designed or used to transport 9+ passengers (including driver) for compensation. 

 
A vehicle that is involved in Interstate or intrastate commerce and is transporting hazardous materials in a 
quantity requiring placards is also considered a CMV. 
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Hours of Service of Drivers Final Rule 
The Hours-of-Service Rules were published in the Federal Register on December 27, 2011. The 
effective date of the Final Rule was February 27, 2012, and the compliance date of selected provisions 
was July 1, 2013.  
 
What is the 34-hour restart rule? 
Per the HOS rule, commercial motor vehicle drivers can reset their 60-hour or 70-hour clocks. In some 
circumstances, this enables drivers to get back on the road quickly. Drivers can take advantage of the rule 
by taking at least 34 consecutive hours in the sleeper berth, off-duty, or by using a combination of both.  
 
Enforcement of the 34-hour rule was suspended by enactment of the Consolidated and Further 
Continuing Appropriations Act of 2015 on 16 December 2014 but was later restored.  
 
Only that portion of the rule that called for two off-duty periods of 1:00am to 5:00am in Section 395.3(C) of 
the agency’s Hours-of-Service Rules will not be enforced, nor will the Once-Per-Week limit on use of the 
restart in 395.3(D). References: FMCSA Summary of Hours of Service Regulations, and FMCSA 
Hours of Service Final Rule for Truck Drivers 
 
Summary of HOS Regulations 
The following table summarizes the HOS regulations for property-carrying and passenger-carrying 
drivers. Reference: 
https://www.fmcsa.dot.gov/regulations/hours-service/summary-hours-service-regulations) 
 

Summary of Hours of Service Regulations  

PROPERTY CARRYING DRIVERS PASSENGER CARRYING DRIVERS 

11 Hour Driving Limit–May drive a maximum of 11 hours after 
10 consecutive hours off duty. 

10 Hour Driving Limit–May drive a maximum of 
10 hours after 8 consecutive hours off duty. 

14 Hour Limit–May not drive beyond the 14th consecutive hour 
after coming on duty, following 10 consecutive hours off duty. 
Off-duty time does not extend the 14-hour period. 

15 Hour Limit–May not drive after having been on 
duty for 15 hours, following 8 consecutive hours 
off duty. Off-duty time is not included in the 
15-hour period. 

Rest Breaks–May drive only if 8 hours or less have passed 
since the end of the driver's last off-duty or sleeper berth 
period of at least 30 minutes. Does not apply to drivers using 
either of the short-haul exceptions in 395.1(e). [49 CFR 397.5 
mandatory “in attendance” time may be included in break if no 
other duties performed] 

60/70 Hour Limit–May not drive after 60/70 hours 
on duty in 7/8 consecutive days. 

60/70 Hour Limit–May not drive after 60/70 hours on duty in 
7/8 consecutive days. A driver may restart a 7/8 consecutive 
day period after taking 34 or more consecutive hours off duty. 

Sleeper Berth Provision–Drivers using a sleeper 
berth must take at least 8 hours in the sleeper 
berth, and may split the sleeper berth time into 
two periods provided neither is less than 2 hours. 

Must include two periods from 1 a.m. to 5 a.m. home terminal 
time, and may only be used once per week, or 168 hours,  
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measured from the beginning of the previous restart. 
Suspended 
 
NOTICE: The Consolidated and Further Continuing 
Appropriations Act of 2015 was enacted on Dec 16, 2014, 
suspending enforcement of new requirements for use of the 
34-hour restart, pending a study. Based on the findings from 
the study, the 34-hour restart rule in operational effect on 
Jun 30, 2013, is restored to full force and effect.  
 
The requirement for two off-duty periods of 1:00am to 5:00am 
in Section 395.3(C) of the agency’s Hours-of-Service Rules will 
not be enforced, nor will the Once-Per-Week limit on use of the 
restart in 395.3(D). 

Sleeper Berth Provision–Drivers using the sleeper berth 
provision must take at least 8 consecutive hours in the sleeper 
berth, plus a separate 2 consecutive hours either in the 
sleeper berth, off duty, or any combination of the two. 

 

Figure 203 – DOT HOS Rules  

Appendix B: Working With Spreadsheets 
DirectRoute enables use of several common spreadsheet and keyboard shortcuts, as well as various 
mouse/keystroke shortcuts for accessing various menu and map options.  
 
DirectRoute uses a spreadsheet format to create and use the various Route Files needed for routing 
projects. These files (spreadsheets) function much the same as any other spreadsheet would, using 
many of the same shortcuts, functions and behaviors, and most of the Route Files can also be opened, 
viewed and/or modified independent of DirectRoute using a spreadsheet, workbook or XML sheet (*.xls, 
*.xlsx, *.XML, etc.).  
 
The DirectRoute files that are accessible in spreadsheet format include: 

•​ Route Files (.RTE, .ROUTE). 
•​ Stop Files (.STOP, .xls, .STP). 
•​ Truck Files (.TRUCK). 
•​ Distance Files (.dist). 
•​ Route Book. 

 
The DirectRoute Keyboard Shortcuts Table lists common shortcuts that can be used while working 
within the DirectRoute program (and files), and the Mouse Enabled Shortcuts Table lists common 
shortcuts created using the mouse and various keystrokes. 
 
While most of these shortcuts may be familiar to those who work with spreadsheets on a regular basis, 
some users may not be as familiar with them. 
 
Spreadsheet Queries 
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Selecting records in DirectRoute is a way of performing queries on your data based on criteria you 
specify. For example, you may want to select all customers on one route to calculate the quantity 
delivered or you may want to find all customers receiving more than 50 cases.  
 
Inside the spreadsheet, DirectRoute attaches a column titled Selected. This column contains a TRUE or 
FALSE data element that populates upon selection of the records to indicate if the record is/is not 
selected. 
 
Records can be selected for identification/view on the map from this column. 

•​ In the spreadsheet column Selected, type TRUE in each record to select. 
•​ Type FALSE in the same column of any record to deselect/not select. 

 
Left click on the Map tab and all the selected records will have a blue box displayed around their symbol. 
 
To select specific records by spreadsheet column while viewing the map, select Map > Point Field 
Displayed from the menu. 

•​ Choose the field (column) to display. 
•​ Choose the display options. 
•​ Select OK when complete. 

 
Figure 204 – Select Records with Point Field Displayed 
 
To select specific records by value contained in a spreadsheet column, select Map > Tools > Select from 
the menu. 

•​ Select the columns you want to use. 
•​ Enter the selection criteria or combination of selection criteria. 

o​ Greater Than ( > =).  
o​ Less Than (<=).  
o​ Contains. 

Tip: The Greater Than and Less Than fields can contain either alpha (text) or numeric (number) data. The 
Contains field can only read text data. 
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Figure 205 – Select Records in Spreadsheet 

 
•​ From the Options drop down arrow, choose one of the selection methods. 
•​ Choose the Select button and then choose Select All, Unselect All, or Reverse. 

 
The number of selected records is displayed in the upper left corner of the dialog box. 

•​ On the map, the selected records will be encircled by a box around their symbol. 
•​ On the spreadsheet, TRUE will be listed in the selected column. 

 
Spreadsheet Statistics 
DirectRoute provides a statistics spreadsheet that will allow you to see relative statistics about numeric 
data columns within a spreadsheet. This can be particularly handy if you need to see volume totals such 
as quantities delivered and average quantity for a selected route or geographic area.  
 
The statistics spreadsheet automatically shows quantity statistics for items such as: 

•​ All records.  
•​ Selected records. 
•​ Unselected records.  
•​ Records inside and outside of a selected boundary. 

 
While the statistics worksheet in DirectRoute cannot be saved as an independent file, the data can be 
copied and pasted into a spreadsheet outside of DirectRoute, and then saved.  
 
View Statistics for All Records 

•​ Open any of the Route Files spreadsheets (Stop File, Truck File, etc.). 
•​ Select Edit > Statistics from the menu, or press the F8 key. 

 
Statistics for Selected Records  

•​ Open the spreadsheet and select the records. 
o​ Type TRUE in the spreadsheet column Selected, or 
o​ Use the Lasso Tool to select records. 

•​ Select Edit > Statistics from the menu, or press the F8 key. 
 
The results will be displayed in separate columns (All, Selected, and Unselected). 
 
Statistics Inside/Outside a Boundary 

•​ Open the spreadsheet (Stop File or Truck File). 
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•​ Select the map tab to view the stops on the map. 

•​ Select the icon to activate the Drawing Tools and then select the icon to activate the 
Polygon Tool. 

•​ Draw the boundary around the stops on the map to select the records. 
•​ Position the cursor over the drawn boundary and then click on it. 
•​ Select Edit > Statistics from the menu, or press the F8 key. 

 
The statistics info box will include two additional columns, In Boundary and Out Boundary, with the 
applicable statistical results displayed in each. 
 

 
Figure 206 – Spreadsheet Statistics 

 

 
Figure 207 – Statistics Inside/Outside a Boundary  
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Appendix C: Printing From DirectRoute 
DirectRoute enables the printing of several files used in the routing process, in addition to reports, 
directions, and map pages. The following files can be printed while working in DirectRoute.   

•​ Route File. 

•​ Route Book Summary Page. 

•​ Route Book Route Pages. 

•​ Driving Directions. 

•​ Truck File. 

•​ Stop File. 

•​ Maps. 

 
Printing Route Book Pages (Route Files)  
To print a Route File, or portions of a Route File (Summary and/or Route pages): 

•​ Open the Route File. 

•​ From the DirectRoute menu, select File > Print > Route Book, or  

•​ Select the Print icon from the menu. 

•​ When the ‘Print Route Book’ info box opens, make the appropriate selections in both the 
Options and Layout tabs then select the OK button to print. 

 
Print Options and Layout Tabs 

•​ Print To–Select Paper, File (Text, Excel, or HTML), or Crystal Reports (if installed). 

•​ Print Range–All routes and stops, or selected routes and/or stops. 

•​ Show Summary–Summary Page of the Route Book (composite list of routes). 

•​ Show Stats–The detailed report appears in gray above the detailed stops (Route Book). 

•​ Show Detail–Detailed list of each route and its stops (if directions were generated, select this 
option to print them). 

•​ Show Unloaded–Will print unloaded stops/routes. 

•​ Show Input Files–Print files used to generate the route in the report. 

•​ Skip Empty Routes–Will skip unloaded routes. 

•​ Print Route Maps–Only available if printing to paper. 

•​ Print Displayed Routes Only–Print only the routes displayed on the screen. 

•​ Display Route Number–If not selected, the Route/Leg number on the Route Page will print. 

•​ Number of Copies–Enter the number desired. 

•​ Print Landscape–Check if desired. 
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Figure 210 – Print Route Book  

 

•​ Scale–Select Scale settings or leave at default settings (100%). 

•​ Margin–Select Margin settings or leave at default settings. 

•​ Header/Footer–Edit to customize the header/footer (Route pages and spreadsheets) or 
leave at default settings. 

•​ &D (prints date). 

•​ &T (prints time). 

•​ &L (left align). 

•​ &C (center alignment). 

•​ &R (right align). 

•​ &P (prints page number). 

•​ &N (prints total number of pages in document). 

•​ &B (prints text in bold font). 

•​ &I (prints text in italics). 

•​ &U (underlines the text). 

•​ &S (strike out the text). 

•​ &"font name" (allows you to select font). 

•​ &NN (allows you to select font size, must be two digits). 
 
Printing Maps 
To print a map, with or without any Route Book Files opened, the map window must be the active window. 
The map that is displayed in the window will be the map that is printed.  
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If the Route Book is open and an active route is displayed on the map, this will be the view that prints.  

•​ Select File > Print > Map from the menu or select the Print icon from the menu. 

•​ Type desired text in Line 1/Line 2 to add a header to the map (actual text, not header 
commands). 

•​ Check Landscape or uncheck to print Portrait format. 

•​ To change current printer settings, select the Set Up button. 

•​ Select OK to print. 

 
  Figure 211 – Printing Captions on Maps 
 
Printing Spreadsheet Records 
To print records from one of the spreadsheets (Stop File, Truck File, etc.), the spreadsheet file must be 
open.  
 

 
Figure 212 – Print Page Setup 

 

•​ Select File > Print > Stop File (or Truck File) from the menu or select the Print icon from the 
menu. 

•​ Select the print range; select specific columns or Select All to print all columns. 

•​ Designate specific rows to print; default will list From/To all rows. 

•​ Change the Header/Footer command if desired or leave at default settings. 
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•​ Choose Printing Format; default is Portrait or select Landscape. 

•​ Select Print Options (Grid Lines, Headings, Horizontal/Vertical centering). 

•​ Select Scale Options or leave at default settings. 

•​ Select Margin Options or leave at default settings. 

•​ Select OK to print. 
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